Update to v243-rc2
This commit is contained in:
parent
07f0cd95cf
commit
d7b2d46533
@ -1,33 +0,0 @@
|
|||||||
From 4c071d7f2a269f1c7b25402a272f90701b8a070c Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Mon, 5 Aug 2019 15:02:13 +0200
|
|
||||||
Subject: [PATCH] meson: create (empty) /etc/systemd/system during installation
|
|
||||||
|
|
||||||
We explicitly create /etc/systemd/user and other parts of the basic directory
|
|
||||||
tree. I think we should create /etc/systemd/system too. (The alternative would
|
|
||||||
be to not create those other directories too, but I think it's nice to have
|
|
||||||
the basic directory structure in place after installation.)
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1737362
|
|
||||||
---
|
|
||||||
src/core/meson.build | 7 +++----
|
|
||||||
1 file changed, 3 insertions(+), 4 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/core/meson.build b/src/core/meson.build
|
|
||||||
index 267d65a3b2..fb6820e109 100644
|
|
||||||
--- a/src/core/meson.build
|
|
||||||
+++ b/src/core/meson.build
|
|
||||||
@@ -212,7 +212,6 @@ meson.add_install_script('sh', '-c', mkdir_p.format(systemsleepdir))
|
|
||||||
meson.add_install_script('sh', '-c', mkdir_p.format(systemgeneratordir))
|
|
||||||
meson.add_install_script('sh', '-c', mkdir_p.format(usergeneratordir))
|
|
||||||
|
|
||||||
-meson.add_install_script('sh', '-c',
|
|
||||||
- mkdir_p.format(join_paths(pkgsysconfdir, 'user')))
|
|
||||||
-meson.add_install_script('sh', '-c',
|
|
||||||
- mkdir_p.format(join_paths(sysconfdir, 'xdg/systemd')))
|
|
||||||
+meson.add_install_script('sh', '-c', mkdir_p.format(join_paths(pkgsysconfdir, 'system')))
|
|
||||||
+meson.add_install_script('sh', '-c', mkdir_p.format(join_paths(pkgsysconfdir, 'user')))
|
|
||||||
+meson.add_install_script('sh', '-c', mkdir_p.format(join_paths(sysconfdir, 'xdg/systemd')))
|
|
||||||
--
|
|
||||||
2.22.0
|
|
||||||
|
|
40
464a73411c13596a130a7a8f0ac00ca728e5f69e.patch
Normal file
40
464a73411c13596a130a7a8f0ac00ca728e5f69e.patch
Normal file
@ -0,0 +1,40 @@
|
|||||||
|
From 464a73411c13596a130a7a8f0ac00ca728e5f69e Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||||
|
Date: Wed, 14 Aug 2019 15:57:42 +0200
|
||||||
|
Subject: [PATCH] udev: use bfq as the default scheduler
|
||||||
|
|
||||||
|
As requested in https://bugzilla.redhat.com/show_bug.cgi?id=1738828.
|
||||||
|
Test results are that bfq seems to behave better and more consistently on
|
||||||
|
typical hardware. The kernel does not have a configuration option to set
|
||||||
|
the default scheduler, and it currently needs to be set by userspace.
|
||||||
|
|
||||||
|
See the bug for more discussion and links.
|
||||||
|
---
|
||||||
|
rules/60-block-scheduler.rules | 5 +++++
|
||||||
|
rules/meson.build | 1 +
|
||||||
|
2 files changed, 6 insertions(+)
|
||||||
|
create mode 100644 rules/60-block-scheduler.rules
|
||||||
|
|
||||||
|
diff --git a/rules/60-block-scheduler.rules b/rules/60-block-scheduler.rules
|
||||||
|
new file mode 100644
|
||||||
|
index 00000000000..480b941761f
|
||||||
|
--- /dev/null
|
||||||
|
+++ b/rules/60-block-scheduler.rules
|
||||||
|
@@ -0,0 +1,5 @@
|
||||||
|
+# do not edit this file, it will be overwritten on update
|
||||||
|
+
|
||||||
|
+ACTION=="add", SUBSYSTEM=="block", \
|
||||||
|
+ KERNEL=="mmcblk*[0-9]|msblk*[0-9]|mspblk*[0-9]|sd*[!0-9]|sr*", \
|
||||||
|
+ ATTR{queue/scheduler}="bfq"
|
||||||
|
diff --git a/rules/meson.build b/rules/meson.build
|
||||||
|
index b6a32ba77e2..1da958b4d46 100644
|
||||||
|
--- a/rules/meson.build
|
||||||
|
+++ b/rules/meson.build
|
||||||
|
@@ -2,6 +2,7 @@
|
||||||
|
|
||||||
|
rules = files('''
|
||||||
|
60-block.rules
|
||||||
|
+ 60-block-scheduler.rules
|
||||||
|
60-cdrom_id.rules
|
||||||
|
60-drm.rules
|
||||||
|
60-evdev.rules
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (systemd-243-rc1.tar.gz) = 6626d7fd5781578d01a30c0d2647a293668d0819f2f85ce78a6aaf62ae1aa4b2c687cf237ca833c5befbc00321a344ff5ca56747cedc6ce00cd0f51c71dd25ff
|
SHA512 (systemd-243-rc2.tar.gz) = 7e9b996c1eeb299fb971f2fd4a39fa62c7cc9178bacaaae6c168008dec438f392b949deb72d08f27060b3cde54b46b70f6a18b1bc70725a56ca2a28a1f96b6a1
|
||||||
|
18
systemd.spec
18
systemd.spec
@ -14,8 +14,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 243~rc1
|
Version: 243~rc2
|
||||||
Release: 2%{?commit:.git%{shortcommit}}%{?dist}
|
Release: 1%{?commit:.git%{shortcommit}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: System and Service Manager
|
Summary: System and Service Manager
|
||||||
@ -52,9 +52,9 @@ i=1; for j in 00*patch; do printf "Patch%04d: %s\n" $i $j; i=$((i+1));done|
|
|||||||
GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[67]* hwdb/parse_hwdb.py > hwdb.patch
|
GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[67]* hwdb/parse_hwdb.py > hwdb.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# Create and therefore own and provide /etc/systemd/system
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
||||||
# https://github.com/systemd/systemd/pull/13267
|
Patch0001: https://github.com/keszybz/systemd/commit/464a73411c13596a130a7a8f0ac00ca728e5f69e.patch
|
||||||
Patch0001: 0001-meson-create-empty-etc-systemd-system-during-install.patch
|
|
||||||
Patch0002: 0002-Revert-units-set-NoNewPrivileges-for-all-long-runnin.patch
|
Patch0002: 0002-Revert-units-set-NoNewPrivileges-for-all-long-runnin.patch
|
||||||
|
|
||||||
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
||||||
@ -335,7 +335,6 @@ CONFIGURE_OPTS=(
|
|||||||
-Db_lto=true
|
-Db_lto=true
|
||||||
-Db_ndebug=false
|
-Db_ndebug=false
|
||||||
-Dman=true
|
-Dman=true
|
||||||
-Ddefault-hierarchy=hybrid
|
|
||||||
-Dversion-tag=v%{version}-%{release}
|
-Dversion-tag=v%{version}-%{release}
|
||||||
)
|
)
|
||||||
|
|
||||||
@ -698,6 +697,13 @@ fi
|
|||||||
%files tests -f .file-list-tests
|
%files tests -f .file-list-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 22 2019 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 243~rc2-1
|
||||||
|
- Update to latest pre-release. Fixes #1740113, #1717712.
|
||||||
|
- The default scheduler for disks is set to BFQ (1738828)
|
||||||
|
- The default cgroup hierarchy is set to unified (cgroups v2) (#1732114).
|
||||||
|
Use systemd.unified-cgroup-hierachy=no on the kernel command line to revert.
|
||||||
|
See https://fedoraproject.org/wiki/Changes/CGroupsV2.
|
||||||
|
|
||||||
* Wed Aug 07 2019 Adam Williamson <awilliam@redhat.com> - 243~rc1-2
|
* Wed Aug 07 2019 Adam Williamson <awilliam@redhat.com> - 243~rc1-2
|
||||||
- Backport PR #1737362 so we own /etc/systemd/system again (#1737362)
|
- Backport PR #1737362 so we own /etc/systemd/system again (#1737362)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user