systemd-252-34
Resolves: RHEL-30372,RHEL-33384,RHEL-36284,RHEL-36505
This commit is contained in:
parent
e3a92f63d1
commit
c86ff2aa72
29
0732-ci-update-actions-upload-artifact-to-v4.patch
Normal file
29
0732-ci-update-actions-upload-artifact-to-v4.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From ddf2ccf36bb804d666da37ce12d00123550d85f1 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Macku <jamacku@redhat.com>
|
||||
Date: Thu, 25 Apr 2024 15:06:03 +0200
|
||||
Subject: [PATCH] ci: update actions/upload-artifact to v4
|
||||
|
||||
`v3` will be deprecated soon, so update to `v4`.
|
||||
|
||||
https://github.blog/changelog/2024-04-16-deprecation-notice-v3-of-the-artifact-actions/
|
||||
|
||||
rhel-only
|
||||
|
||||
Related: RHEL-30372
|
||||
---
|
||||
.github/workflows/gather-metadata.yml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/.github/workflows/gather-metadata.yml b/.github/workflows/gather-metadata.yml
|
||||
index 635708a71f..59659d9bc5 100644
|
||||
--- a/.github/workflows/gather-metadata.yml
|
||||
+++ b/.github/workflows/gather-metadata.yml
|
||||
@@ -22,7 +22,7 @@ jobs:
|
||||
uses: redhat-plumbers-in-action/gather-pull-request-metadata@v1
|
||||
|
||||
- name: Upload artifact with gathered metadata
|
||||
- uses: actions/upload-artifact@v3
|
||||
+ uses: actions/upload-artifact@v4
|
||||
with:
|
||||
name: pr-metadata
|
||||
path: ${{ steps.Metadata.outputs.metadata-file }}
|
@ -0,0 +1,33 @@
|
||||
From da0298596af24d1da92eb748b0a56065a9c041d9 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Cristian=20Rodr=C3=ADguez?= <crodriguez@owncloud.com>
|
||||
Date: Fri, 11 Nov 2022 15:28:51 +0000
|
||||
Subject: [PATCH] journal-remote: code is of type enum
|
||||
MHD_RequestTerminationCode
|
||||
|
||||
Fixes gcc 13 -Wenum-int-mismatch which are enabled by default.
|
||||
|
||||
(cherry picked from commit aa70dd624bff6280ab6f2871f62d313bdb1e1bcc)
|
||||
|
||||
Related: RHEL-30372
|
||||
---
|
||||
src/journal-remote/microhttpd-util.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/journal-remote/microhttpd-util.h b/src/journal-remote/microhttpd-util.h
|
||||
index 7e7d1b56b1..df18335469 100644
|
||||
--- a/src/journal-remote/microhttpd-util.h
|
||||
+++ b/src/journal-remote/microhttpd-util.h
|
||||
@@ -64,11 +64,11 @@ void microhttpd_logger(void *arg, const char *fmt, va_list ap) _printf_(2, 0);
|
||||
|
||||
int mhd_respondf(struct MHD_Connection *connection,
|
||||
int error,
|
||||
- unsigned code,
|
||||
+ enum MHD_RequestTerminationCode code,
|
||||
const char *format, ...) _printf_(4,5);
|
||||
|
||||
int mhd_respond(struct MHD_Connection *connection,
|
||||
- unsigned code,
|
||||
+ enum MHD_RequestTerminationCode code,
|
||||
const char *message);
|
||||
|
||||
int mhd_respond_oom(struct MHD_Connection *connection);
|
@ -0,0 +1,30 @@
|
||||
From cc1a9f1a9a74dd8f5491a3a0fd9734fbca731378 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Cristian=20Rodr=C3=ADguez?= <crodriguez@owncloud.com>
|
||||
Date: Fri, 11 Nov 2022 15:31:18 +0000
|
||||
Subject: [PATCH] resolve: dns_server_feature_level_*_string type is
|
||||
DnsServerFeatureLevel
|
||||
|
||||
gcc 13 -Wenum-int-mismatch reminds us that enum != int
|
||||
|
||||
(cherry picked from commit e14afe31c3e8380496dc85b57103b2f648bc7d43)
|
||||
|
||||
Related: RHEL-30372
|
||||
---
|
||||
src/resolve/resolved-dns-server.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/resolve/resolved-dns-server.h b/src/resolve/resolved-dns-server.h
|
||||
index be9efb0a79..f939b534c3 100644
|
||||
--- a/src/resolve/resolved-dns-server.h
|
||||
+++ b/src/resolve/resolved-dns-server.h
|
||||
@@ -44,8 +44,8 @@ typedef enum DnsServerFeatureLevel {
|
||||
#define DNS_SERVER_FEATURE_LEVEL_IS_DNSSEC(x) ((x) >= DNS_SERVER_FEATURE_LEVEL_DO)
|
||||
#define DNS_SERVER_FEATURE_LEVEL_IS_UDP(x) IN_SET(x, DNS_SERVER_FEATURE_LEVEL_UDP, DNS_SERVER_FEATURE_LEVEL_EDNS0, DNS_SERVER_FEATURE_LEVEL_DO)
|
||||
|
||||
-const char* dns_server_feature_level_to_string(int i) _const_;
|
||||
-int dns_server_feature_level_from_string(const char *s) _pure_;
|
||||
+const char* dns_server_feature_level_to_string(DnsServerFeatureLevel i) _const_;
|
||||
+DnsServerFeatureLevel dns_server_feature_level_from_string(const char *s) _pure_;
|
||||
|
||||
struct DnsServer {
|
||||
Manager *manager;
|
36
0735-shared-install-Use-InstallChangeType-consistently.patch
Normal file
36
0735-shared-install-Use-InstallChangeType-consistently.patch
Normal file
@ -0,0 +1,36 @@
|
||||
From 9f0967eb61b1889c97da705abaf0b0e905d117f3 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Cristian=20Rodr=C3=ADguez?= <crodriguez@owncloud.com>
|
||||
Date: Fri, 11 Nov 2022 15:34:32 +0000
|
||||
Subject: [PATCH] shared|install: Use InstallChangeType consistently
|
||||
|
||||
gcc 13 -Wenum-int-mismatch, enabled by default, reminds us enum ! = int
|
||||
|
||||
(cherry picked from commit 9264db1a0ac6034ab5b40ef3f5914d8dc7d77aba)
|
||||
|
||||
Related: RHEL-30372
|
||||
---
|
||||
src/shared/install.h | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/shared/install.h b/src/shared/install.h
|
||||
index 9bb412ba06..0abc73897e 100644
|
||||
--- a/src/shared/install.h
|
||||
+++ b/src/shared/install.h
|
||||
@@ -197,7 +197,7 @@ int unit_file_exists(LookupScope scope, const LookupPaths *paths, const char *na
|
||||
int unit_file_get_list(LookupScope scope, const char *root_dir, Hashmap *h, char **states, char **patterns);
|
||||
Hashmap* unit_file_list_free(Hashmap *h);
|
||||
|
||||
-InstallChangeType install_changes_add(InstallChange **changes, size_t *n_changes, int type, const char *path, const char *source);
|
||||
+InstallChangeType install_changes_add(InstallChange **changes, size_t *n_changes, InstallChangeType type, const char *path, const char *source);
|
||||
void install_changes_free(InstallChange *changes, size_t n_changes);
|
||||
void install_changes_dump(int r, const char *verb, const InstallChange *changes, size_t n_changes, bool quiet);
|
||||
|
||||
@@ -224,7 +224,7 @@ UnitFileState unit_file_state_from_string(const char *s) _pure_;
|
||||
/* from_string conversion is unreliable because of the overlap between -EPERM and -1 for error. */
|
||||
|
||||
const char *install_change_type_to_string(InstallChangeType t) _const_;
|
||||
-int install_change_type_from_string(const char *s) _pure_;
|
||||
+InstallChangeType install_change_type_from_string(const char *s) _pure_;
|
||||
|
||||
const char *unit_file_preset_mode_to_string(UnitFilePresetMode m) _const_;
|
||||
UnitFilePresetMode unit_file_preset_mode_from_string(const char *s) _pure_;
|
@ -0,0 +1,78 @@
|
||||
From 54c44b19c1018400c38da8f8be597536d14e7afa Mon Sep 17 00:00:00 2001
|
||||
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
||||
Date: Thu, 18 Apr 2024 22:39:31 +0200
|
||||
Subject: [PATCH] test: temporarily disable coredumps in testsuite-17.03.sh
|
||||
|
||||
Since f387005b54 we started generating coredumps by default (up to
|
||||
certain size). This change has one unintentional effect on our test
|
||||
suite - if a sanitized binary (udevd worker here) crashes and ASan is
|
||||
instructed to allow core dumping (via disable_coredump=0 and
|
||||
use_madv_dontdump=1), we try to dump a relatively big core file (~80
|
||||
MiB), and since the test suite configures systemd-coredumpd to dump the
|
||||
cores into the journal, we try to append it to the journal message about
|
||||
the crash. However, journal complains that the message with the coredump
|
||||
is too big so the crash report is not written, and we end up with
|
||||
coredumpctl not showing the crash, which the test in this case uses to
|
||||
monitor if the udevd worker's job timed out:
|
||||
|
||||
[ 17.873463] systemd-udevd[1617]: null: Worker [1625] processing SEQNUM=3588 is taking a long time
|
||||
[ 17.876823] systemd-udevd[1625]: null: Spawned process '/bin/sleep 60' [1626] is taking longer than 3s to complete
|
||||
...
|
||||
[ 24.223459] systemd-udevd[1617]: null: Worker [1625] processing SEQNUM=3588 killed
|
||||
[ 24.265141] systemd[1]: Created slice system-systemd\x2dcoredump.slice.
|
||||
[ 24.284960] systemd[1]: Started systemd-coredump@0-1707-0.service.
|
||||
[ 27.545120] systemd-journald[1225]: Failed to write entry to /var/log/journal/6da99a97048e4f08abd4ddabcf92bbdd/system.journal (51 items, 89252196 bytes) despite vacuuming, ignoring: Argument list too long
|
||||
[ 27.551759] systemd-coredump[1709]: ==1709==LeakSanitizer has encountered a fatal error.
|
||||
[ 27.551759] systemd-coredump[1709]: ==1709==HINT: For debugging, try setting environment variable LSAN_OPTIONS=verbosity=1:log_threads=1
|
||||
[ 27.551759] systemd-coredump[1709]: ==1709==HINT: LeakSanitizer does not work under ptrace (strace, gdb, etc)
|
||||
|
||||
The upstream version of this test doesn't suffer from this because it
|
||||
was recently-ish rewritten to not check for the crash event
|
||||
(5592608bdcb, but we're missing some udevd prerequisites for that to
|
||||
work in RHEL9), and we also started instructing ASan to allow coredumps
|
||||
after that change, so the issue was never encountered there in the first
|
||||
place.
|
||||
|
||||
Since we don't really care about the actual coredump in this case, let's
|
||||
just temporarily override the core rlimit to 0 for the udevd process.
|
||||
|
||||
Related: RHEL-30372
|
||||
rhel-only
|
||||
---
|
||||
test/units/testsuite-17.03.sh | 10 +++++++++-
|
||||
1 file changed, 9 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/test/units/testsuite-17.03.sh b/test/units/testsuite-17.03.sh
|
||||
index 318afdcb5a..8fa58e2f08 100755
|
||||
--- a/test/units/testsuite-17.03.sh
|
||||
+++ b/test/units/testsuite-17.03.sh
|
||||
@@ -17,9 +17,16 @@ event_timeout=10
|
||||
timeout_signal=SIGABRT
|
||||
EOF
|
||||
|
||||
+ mkdir -p /run/systemd/system/systemd-udevd.service.d/
|
||||
+ cat >/run/systemd/system/systemd-udevd.service.d/99-disable-coredumps.conf <<EOF
|
||||
+[Service]
|
||||
+LimitCORE=0
|
||||
+EOF
|
||||
+ systemctl daemon-reload
|
||||
systemctl restart systemd-udevd.service
|
||||
}
|
||||
|
||||
+# shellcheck disable=SC2317
|
||||
teardown() {
|
||||
set +e
|
||||
|
||||
@@ -27,10 +34,11 @@ teardown() {
|
||||
kill "$KILL_PID"
|
||||
fi
|
||||
|
||||
- rm -rf "$TMPDIR"
|
||||
+ rm -rf "$TMPDIR" /run/systemd/system/systemd-udevd.service.d
|
||||
|
||||
mv -f /etc/udev/udev.conf.bckp /etc/udev/udev.conf
|
||||
rm -f "$test_rule"
|
||||
+ systemctl daemon-reload
|
||||
systemctl restart systemd-udevd.service
|
||||
}
|
||||
|
80
0737-ci-update-manpage-deployment-workflow.patch
Normal file
80
0737-ci-update-manpage-deployment-workflow.patch
Normal file
@ -0,0 +1,80 @@
|
||||
From 365a74eef2463a011fbe7413ab5479b4fbd60650 Mon Sep 17 00:00:00 2001
|
||||
From: Jan Macku <jamacku@redhat.com>
|
||||
Date: Thu, 25 Apr 2024 15:46:35 +0200
|
||||
Subject: [PATCH] ci: update manpage deployment workflow
|
||||
|
||||
rhel-only
|
||||
|
||||
Related: RHEL-30372
|
||||
---
|
||||
.github/workflows/deploy-man-pages.yml | 52 +-------------------------
|
||||
1 file changed, 2 insertions(+), 50 deletions(-)
|
||||
|
||||
diff --git a/.github/workflows/deploy-man-pages.yml b/.github/workflows/deploy-man-pages.yml
|
||||
index 08c3d6e322..9739228a87 100644
|
||||
--- a/.github/workflows/deploy-man-pages.yml
|
||||
+++ b/.github/workflows/deploy-man-pages.yml
|
||||
@@ -37,61 +37,13 @@ jobs:
|
||||
|
||||
- name: Install dependencies
|
||||
run: |
|
||||
- RELEASE="$(lsb_release -cs)"
|
||||
- sudo bash -c "echo 'deb-src http://archive.ubuntu.com/ubuntu/ $RELEASE main restricted universe multiverse' >>/etc/apt/sources.list"
|
||||
- sudo add-apt-repository -y ppa:upstream-systemd-ci/systemd-ci
|
||||
+ sudo add-apt-repository -y --no-update --enable-source
|
||||
sudo apt-get -y update
|
||||
sudo apt-get -y build-dep systemd
|
||||
- sudo apt-get install -y \
|
||||
- cryptsetup-bin \
|
||||
- expect \
|
||||
- fdisk \
|
||||
- gettext \
|
||||
- iputils-ping \
|
||||
- isc-dhcp-client \
|
||||
- itstool \
|
||||
- kbd \
|
||||
- libblkid-dev \
|
||||
- libbpf-dev \
|
||||
- libc6-dev-i386 \
|
||||
- libcap-dev \
|
||||
- libcurl4-gnutls-dev \
|
||||
- libfdisk-dev \
|
||||
- libfido2-dev \
|
||||
- libgpg-error-dev \
|
||||
- liblz4-dev \
|
||||
- liblzma-dev \
|
||||
- libmicrohttpd-dev \
|
||||
- libmount-dev \
|
||||
- libp11-kit-dev \
|
||||
- libpwquality-dev \
|
||||
- libqrencode-dev \
|
||||
- libssl-dev \
|
||||
- libtss2-dev \
|
||||
- libxkbcommon-dev \
|
||||
- libxtables-dev \
|
||||
- libzstd-dev \
|
||||
- meson \
|
||||
- mold \
|
||||
- mount \
|
||||
- net-tools \
|
||||
- ninja-build \
|
||||
- perl \
|
||||
- python3-evdev \
|
||||
- python3-jinja2 \
|
||||
- python3-lxml \
|
||||
- python3-pip \
|
||||
- python3-pyparsing \
|
||||
- python3-setuptools \
|
||||
- quota \
|
||||
- strace \
|
||||
- unifont \
|
||||
- util-linux \
|
||||
- zstd \
|
||||
|
||||
- name: Build HTML man pages
|
||||
run: |
|
||||
- meson build
|
||||
+ meson setup build
|
||||
ninja -C build man/html
|
||||
|
||||
- name: Setup Pages
|
38
0738-bootspec-fix-null-dereference-read.patch
Normal file
38
0738-bootspec-fix-null-dereference-read.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From 41d2e7fbb87a99e80e9be1873775c79879f8b821 Mon Sep 17 00:00:00 2001
|
||||
From: Yu Watanabe <watanabe.yu+github@gmail.com>
|
||||
Date: Fri, 2 Dec 2022 14:30:22 +0900
|
||||
Subject: [PATCH] bootspec: fix null-dereference-read
|
||||
|
||||
Fixes [oss-fuzz#53578](https://bugs.chromium.org/p/oss-fuzz/issues/detail?id=53578).
|
||||
Fixes #25450.
|
||||
|
||||
(cherry picked from commit 46dc071985ff487f5ccf20808531168a6add73d3)
|
||||
|
||||
Resolves: RHEL-36284
|
||||
---
|
||||
src/shared/bootspec.c | 2 ++
|
||||
...lusterfuzz-testcase-minimized-fuzz-bootspec-5731869371269120 | 1 +
|
||||
2 files changed, 3 insertions(+)
|
||||
create mode 100644 test/fuzz/fuzz-bootspec/clusterfuzz-testcase-minimized-fuzz-bootspec-5731869371269120
|
||||
|
||||
diff --git a/src/shared/bootspec.c b/src/shared/bootspec.c
|
||||
index 61e20c40a8..7fe8845429 100644
|
||||
--- a/src/shared/bootspec.c
|
||||
+++ b/src/shared/bootspec.c
|
||||
@@ -996,6 +996,8 @@ static int boot_config_find(const BootConfig *config, const char *id) {
|
||||
if (id[0] == '@') {
|
||||
if (!strcaseeq(id, "@saved"))
|
||||
return -1;
|
||||
+ if (!config->entry_selected)
|
||||
+ return -1;
|
||||
id = config->entry_selected;
|
||||
}
|
||||
|
||||
diff --git a/test/fuzz/fuzz-bootspec/clusterfuzz-testcase-minimized-fuzz-bootspec-5731869371269120 b/test/fuzz/fuzz-bootspec/clusterfuzz-testcase-minimized-fuzz-bootspec-5731869371269120
|
||||
new file mode 100644
|
||||
index 0000000000..8804abd094
|
||||
--- /dev/null
|
||||
+++ b/test/fuzz/fuzz-bootspec/clusterfuzz-testcase-minimized-fuzz-bootspec-5731869371269120
|
||||
@@ -0,0 +1 @@
|
||||
+{"config":"default @saved","loader":[""]}
|
||||
\ No newline at end of file
|
@ -0,0 +1,40 @@
|
||||
From 0947147008c9b2cb56b40616fccccf64a6534f07 Mon Sep 17 00:00:00 2001
|
||||
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
||||
Date: Tue, 17 Jan 2023 12:14:13 +0100
|
||||
Subject: [PATCH] units: don't install pcrphase-related units without gnu-efi
|
||||
|
||||
since we don't have systemd-pcrphase built anyway, which breaks the tests:
|
||||
|
||||
...
|
||||
I: Attempting to install /usr/lib/systemd/systemd-networkd-wait-online (based on unit file reference)
|
||||
I: Attempting to install /usr/lib/systemd/systemd-network-generator (based on unit file reference)
|
||||
I: Attempting to install /usr/lib/systemd/systemd-oomd (based on unit file reference)
|
||||
I: Attempting to install /usr/lib/systemd/systemd-pcrphase (based on unit file reference)
|
||||
W: Failed to install '/usr/lib/systemd/systemd-pcrphase'
|
||||
make: *** [Makefile:4: setup] Error 1
|
||||
make: Leaving directory '/root/systemd/test/TEST-01-BASIC'
|
||||
|
||||
Follow-up to 04959faa632272a8fc9cdac3121b2e4af721c1b6.
|
||||
|
||||
(cherry picked from commit 0eb635ef4bc11792cd4ef384ae252a2c7fd4122a)
|
||||
|
||||
Related: RHEL-33384
|
||||
---
|
||||
units/meson.build | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/units/meson.build b/units/meson.build
|
||||
index cfc96a9111..39e6a9bb65 100644
|
||||
--- a/units/meson.build
|
||||
+++ b/units/meson.build
|
||||
@@ -264,8 +264,8 @@ in_units = [
|
||||
'sysinit.target.wants/'],
|
||||
['systemd-pcrphase.service', 'HAVE_GNU_EFI HAVE_OPENSSL HAVE_TPM2',
|
||||
'sysinit.target.wants/'],
|
||||
- ['systemd-pcrfs-root.service', ''],
|
||||
- ['systemd-pcrfs@.service', ''],
|
||||
+ ['systemd-pcrfs-root.service', 'HAVE_GNU_EFI HAVE_OPENSSL HAVE_TPM2'],
|
||||
+ ['systemd-pcrfs@.service', 'HAVE_GNU_EFI HAVE_OPENSSL HAVE_TPM2'],
|
||||
['systemd-growfs-root.service', ''],
|
||||
['systemd-growfs@.service', ''],
|
||||
['systemd-pcrmachine.service', 'HAVE_GNU_EFI HAVE_OPENSSL HAVE_TPM2',
|
44
0740-kernel-install-fix-uki-copy-deinstall.patch
Normal file
44
0740-kernel-install-fix-uki-copy-deinstall.patch
Normal file
@ -0,0 +1,44 @@
|
||||
From 4ab2df57c79a923fba74b2cf48fd56c6a0756413 Mon Sep 17 00:00:00 2001
|
||||
From: Gerd Hoffmann <kraxel@redhat.com>
|
||||
Date: Mon, 18 Mar 2024 17:04:22 +0100
|
||||
Subject: [PATCH] kernel-install: fix uki-copy deinstall
|
||||
|
||||
For "kernel-install remove ..." only the kernel version is passed, not
|
||||
the kernel image. So auto-detecting KERNEL_INSTALL_IMAGE_TYPE and
|
||||
setting KERNEL_INSTALL_LAYOUT does not work for uninstall.
|
||||
|
||||
The 90-uki-copy.install plugin must consider this and *not* exit early
|
||||
for the "remove" command, otherwise $BOOT_ROOT will be filled with stale
|
||||
kernel images.
|
||||
|
||||
Signed-off-by: Gerd Hoffmann <kraxel@redhat.com>
|
||||
|
||||
(cherry picked from commit 3037616d8ed68f3263746e3c6399d4a05242068b)
|
||||
|
||||
Resolves: RHEL-36505
|
||||
---
|
||||
src/kernel-install/90-uki-copy.install | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/kernel-install/90-uki-copy.install b/src/kernel-install/90-uki-copy.install
|
||||
index c66c09719c..d443c4b401 100755
|
||||
--- a/src/kernel-install/90-uki-copy.install
|
||||
+++ b/src/kernel-install/90-uki-copy.install
|
||||
@@ -26,8 +26,6 @@ KERNEL_VERSION="${2:?}"
|
||||
ENTRY_DIR_ABS="$3"
|
||||
KERNEL_IMAGE="$4"
|
||||
|
||||
-[ "$KERNEL_INSTALL_LAYOUT" = "uki" ] || exit 0
|
||||
-
|
||||
ENTRY_TOKEN="$KERNEL_INSTALL_ENTRY_TOKEN"
|
||||
BOOT_ROOT="$KERNEL_INSTALL_BOOT_ROOT"
|
||||
|
||||
@@ -48,6 +46,8 @@ case "$COMMAND" in
|
||||
;;
|
||||
esac
|
||||
|
||||
+[ "$KERNEL_INSTALL_LAYOUT" = "uki" ] || exit 0
|
||||
+
|
||||
if ! [ -d "$UKI_DIR" ]; then
|
||||
[ "$KERNEL_INSTALL_VERBOSE" -gt 0 ] && echo "creating $UKI_DIR"
|
||||
mkdir -p "$UKI_DIR"
|
27
0741-ci-packit-explicitly-clone-c9s-branch.patch
Normal file
27
0741-ci-packit-explicitly-clone-c9s-branch.patch
Normal file
@ -0,0 +1,27 @@
|
||||
From 16eace42619860cbcfedca8c93e4ea20bfb0f98b Mon Sep 17 00:00:00 2001
|
||||
From: Jan Macku <jamacku@redhat.com>
|
||||
Date: Fri, 17 May 2024 14:02:07 +0200
|
||||
Subject: [PATCH] ci(packit): explicitly clone `c9s` branch
|
||||
|
||||
Once default branch is changed to `c10s` the current configuration could stop working.
|
||||
|
||||
rhel-only
|
||||
|
||||
Related: RHEL-30372
|
||||
---
|
||||
.packit.yml | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/.packit.yml b/.packit.yml
|
||||
index 35938f3586..9697a0df84 100644
|
||||
--- a/.packit.yml
|
||||
+++ b/.packit.yml
|
||||
@@ -18,7 +18,7 @@ srpm_build_deps: []
|
||||
actions:
|
||||
post-upstream-clone:
|
||||
# Use the CentOS Stream specfile
|
||||
- - "git clone https://gitlab.com/redhat/centos-stream/rpms/systemd.git .packit_rpm --depth=1"
|
||||
+ - "git clone -b c9s https://gitlab.com/redhat/centos-stream/rpms/systemd.git .packit_rpm --depth=1"
|
||||
# Drop the "sources" file so rebase-helper doesn't think we're a dist-git
|
||||
- "rm -fv .packit_rpm/sources"
|
||||
# Drop all patches, since they're already included in the tarball
|
24
systemd.spec
24
systemd.spec
@ -25,7 +25,7 @@
|
||||
Name: systemd
|
||||
Url: https://systemd.io
|
||||
Version: 252
|
||||
Release: 33%{?dist}
|
||||
Release: 34%{?dist}
|
||||
# For a breakdown of the licensing, see README
|
||||
License: LGPLv2+ and MIT and GPLv2+
|
||||
Summary: System and Service Manager
|
||||
@ -820,6 +820,16 @@ Patch0728: 0728-test-add-coverage-for-CoredumpFilter-all.patch
|
||||
Patch0729: 0729-test-rotate-journal-before-storing-coredumps.patch
|
||||
Patch0730: 0730-test-sync-with-the-fake-binary-before-killing-it.patch
|
||||
Patch0731: 0731-test-check-coredump-handling-in-containers-namespace.patch
|
||||
Patch0732: 0732-ci-update-actions-upload-artifact-to-v4.patch
|
||||
Patch0733: 0733-journal-remote-code-is-of-type-enum-MHD_RequestTermi.patch
|
||||
Patch0734: 0734-resolve-dns_server_feature_level_-_string-type-is-Dn.patch
|
||||
Patch0735: 0735-shared-install-Use-InstallChangeType-consistently.patch
|
||||
Patch0736: 0736-test-temporarily-disable-coredumps-in-testsuite-17.0.patch
|
||||
Patch0737: 0737-ci-update-manpage-deployment-workflow.patch
|
||||
Patch0738: 0738-bootspec-fix-null-dereference-read.patch
|
||||
Patch0739: 0739-units-don-t-install-pcrphase-related-units-without-g.patch
|
||||
Patch0740: 0740-kernel-install-fix-uki-copy-deinstall.patch
|
||||
Patch0741: 0741-ci-packit-explicitly-clone-c9s-branch.patch
|
||||
|
||||
# Downstream-only patches (9000–9999)
|
||||
|
||||
@ -1696,6 +1706,18 @@ systemd-hwdb update &>/dev/null || :
|
||||
%{_prefix}/lib/dracut/modules.d/70rhel-net-naming-sysattrs/*
|
||||
|
||||
%changelog
|
||||
* Mon May 20 2024 systemd maintenance team <systemd-maint@redhat.com> - 252-34
|
||||
- ci: update actions/upload-artifact to v4 (RHEL-30372)
|
||||
- journal-remote: code is of type enum MHD_RequestTerminationCode (RHEL-30372)
|
||||
- resolve: dns_server_feature_level_*_string type is DnsServerFeatureLevel (RHEL-30372)
|
||||
- shared|install: Use InstallChangeType consistently (RHEL-30372)
|
||||
- test: temporarily disable coredumps in testsuite-17.03.sh (RHEL-30372)
|
||||
- ci: update manpage deployment workflow (RHEL-30372)
|
||||
- bootspec: fix null-dereference-read (RHEL-36284)
|
||||
- units: don't install pcrphase-related units without gnu-efi (RHEL-33384)
|
||||
- kernel-install: fix uki-copy deinstall (RHEL-36505)
|
||||
- ci(packit): explicitly clone `c9s` branch (RHEL-30372)
|
||||
|
||||
* Fri Apr 26 2024 systemd maintenance team <systemd-maint@redhat.com> - 252-33
|
||||
- execute: Pass AT_FDCWD instead of -1 (RHEL-31783)
|
||||
- ci(src-git): update list of supported products (RHEL-30372)
|
||||
|
Loading…
Reference in New Issue
Block a user