Compile with oomd
This commit is contained in:
parent
39bdda8d19
commit
bca98cfc50
@ -0,0 +1,25 @@
|
||||
From fe1781d10dd8734af21dbea8c070069829456c03 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 12 Nov 2020 13:05:05 +0100
|
||||
Subject: [PATCH] meson: allow oomd to be enabled even in release mode
|
||||
|
||||
A distro (Fedora in particular) may want to enable oomd in a unstable
|
||||
branch for testing, even though the package as a whole is compiled in release
|
||||
mode. Let's emit a warning but otherwise allow this.
|
||||
---
|
||||
meson.build | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/meson.build b/meson.build
|
||||
index 7996bc2c65..43e328f5a6 100644
|
||||
--- a/meson.build
|
||||
+++ b/meson.build
|
||||
@@ -1419,7 +1419,7 @@ if have == 'auto'
|
||||
else
|
||||
have = have == 'true'
|
||||
if have and get_option('mode') != 'developer'
|
||||
- error('oomd is not available in release mode (yet)')
|
||||
+ warning('oomd is not ready for release mode (yet)')
|
||||
endif
|
||||
endif
|
||||
conf.set10('ENABLE_OOMD', have)
|
@ -71,6 +71,8 @@ GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
||||
Patch0001: use-bfq-scheduler.patch
|
||||
|
||||
Patch0002: 0001-meson-allow-oomd-to-be-enabled-even-in-release-mode.patch
|
||||
|
||||
Patch0009: https://github.com/systemd/systemd/pull/17050/commits/f58b96d3e8d1cb0dd3666bc74fa673918b586612.patch
|
||||
|
||||
%ifarch %{ix86} x86_64 aarch64
|
||||
@ -446,6 +448,7 @@ CONFIGURE_OPTS=(
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1867830
|
||||
-Ddefault-mdns=no
|
||||
-Ddefault-llmnr=resolve
|
||||
-Doomd=true
|
||||
)
|
||||
|
||||
%meson "${CONFIGURE_OPTS[@]}"
|
||||
@ -892,7 +895,6 @@ getent passwd systemd-network &>/dev/null || useradd -r -u 192 -l -g systemd-net
|
||||
- New upstream pre-release. See
|
||||
https://github.com/systemd/systemd/blob/v247-rc1/NEWS.
|
||||
Many smaller and bigger improvements and features are introduced.
|
||||
Note that systemd-oomd is not built as part of this package.
|
||||
(#1885101, #1890632, #1879216)
|
||||
|
||||
A backwards-incompatible change affects PCI network devices which
|
||||
@ -903,6 +905,9 @@ getent passwd systemd-network &>/dev/null || useradd -r -u 192 -l -g systemd-net
|
||||
causes the net naming scheme to be changed to "v247". To restore
|
||||
previous behaviour, specify net.naming-scheme=v245.
|
||||
|
||||
systemd-oomd is built, but should not be considered "production
|
||||
ready" at this point. Testing and bug reports are welcome.
|
||||
|
||||
* Wed Sep 30 2020 Dusty Mabe <dusty@dustymabe.com> - 246.6-3
|
||||
- Try to make files in subpackages (especially the networkd subpackage)
|
||||
more appropriate.
|
||||
|
Loading…
Reference in New Issue
Block a user