Also include gperf compat patch
This commit is contained in:
parent
405c2cd182
commit
b6b3541a52
303
0054-build-sys-add-check-for-gperf-lookup-function-signat.patch
Normal file
303
0054-build-sys-add-check-for-gperf-lookup-function-signat.patch
Normal file
@ -0,0 +1,303 @@
|
||||
From a6bb2c249be58469888cf3b1502f1a01de06bd33 Mon Sep 17 00:00:00 2001
|
||||
From: Mike Gilbert <floppymaster@gmail.com>
|
||||
Date: Tue, 10 Jan 2017 02:39:05 -0500
|
||||
Subject: [PATCH] build-sys: add check for gperf lookup function signature
|
||||
(#5055)
|
||||
|
||||
gperf-3.1 generates lookup functions that take a size_t length
|
||||
parameter instead of unsigned int. Test for this at configure time.
|
||||
|
||||
Fixes: https://github.com/systemd/systemd/issues/5039
|
||||
(cherry picked from commit c9f7b4d356a453a01aa77a6bb74ca7ef49732c08)
|
||||
---
|
||||
configure.ac | 22 ++++++++++++++++++++++
|
||||
src/basic/af-list.c | 2 +-
|
||||
src/basic/arphrd-list.c | 2 +-
|
||||
src/basic/cap-list.c | 2 +-
|
||||
src/basic/errno-list.c | 2 +-
|
||||
src/core/load-fragment.h | 2 +-
|
||||
src/journal/journald-server.h | 2 +-
|
||||
src/login/logind.h | 2 +-
|
||||
src/network/networkd-conf.h | 2 +-
|
||||
src/network/networkd-netdev.h | 2 +-
|
||||
src/network/networkd-network.h | 2 +-
|
||||
src/nspawn/nspawn-settings.h | 2 +-
|
||||
src/resolve/dns-type.c | 2 +-
|
||||
src/resolve/resolved-conf.h | 2 +-
|
||||
src/test/test-af-list.c | 2 +-
|
||||
src/test/test-arphrd-list.c | 2 +-
|
||||
src/timesync/timesyncd-conf.h | 2 +-
|
||||
src/udev/net/link-config.h | 2 +-
|
||||
src/udev/udev-builtin-keyboard.c | 2 +-
|
||||
19 files changed, 40 insertions(+), 18 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1928e65bde..5c639e32d4 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -258,6 +258,28 @@ AC_CHECK_SIZEOF(rlim_t,,[
|
||||
#include <sys/resource.h>
|
||||
])
|
||||
|
||||
+GPERF_TEST="$(echo foo,bar | ${GPERF} -L ANSI-C)"
|
||||
+
|
||||
+AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_PROGRAM([
|
||||
+ #include <string.h>
|
||||
+ const char * in_word_set(const char *, size_t);
|
||||
+ $GPERF_TEST]
|
||||
+ )],
|
||||
+ [GPERF_LEN_TYPE=size_t],
|
||||
+ [AC_COMPILE_IFELSE(
|
||||
+ [AC_LANG_PROGRAM([
|
||||
+ #include <string.h>
|
||||
+ const char * in_word_set(const char *, unsigned);
|
||||
+ $GPERF_TEST]
|
||||
+ )],
|
||||
+ [GPERF_LEN_TYPE=unsigned],
|
||||
+ [AC_MSG_ERROR([** unable to determine gperf len type])]
|
||||
+ )]
|
||||
+)
|
||||
+
|
||||
+AC_DEFINE_UNQUOTED([GPERF_LEN_TYPE], [$GPERF_LEN_TYPE], [gperf len type])
|
||||
+
|
||||
# ------------------------------------------------------------------------------
|
||||
# we use python to build the man page index
|
||||
have_python=no
|
||||
diff --git a/src/basic/af-list.c b/src/basic/af-list.c
|
||||
index 3fac9c508b..4b291d177b 100644
|
||||
--- a/src/basic/af-list.c
|
||||
+++ b/src/basic/af-list.c
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "af-list.h"
|
||||
#include "macro.h"
|
||||
|
||||
-static const struct af_name* lookup_af(register const char *str, register unsigned int len);
|
||||
+static const struct af_name* lookup_af(register const char *str, register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "af-from-name.h"
|
||||
#include "af-to-name.h"
|
||||
diff --git a/src/basic/arphrd-list.c b/src/basic/arphrd-list.c
|
||||
index 6792d1ee3f..2d598dc66f 100644
|
||||
--- a/src/basic/arphrd-list.c
|
||||
+++ b/src/basic/arphrd-list.c
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "arphrd-list.h"
|
||||
#include "macro.h"
|
||||
|
||||
-static const struct arphrd_name* lookup_arphrd(register const char *str, register unsigned int len);
|
||||
+static const struct arphrd_name* lookup_arphrd(register const char *str, register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "arphrd-from-name.h"
|
||||
#include "arphrd-to-name.h"
|
||||
diff --git a/src/basic/cap-list.c b/src/basic/cap-list.c
|
||||
index 3e773a06f5..d68cc78d05 100644
|
||||
--- a/src/basic/cap-list.c
|
||||
+++ b/src/basic/cap-list.c
|
||||
@@ -26,7 +26,7 @@
|
||||
#include "parse-util.h"
|
||||
#include "util.h"
|
||||
|
||||
-static const struct capability_name* lookup_capability(register const char *str, register unsigned int len);
|
||||
+static const struct capability_name* lookup_capability(register const char *str, register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "cap-from-name.h"
|
||||
#include "cap-to-name.h"
|
||||
diff --git a/src/basic/errno-list.c b/src/basic/errno-list.c
|
||||
index 31b66bad5e..c6a01eec8b 100644
|
||||
--- a/src/basic/errno-list.c
|
||||
+++ b/src/basic/errno-list.c
|
||||
@@ -23,7 +23,7 @@
|
||||
#include "macro.h"
|
||||
|
||||
static const struct errno_name* lookup_errno(register const char *str,
|
||||
- register unsigned int len);
|
||||
+ register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "errno-from-name.h"
|
||||
#include "errno-to-name.h"
|
||||
diff --git a/src/core/load-fragment.h b/src/core/load-fragment.h
|
||||
index 1cff815a50..e78219786a 100644
|
||||
--- a/src/core/load-fragment.h
|
||||
+++ b/src/core/load-fragment.h
|
||||
@@ -119,7 +119,7 @@ int config_parse_user_group_strv(const char *unit, const char *filename, unsigne
|
||||
int config_parse_restrict_namespaces(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
|
||||
/* gperf prototypes */
|
||||
-const struct ConfigPerfItem* load_fragment_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* load_fragment_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
extern const char load_fragment_gperf_nulstr[];
|
||||
|
||||
typedef enum Disabled {
|
||||
diff --git a/src/journal/journald-server.h b/src/journal/journald-server.h
|
||||
index de1c48f805..716e758b7c 100644
|
||||
--- a/src/journal/journald-server.h
|
||||
+++ b/src/journal/journald-server.h
|
||||
@@ -179,7 +179,7 @@ void server_dispatch_message(Server *s, struct iovec *iovec, unsigned n, unsigne
|
||||
void server_driver_message(Server *s, sd_id128_t message_id, const char *format, ...) _printf_(3,0) _sentinel_;
|
||||
|
||||
/* gperf lookup function */
|
||||
-const struct ConfigPerfItem* journald_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* journald_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int config_parse_storage(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
|
||||
diff --git a/src/login/logind.h b/src/login/logind.h
|
||||
index 086fa1eeb5..7556ee2e48 100644
|
||||
--- a/src/login/logind.h
|
||||
+++ b/src/login/logind.h
|
||||
@@ -182,7 +182,7 @@ int manager_unit_is_active(Manager *manager, const char *unit);
|
||||
int manager_job_is_active(Manager *manager, const char *path);
|
||||
|
||||
/* gperf lookup function */
|
||||
-const struct ConfigPerfItem* logind_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* logind_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int manager_set_lid_switch_ignore(Manager *m, usec_t until);
|
||||
|
||||
diff --git a/src/network/networkd-conf.h b/src/network/networkd-conf.h
|
||||
index c7bfb42a72..00ddb7672a 100644
|
||||
--- a/src/network/networkd-conf.h
|
||||
+++ b/src/network/networkd-conf.h
|
||||
@@ -23,7 +23,7 @@
|
||||
|
||||
int manager_parse_config_file(Manager *m);
|
||||
|
||||
-const struct ConfigPerfItem* networkd_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* networkd_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int config_parse_duid_type(
|
||||
const char *unit,
|
||||
diff --git a/src/network/networkd-netdev.h b/src/network/networkd-netdev.h
|
||||
index 70ff947b99..37c7431213 100644
|
||||
--- a/src/network/networkd-netdev.h
|
||||
+++ b/src/network/networkd-netdev.h
|
||||
@@ -175,7 +175,7 @@ NetDevKind netdev_kind_from_string(const char *d) _pure_;
|
||||
int config_parse_netdev_kind(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
|
||||
/* gperf */
|
||||
-const struct ConfigPerfItem* network_netdev_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* network_netdev_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
/* Macros which append INTERFACE= to the message */
|
||||
|
||||
diff --git a/src/network/networkd-network.h b/src/network/networkd-network.h
|
||||
index 11ff34b5b5..e39127b7b8 100644
|
||||
--- a/src/network/networkd-network.h
|
||||
+++ b/src/network/networkd-network.h
|
||||
@@ -236,7 +236,7 @@ int config_parse_dhcp_route_table(const char *unit, const char *filename, unsign
|
||||
/* Legacy IPv4LL support */
|
||||
int config_parse_ipv4ll(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
|
||||
-const struct ConfigPerfItem* network_network_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* network_network_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
extern const sd_bus_vtable network_vtable[];
|
||||
|
||||
diff --git a/src/nspawn/nspawn-settings.h b/src/nspawn/nspawn-settings.h
|
||||
index 231e6d7266..4ae34f8e28 100644
|
||||
--- a/src/nspawn/nspawn-settings.h
|
||||
+++ b/src/nspawn/nspawn-settings.h
|
||||
@@ -103,7 +103,7 @@ bool settings_private_network(Settings *s);
|
||||
|
||||
DEFINE_TRIVIAL_CLEANUP_FUNC(Settings*, settings_free);
|
||||
|
||||
-const struct ConfigPerfItem* nspawn_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* nspawn_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int config_parse_capability(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
int config_parse_id128(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
diff --git a/src/resolve/dns-type.c b/src/resolve/dns-type.c
|
||||
index aaf5ed62c1..d89ae28dcd 100644
|
||||
--- a/src/resolve/dns-type.c
|
||||
+++ b/src/resolve/dns-type.c
|
||||
@@ -29,7 +29,7 @@ typedef const struct {
|
||||
} dns_type;
|
||||
|
||||
static const struct dns_type_name *
|
||||
-lookup_dns_type (register const char *str, register unsigned int len);
|
||||
+lookup_dns_type (register const char *str, register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "dns_type-from-name.h"
|
||||
#include "dns_type-to-name.h"
|
||||
diff --git a/src/resolve/resolved-conf.h b/src/resolve/resolved-conf.h
|
||||
index fc425a36b2..8184d6cadf 100644
|
||||
--- a/src/resolve/resolved-conf.h
|
||||
+++ b/src/resolve/resolved-conf.h
|
||||
@@ -41,7 +41,7 @@ int manager_parse_search_domains_and_warn(Manager *m, const char *string);
|
||||
int manager_add_dns_server_by_string(Manager *m, DnsServerType type, const char *word);
|
||||
int manager_parse_dns_server_string_and_warn(Manager *m, DnsServerType type, const char *string);
|
||||
|
||||
-const struct ConfigPerfItem* resolved_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* resolved_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int config_parse_dns_servers(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
int config_parse_search_domains(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
diff --git a/src/test/test-af-list.c b/src/test/test-af-list.c
|
||||
index aeaa0929b1..e2479133de 100644
|
||||
--- a/src/test/test-af-list.c
|
||||
+++ b/src/test/test-af-list.c
|
||||
@@ -24,7 +24,7 @@
|
||||
#include "string-util.h"
|
||||
#include "util.h"
|
||||
|
||||
-static const struct af_name* lookup_af(register const char *str, register unsigned int len);
|
||||
+static const struct af_name* lookup_af(register const char *str, register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "af-from-name.h"
|
||||
#include "af-list.h"
|
||||
diff --git a/src/test/test-arphrd-list.c b/src/test/test-arphrd-list.c
|
||||
index f3989ad201..8f4f342faa 100644
|
||||
--- a/src/test/test-arphrd-list.c
|
||||
+++ b/src/test/test-arphrd-list.c
|
||||
@@ -24,7 +24,7 @@
|
||||
#include "string-util.h"
|
||||
#include "util.h"
|
||||
|
||||
-static const struct arphrd_name* lookup_arphrd(register const char *str, register unsigned int len);
|
||||
+static const struct arphrd_name* lookup_arphrd(register const char *str, register GPERF_LEN_TYPE len);
|
||||
|
||||
#include "arphrd-from-name.h"
|
||||
#include "arphrd-list.h"
|
||||
diff --git a/src/timesync/timesyncd-conf.h b/src/timesync/timesyncd-conf.h
|
||||
index cba0724b1b..0280697e9c 100644
|
||||
--- a/src/timesync/timesyncd-conf.h
|
||||
+++ b/src/timesync/timesyncd-conf.h
|
||||
@@ -22,7 +22,7 @@
|
||||
#include "conf-parser.h"
|
||||
#include "timesyncd-manager.h"
|
||||
|
||||
-const struct ConfigPerfItem* timesyncd_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* timesyncd_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int manager_parse_server_string(Manager *m, ServerType type, const char *string);
|
||||
|
||||
diff --git a/src/udev/net/link-config.h b/src/udev/net/link-config.h
|
||||
index 91cc0357c4..b0d8ceb76a 100644
|
||||
--- a/src/udev/net/link-config.h
|
||||
+++ b/src/udev/net/link-config.h
|
||||
@@ -93,7 +93,7 @@ const char *mac_policy_to_string(MACPolicy p) _const_;
|
||||
MACPolicy mac_policy_from_string(const char *p) _pure_;
|
||||
|
||||
/* gperf lookup function */
|
||||
-const struct ConfigPerfItem* link_config_gperf_lookup(const char *key, unsigned length);
|
||||
+const struct ConfigPerfItem* link_config_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||
|
||||
int config_parse_mac_policy(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
int config_parse_name_policy(const char *unit, const char *filename, unsigned line, const char *section, unsigned section_line, const char *lvalue, int ltype, const char *rvalue, void *data, void *userdata);
|
||||
diff --git a/src/udev/udev-builtin-keyboard.c b/src/udev/udev-builtin-keyboard.c
|
||||
index aa10beafb0..09024116f2 100644
|
||||
--- a/src/udev/udev-builtin-keyboard.c
|
||||
+++ b/src/udev/udev-builtin-keyboard.c
|
||||
@@ -29,7 +29,7 @@
|
||||
#include "string-util.h"
|
||||
#include "udev.h"
|
||||
|
||||
-static const struct key *keyboard_lookup_key(const char *str, unsigned len);
|
||||
+static const struct key *keyboard_lookup_key(const char *str, GPERF_LEN_TYPE len);
|
||||
#include "keyboard-keys-from-name.h"
|
||||
|
||||
static int install_force_release(struct udev_device *dev, const unsigned *release, unsigned release_count) {
|
||||
--
|
||||
2.9.3
|
||||
|
@ -95,6 +95,7 @@ Patch0050: 0050-journald-don-t-flush-to-var-log-journal-before-we-ge.patch
|
||||
Patch0051: 0051-tree-wide-drop-NULL-sentinel-from-strjoin.patch
|
||||
Patch0052: 0052-core-add-new-RestrictNamespaces-unit-file-setting.patch
|
||||
Patch0053: 0053-seccomp-rework-seccomp-code-to-improve-compat-with-s.patch
|
||||
Patch0054: 0054-build-sys-add-check-for-gperf-lookup-function-signat.patch
|
||||
|
||||
# GIT_DIR=../../src/systemd/.git git diffab -M v232..master@{2017-01-30} hwdb/[67]* > hwdb.patch
|
||||
Patch0997: hwdb.patch
|
||||
|
Loading…
Reference in New Issue
Block a user