Revert patch that breaks Atomic/OSTree (#1195761)
Conflicts: systemd.spec
This commit is contained in:
parent
5427ee063b
commit
b1d608a2b3
@ -0,0 +1,27 @@
|
||||
From eb7a760052667c5a35637901de9359c377263804 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Tue, 24 Feb 2015 10:12:28 -0500
|
||||
Subject: [PATCH] Revert "core/mount: add dependencies to dynamically mounted
|
||||
mounts too"
|
||||
|
||||
This reverts commit 06e97888883e2cc12eb6514e80c7f0014295f59b.
|
||||
---
|
||||
src/core/mount.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/core/mount.c b/src/core/mount.c
|
||||
index 40037e7..cddb5e2 100644
|
||||
--- a/src/core/mount.c
|
||||
+++ b/src/core/mount.c
|
||||
@@ -295,7 +295,7 @@ static int mount_add_device_links(Mount *m) {
|
||||
|
||||
assert(m);
|
||||
|
||||
- p = get_mount_parameters(m);
|
||||
+ p = get_mount_parameters_fragment(m);
|
||||
if (!p)
|
||||
return 0;
|
||||
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -0,0 +1,49 @@
|
||||
From f94b2f6c88693a9dbd9230723d097d35c0e94b75 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Mon, 16 Feb 2015 11:43:46 -0500
|
||||
Subject: [PATCH] unit: When stopping due to BindsTo=, log which unit caused it
|
||||
|
||||
I'm trying to track down a relatively recent change in systemd
|
||||
which broke OSTree; see https://bugzilla.gnome.org/show_bug.cgi?id=743891
|
||||
|
||||
Systemd started to stop sysroot.mount, and this patch should help
|
||||
me debug why at least.
|
||||
|
||||
While we're here, "break" on the first unit we find that will
|
||||
deactivate, as there's no point in further iteration.
|
||||
---
|
||||
src/core/unit.c | 6 ++++--
|
||||
1 file changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/core/unit.c b/src/core/unit.c
|
||||
index ad5348b..f898bb7 100644
|
||||
--- a/src/core/unit.c
|
||||
+++ b/src/core/unit.c
|
||||
@@ -1623,7 +1623,7 @@ static void unit_check_unneeded(Unit *u) {
|
||||
|
||||
static void unit_check_binds_to(Unit *u) {
|
||||
bool stop = false;
|
||||
- Unit *other;
|
||||
+ Unit *other = NULL;
|
||||
Iterator i;
|
||||
|
||||
assert(u);
|
||||
@@ -1642,12 +1642,14 @@ static void unit_check_binds_to(Unit *u) {
|
||||
continue;
|
||||
|
||||
stop = true;
|
||||
+ break;
|
||||
}
|
||||
|
||||
if (!stop)
|
||||
return;
|
||||
|
||||
- log_unit_info(u->id, "Unit %s is bound to inactive unit. Stopping, too.", u->id);
|
||||
+ assert(other);
|
||||
+ log_unit_info(u->id, "Unit %s is bound to inactive unit %s. Stopping, too.", u->id, other->id);
|
||||
|
||||
/* A unit we need to run is gone. Sniff. Let's stop this. */
|
||||
manager_add_job(u->manager, JOB_STOP, u, JOB_FAIL, true, NULL, NULL);
|
||||
--
|
||||
1.8.3.1
|
||||
|
@ -16,7 +16,7 @@
|
||||
Name: systemd
|
||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||
Version: 219
|
||||
Release: 5%{?gitcommit:.git%{gitcommit}}%{?dist}
|
||||
Release: 6%{?gitcommit:.git%{gitcommit}}%{?dist}
|
||||
# For a breakdown of the licensing, see README
|
||||
License: LGPLv2+ and MIT and GPLv2+
|
||||
Summary: A System and Service Manager
|
||||
@ -42,6 +42,9 @@ Source8: systemd-journal-gatewayd.xml
|
||||
# GIT_DIR=~/src/systemd/.git git format-patch-ab -M -N --no-signature v219..v219-stable
|
||||
# i=1; for p in 0*patch;do printf "Patch%04d: %s\n" $i $p; ((i++));done
|
||||
|
||||
Patch998: 0001-unit-When-stopping-due-to-BindsTo-log-which-unit-cau.patch
|
||||
Patch999: 0001-Revert-core-mount-add-dependencies-to-dynamically-mo.patch
|
||||
|
||||
# kernel-install patch for grubby, drop if grubby is obsolete
|
||||
Patch1000: kernel-install-grubby.patch
|
||||
|
||||
@ -862,6 +865,9 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
||||
/usr/lib/firewalld/services/*
|
||||
|
||||
%changelog
|
||||
* Tue Feb 24 2015 Colin Walters <walters@redhat.com> - 219-6
|
||||
- Revert patch that breaks Atomic/OSTree (#1195761)
|
||||
|
||||
* Fri Feb 20 2015 Michal Schmidt <mschmidt@redhat.com> - 219-5
|
||||
- Undo the resolv.conf workaround, Aim for a proper fix in Rawhide.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user