Update to current git snapshot, split systemd-libs
- Update to current git snapshot - Add systemd-readahead-analyze - Drop upstream patch - Split systemd-libs - Drop duplicate doc files - Fixed License headers of subpackages
This commit is contained in:
parent
1b8a7f0f16
commit
998394df66
@ -1,48 +0,0 @@
|
|||||||
From 3cbd5f6be191a4e71fc85d8b893e96d6d65bf792 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Kay Sievers <kay@vrfy.org>
|
|
||||||
Date: Tue, 5 Jun 2012 17:31:32 +0200
|
|
||||||
Subject: [PATCH] udev: remove remaining selinux labeling for file in /run
|
|
||||||
|
|
||||||
---
|
|
||||||
src/libudev/libudev-device-private.c | 4 ++--
|
|
||||||
src/udev/udev-node.c | 2 +-
|
|
||||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/libudev/libudev-device-private.c b/src/libudev/libudev-device-private.c
|
|
||||||
index bdb0e70..2347736 100644
|
|
||||||
--- a/src/libudev/libudev-device-private.c
|
|
||||||
+++ b/src/libudev/libudev-device-private.c
|
|
||||||
@@ -35,7 +35,7 @@ static void udev_device_tag(struct udev_device *dev, const char *tag, bool add)
|
|
||||||
if (add) {
|
|
||||||
int fd;
|
|
||||||
|
|
||||||
- mkdir_parents_label(filename, 0755);
|
|
||||||
+ mkdir_parents(filename, 0755);
|
|
||||||
fd = open(filename, O_WRONLY|O_CREAT|O_CLOEXEC|O_TRUNC|O_NOFOLLOW, 0444);
|
|
||||||
if (fd >= 0)
|
|
||||||
close(fd);
|
|
||||||
@@ -119,7 +119,7 @@ int udev_device_update_db(struct udev_device *udev_device)
|
|
||||||
|
|
||||||
/* write a database file */
|
|
||||||
util_strscpyl(filename_tmp, sizeof(filename_tmp), filename, ".tmp", NULL);
|
|
||||||
- mkdir_parents_label(filename_tmp, 0755);
|
|
||||||
+ mkdir_parents(filename_tmp, 0755);
|
|
||||||
f = fopen(filename_tmp, "we");
|
|
||||||
if (f == NULL) {
|
|
||||||
udev_err(udev, "unable to create temporary db file '%s': %m\n", filename_tmp);
|
|
||||||
diff --git a/src/udev/udev-node.c b/src/udev/udev-node.c
|
|
||||||
index 2ef6341..aee84a9 100644
|
|
||||||
--- a/src/udev/udev-node.c
|
|
||||||
+++ b/src/udev/udev-node.c
|
|
||||||
@@ -226,7 +226,7 @@ static void link_update(struct udev_device *dev, const char *slink, bool add)
|
|
||||||
do {
|
|
||||||
int fd;
|
|
||||||
|
|
||||||
- err = mkdir_parents_label(filename, 0755);
|
|
||||||
+ err = mkdir_parents(filename, 0755);
|
|
||||||
if (err != 0 && err != -ENOENT)
|
|
||||||
break;
|
|
||||||
fd = open(filename, O_WRONLY|O_CREAT|O_CLOEXEC|O_TRUNC|O_NOFOLLOW, 0444);
|
|
||||||
--
|
|
||||||
1.7.10.2
|
|
||||||
|
|
43
systemd.spec
43
systemd.spec
@ -1,9 +1,9 @@
|
|||||||
#global gitcommit 9fa2f41
|
%global gitcommit a2368a3
|
||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 185
|
Version: 185
|
||||||
Release: 3%{?gitcommit:.git%{gitcommit}}%{?dist}
|
Release: 4%{?gitcommit:.git%{gitcommit}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -56,7 +56,6 @@ Source2: systemd-sysv-convert
|
|||||||
Source3: udlfb.conf
|
Source3: udlfb.conf
|
||||||
# Stop-gap, just to ensure things work fine with rsyslog without having to change the package right-away
|
# Stop-gap, just to ensure things work fine with rsyslog without having to change the package right-away
|
||||||
Source4: listen.conf
|
Source4: listen.conf
|
||||||
Patch0: 0001-udev-remove-remaining-selinux-labeling-for-file-in-r.patch
|
|
||||||
|
|
||||||
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
|
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
|
||||||
Provides: SysVinit = 2.86-24, sysvinit = 2.86-24
|
Provides: SysVinit = 2.86-24, sysvinit = 2.86-24
|
||||||
@ -87,9 +86,18 @@ state, maintains mount and automount points and implements an
|
|||||||
elaborate transactional dependency-based service control logic. It can
|
elaborate transactional dependency-based service control logic. It can
|
||||||
work as a drop-in replacement for sysvinit.
|
work as a drop-in replacement for sysvinit.
|
||||||
|
|
||||||
|
%package libs
|
||||||
|
Group: System Environment/Base
|
||||||
|
Summary: systemd libraries
|
||||||
|
License: LGPLv2+ and MIT
|
||||||
|
|
||||||
|
%description libs
|
||||||
|
Libraries for systemd and udev. systemd PAM module.
|
||||||
|
|
||||||
%package devel
|
%package devel
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Summary: Development headers for systemd
|
Summary: Development headers for systemd
|
||||||
|
License: LGPLv2+ and MIT
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Provides: libudev-devel = %{version}
|
Provides: libudev-devel = %{version}
|
||||||
Obsoletes: libudev-devel < 183
|
Obsoletes: libudev-devel < 183
|
||||||
@ -100,6 +108,7 @@ Development headers and auxiliary files for developing applications for systemd.
|
|||||||
%package sysv
|
%package sysv
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Summary: SysV tools for systemd
|
Summary: SysV tools for systemd
|
||||||
|
License: LGPLv2+
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
|
|
||||||
%description sysv
|
%description sysv
|
||||||
@ -108,6 +117,7 @@ SysV compatibility tools for systemd
|
|||||||
%package analyze
|
%package analyze
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Summary: Tool for processing systemd profiling information
|
Summary: Tool for processing systemd profiling information
|
||||||
|
License: LGPLv2+
|
||||||
Requires: %{name} = %{version}-%{release}
|
Requires: %{name} = %{version}-%{release}
|
||||||
Requires: dbus-python
|
Requires: dbus-python
|
||||||
Requires: pycairo
|
Requires: pycairo
|
||||||
@ -142,7 +152,6 @@ glib-based applications using libudev functionality.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q %{?gitcommit:-n %{name}-git%{gitcommit}}
|
%setup -q %{?gitcommit:-n %{name}-git%{gitcommit}}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{?gitcommit: ./autogen.sh }
|
%{?gitcommit: ./autogen.sh }
|
||||||
@ -309,7 +318,6 @@ mv /etc/systemd/system/default.target.save /etc/systemd/system/default.target >/
|
|||||||
%postun -n libgudev1 -p /sbin/ldconfig
|
%postun -n libgudev1 -p /sbin/ldconfig
|
||||||
|
|
||||||
%files
|
%files
|
||||||
%doc NEWS README src/udev/keymap/README.keymap.txt
|
|
||||||
%doc %{_docdir}/systemd
|
%doc %{_docdir}/systemd
|
||||||
%dir %{_sysconfdir}/systemd
|
%dir %{_sysconfdir}/systemd
|
||||||
%dir %{_sysconfdir}/systemd/system
|
%dir %{_sysconfdir}/systemd/system
|
||||||
@ -374,6 +382,7 @@ mv /etc/systemd/system/default.target.save /etc/systemd/system/default.target >/
|
|||||||
%{_bindir}/systemd-delta
|
%{_bindir}/systemd-delta
|
||||||
%{_bindir}/systemd-detect-virt
|
%{_bindir}/systemd-detect-virt
|
||||||
%{_bindir}/systemd-inhibit
|
%{_bindir}/systemd-inhibit
|
||||||
|
%{_bindir}/systemd-readahead-analyze
|
||||||
%{_bindir}/udevadm
|
%{_bindir}/udevadm
|
||||||
%{_prefix}/lib/systemd/system
|
%{_prefix}/lib/systemd/system
|
||||||
%{_prefix}/lib/systemd/user
|
%{_prefix}/lib/systemd/user
|
||||||
@ -384,12 +393,6 @@ mv /etc/systemd/system/default.target.save /etc/systemd/system/default.target >/
|
|||||||
%{_prefix}/lib/systemd/system-generators/systemd-rc-local-generator
|
%{_prefix}/lib/systemd/system-generators/systemd-rc-local-generator
|
||||||
%{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
|
%{_prefix}/lib/systemd/system-generators/systemd-fstab-generator
|
||||||
%{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
|
%{_prefix}/lib/systemd/system-generators/systemd-system-update-generator
|
||||||
%{_libdir}/security/pam_systemd.so
|
|
||||||
%{_libdir}/libsystemd-daemon.so.*
|
|
||||||
%{_libdir}/libsystemd-login.so.*
|
|
||||||
%{_libdir}/libsystemd-journal.so.*
|
|
||||||
%{_libdir}/libsystemd-id128.so.*
|
|
||||||
%{_libdir}/libudev.so.*
|
|
||||||
%{_sbindir}/init
|
%{_sbindir}/init
|
||||||
%{_sbindir}/reboot
|
%{_sbindir}/reboot
|
||||||
%{_sbindir}/halt
|
%{_sbindir}/halt
|
||||||
@ -431,6 +434,14 @@ mv /etc/systemd/system/default.target.save /etc/systemd/system/default.target >/
|
|||||||
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel4.target
|
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel4.target
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel5.target
|
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel5.target
|
||||||
|
|
||||||
|
%files libs
|
||||||
|
%{_libdir}/security/pam_systemd.so
|
||||||
|
%{_libdir}/libsystemd-daemon.so.*
|
||||||
|
%{_libdir}/libsystemd-login.so.*
|
||||||
|
%{_libdir}/libsystemd-journal.so.*
|
||||||
|
%{_libdir}/libsystemd-id128.so.*
|
||||||
|
%{_libdir}/libudev.so.*
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/libsystemd-daemon.so
|
%{_libdir}/libsystemd-daemon.so
|
||||||
%{_libdir}/libsystemd-login.so
|
%{_libdir}/libsystemd-login.so
|
||||||
@ -475,7 +486,15 @@ mv /etc/systemd/system/default.target.save /etc/systemd/system/default.target >/
|
|||||||
%attr(0644,root,root) %{_libdir}/pkgconfig/gudev-1.0*
|
%attr(0644,root,root) %{_libdir}/pkgconfig/gudev-1.0*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Wed Jun 06 2012 Ray Strode <rstrode@redhat.com> 185-3
|
* Wed Jun 06 2012 Michal Schmidt <mschmidt@redhat.com> - 185-4.gita2368a3
|
||||||
|
- Update to current git snapshot
|
||||||
|
- Add systemd-readahead-analyze
|
||||||
|
- Drop upstream patch
|
||||||
|
- Split systemd-libs
|
||||||
|
- Drop duplicate doc files
|
||||||
|
- Fixed License headers of subpackages
|
||||||
|
|
||||||
|
* Wed Jun 06 2012 Ray Strode <rstrode@redhat.com> - 185-3
|
||||||
- Drop plymouth files
|
- Drop plymouth files
|
||||||
- Conflict with old plymouth
|
- Conflict with old plymouth
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user