New upstream release
This commit is contained in:
parent
ea5796cf9b
commit
90285fd093
1
.gitignore
vendored
1
.gitignore
vendored
@ -30,3 +30,4 @@ systemd-*src.rpm
|
|||||||
/systemd-31.tar.bz2
|
/systemd-31.tar.bz2
|
||||||
/systemd-32.tar.bz2
|
/systemd-32.tar.bz2
|
||||||
/systemd-33.tar.bz2
|
/systemd-33.tar.bz2
|
||||||
|
/systemd-34.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
361cad7c3debbdd81c211527509ba181 systemd-33.tar.bz2
|
35761c50d5fe8fa8d15a3c651ab8bace systemd-34.tar.bz2
|
||||||
|
@ -1,19 +0,0 @@
|
|||||||
commit e191553d1dc80cd6d65d05f0cb29f8967fab6983
|
|
||||||
Author: Kay Sievers <kay.sievers@vrfy.org>
|
|
||||||
Date: Wed Aug 17 19:38:07 2011 +0200
|
|
||||||
|
|
||||||
convert int to boolean for dbus_bool_t
|
|
||||||
|
|
||||||
diff --git a/src/dbus-manager.c b/src/dbus-manager.c
|
|
||||||
index ae88895..cfc2afc 100644
|
|
||||||
--- a/src/dbus-manager.c
|
|
||||||
+++ b/src/dbus-manager.c
|
|
||||||
@@ -444,7 +444,7 @@ static DBusMessage *message_from_file_changes(
|
|
||||||
if (carries_install_info >= 0) {
|
|
||||||
dbus_bool_t b;
|
|
||||||
|
|
||||||
- b = carries_install_info;
|
|
||||||
+ b = !!carries_install_info;
|
|
||||||
if (!dbus_message_iter_append_basic(&iter, DBUS_TYPE_BOOLEAN, &b))
|
|
||||||
goto oom;
|
|
||||||
}
|
|
10
systemd.spec
10
systemd.spec
@ -1,8 +1,8 @@
|
|||||||
Name: systemd
|
Name: systemd
|
||||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
Version: 33
|
Version: 34
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Summary: A System and Service Manager
|
Summary: A System and Service Manager
|
||||||
@ -44,7 +44,6 @@ Source1: macros.systemd
|
|||||||
Source2: systemd-sysv-convert
|
Source2: systemd-sysv-convert
|
||||||
# Stop-gap, just to ensure things work out-of-the-box for this driver.
|
# Stop-gap, just to ensure things work out-of-the-box for this driver.
|
||||||
Source3: udlfb.conf
|
Source3: udlfb.conf
|
||||||
Patch1: systemd-git-e191553d1dc80cd6d65d05f0cb29f8967fab6983.patch
|
|
||||||
|
|
||||||
# For sysvinit tools
|
# For sysvinit tools
|
||||||
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
|
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
|
||||||
@ -107,7 +106,6 @@ SysV compatibility tools for systemd
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-rootdir= --with-distro=fedora --with-rootlibdir=/%{_lib}
|
%configure --with-rootdir= --with-distro=fedora --with-rootlibdir=/%{_lib}
|
||||||
@ -236,6 +234,7 @@ fi
|
|||||||
%{_libdir}/../lib/tmpfiles.d/systemd.conf
|
%{_libdir}/../lib/tmpfiles.d/systemd.conf
|
||||||
%{_libdir}/../lib/tmpfiles.d/x11.conf
|
%{_libdir}/../lib/tmpfiles.d/x11.conf
|
||||||
%{_libdir}/../lib/tmpfiles.d/legacy.conf
|
%{_libdir}/../lib/tmpfiles.d/legacy.conf
|
||||||
|
%{_libdir}/../lib/tmpfiles.d/tmp.conf
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/hostname
|
%ghost %config(noreplace) %{_sysconfdir}/hostname
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
|
%ghost %config(noreplace) %{_sysconfdir}/vconsole.conf
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/locale.conf
|
%ghost %config(noreplace) %{_sysconfdir}/locale.conf
|
||||||
@ -345,6 +344,9 @@ fi
|
|||||||
%{_bindir}/systemd-sysv-convert
|
%{_bindir}/systemd-sysv-convert
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Aug 25 2011 Lennart Poettering <lpoetter@redhat.com> - 34-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Fri Aug 19 2011 Harald Hoyer <harald@redhat.com> 33-2
|
* Fri Aug 19 2011 Harald Hoyer <harald@redhat.com> 33-2
|
||||||
- fix ABRT on service file reloading
|
- fix ABRT on service file reloading
|
||||||
Resolves: rhbz#732020
|
Resolves: rhbz#732020
|
||||||
|
Loading…
Reference in New Issue
Block a user