Version 249.5
This commit is contained in:
parent
013143c94e
commit
837a32b7cd
24
20695.patch
24
20695.patch
@ -1,24 +0,0 @@
|
|||||||
From 67cd626399b0d02882ee00716c8bd31ba764c862 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Chris Packham <chris.packham@alliedtelesis.co.nz>
|
|
||||||
Date: Fri, 10 Sep 2021 09:51:36 +1200
|
|
||||||
Subject: [PATCH] basic/linux: Sync if_arp.h with Linux 5.14
|
|
||||||
|
|
||||||
ARPHRD_MCTP was added in 5.14. Sync if_arp.h to pick up the definition
|
|
||||||
|
|
||||||
Fixes #20694
|
|
||||||
---
|
|
||||||
src/basic/linux/if_arp.h | 1 +
|
|
||||||
1 file changed, 1 insertion(+)
|
|
||||||
|
|
||||||
diff --git a/src/basic/linux/if_arp.h b/src/basic/linux/if_arp.h
|
|
||||||
index c3cc5a9e5eaf..4783af9fe520 100644
|
|
||||||
--- a/src/basic/linux/if_arp.h
|
|
||||||
+++ b/src/basic/linux/if_arp.h
|
|
||||||
@@ -54,6 +54,7 @@
|
|
||||||
#define ARPHRD_X25 271 /* CCITT X.25 */
|
|
||||||
#define ARPHRD_HWX25 272 /* Boards with X.25 in firmware */
|
|
||||||
#define ARPHRD_CAN 280 /* Controller Area Network */
|
|
||||||
+#define ARPHRD_MCTP 290
|
|
||||||
#define ARPHRD_PPP 512
|
|
||||||
#define ARPHRD_CISCO 513 /* Cisco HDLC */
|
|
||||||
#define ARPHRD_HDLC ARPHRD_CISCO
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (systemd-249.4.tar.gz) = 5b9ec28102538bc3dcb632ee16389ff20dccf4b723186f6ae2da119a1809d84db0d8bcecf9b75c5e2da8427f5543e1da281bbed1a154e529d8a82ea5128c465c
|
SHA512 (systemd-249.5.tar.gz) = d6f1a5a6f03f0ed05b111aee75da509c5868c523af6209f33e630724dd0c7e0d0abf16920795d587e6c31a5915d247ebc613cf26d4aecf39f82ebb0690fab75f
|
||||||
|
13
systemd.spec
13
systemd.spec
@ -30,8 +30,8 @@
|
|||||||
Name: systemd
|
Name: systemd
|
||||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||||
%if %{without inplace}
|
%if %{without inplace}
|
||||||
Version: 249.4
|
Version: 249.5
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
%else
|
%else
|
||||||
# determine the build information from local checkout
|
# determine the build information from local checkout
|
||||||
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
|
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
|
||||||
@ -97,8 +97,6 @@ Patch0003: 0003-rpm-call-needs-restart-in-parallel.patch
|
|||||||
Patch0004: 0004-rpm-restart-user-services-at-the-end-of-the-transact.patch
|
Patch0004: 0004-rpm-restart-user-services-at-the-end-of-the-transact.patch
|
||||||
Patch0005: 0005-update-helper-also-add-user-reexec-verb.patch
|
Patch0005: 0005-update-helper-also-add-user-reexec-verb.patch
|
||||||
|
|
||||||
Patch0006: https://github.com/systemd/systemd/pull/20695.patch
|
|
||||||
|
|
||||||
# Downstream-only patches (5000–9999)
|
# Downstream-only patches (5000–9999)
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
||||||
Patch0500: use-bfq-scheduler.patch
|
Patch0500: use-bfq-scheduler.patch
|
||||||
@ -1001,6 +999,13 @@ fi
|
|||||||
%files standalone-sysusers -f .file-list-standalone-sysusers
|
%files standalone-sysusers -f .file-list-standalone-sysusers
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 12 2021 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 249.5-1
|
||||||
|
- Latest bugfix release (various fixes in systemd-networkd,
|
||||||
|
--timesyncd, -journald, -udev, homed, -resolved, -repart, -oomd,
|
||||||
|
--coredump, systemd itself, seccomp filters, TPM2 handling,
|
||||||
|
-documentation, sd-event, sd-journal, journalctl, and nss-systemd).
|
||||||
|
- Fixes #1976445.
|
||||||
|
|
||||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com>
|
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com>
|
||||||
- Rebuilt with OpenSSL 3.0.0
|
- Rebuilt with OpenSSL 3.0.0
|
||||||
|
|
||||||
|
@ -14,10 +14,10 @@
|
|||||||
# upgraded. We care about the case where a package is initially
|
# upgraded. We care about the case where a package is initially
|
||||||
# installed, because other cases are covered by the *un scriptlets,
|
# installed, because other cases are covered by the *un scriptlets,
|
||||||
# so sometimes we will reload needlessly.
|
# so sometimes we will reload needlessly.
|
||||||
if test -d "/run/systemd/system"; then
|
/usr/lib/systemd/systemd-update-helper system-reload-restart || :
|
||||||
%{_bindir}/systemctl daemon-reload || :
|
|
||||||
%{_bindir}/systemctl reload-or-restart --marked || :
|
%transfiletriggerin -P 900899 -- /usr/lib/systemd/user /etc/systemd/user
|
||||||
fi
|
/usr/lib/systemd/systemd-update-helper user-reload-restart || :
|
||||||
|
|
||||||
%transfiletriggerpostun -P 1000100 -- /usr/lib/systemd/system /etc/systemd/system
|
%transfiletriggerpostun -P 1000100 -- /usr/lib/systemd/system /etc/systemd/system
|
||||||
# On removal, we need to run daemon-reload after any units have been
|
# On removal, we need to run daemon-reload after any units have been
|
||||||
@ -25,36 +25,40 @@ fi
|
|||||||
# On upgrade, we need to run daemon-reload after any new unit files
|
# On upgrade, we need to run daemon-reload after any new unit files
|
||||||
# have been installed, but before %postun scripts in packages get
|
# have been installed, but before %postun scripts in packages get
|
||||||
# executed.
|
# executed.
|
||||||
if test -d "/run/systemd/system"; then
|
/usr/lib/systemd/systemd-update-helper system-reload || :
|
||||||
%{_bindir}/systemctl daemon-reload || :
|
|
||||||
fi
|
%transfiletriggerpostun -P 1000099 -- /usr/lib/systemd/user /etc/systemd/user
|
||||||
|
# Execute daemon-reload in user managers.
|
||||||
|
/usr/lib/systemd/systemd-update-helper user-reload || :
|
||||||
|
|
||||||
%transfiletriggerpostun -P 10000 -- /usr/lib/systemd/system /etc/systemd/system
|
%transfiletriggerpostun -P 10000 -- /usr/lib/systemd/system /etc/systemd/system
|
||||||
# We restart remaining services that should be restarted here.
|
# We restart remaining system services that should be restarted here.
|
||||||
if test -d "/run/systemd/system"; then
|
/usr/lib/systemd/systemd-update-helper system-restart || :
|
||||||
%{_bindir}/systemctl reload-or-restart --marked || :
|
|
||||||
fi
|
%transfiletriggerpostun -P 9999 -- /usr/lib/systemd/user /etc/systemd/user
|
||||||
|
# We restart remaining user services that should be restarted here.
|
||||||
|
/usr/lib/systemd/systemd-update-helper user-restart || :
|
||||||
|
|
||||||
%transfiletriggerin -P 1000700 -- /usr/lib/sysusers.d
|
%transfiletriggerin -P 1000700 -- /usr/lib/sysusers.d
|
||||||
# This script will process files installed in /usr/lib/sysusers.d to create
|
# This script will process files installed in /usr/lib/sysusers.d to create
|
||||||
# specified users automatically. The priority is set such that it
|
# specified users automatically. The priority is set such that it
|
||||||
# will run before the tmpfiles file trigger.
|
# will run before the tmpfiles file trigger.
|
||||||
if test -d "/run/systemd/system"; then
|
if test -d "/run/systemd/system"; then
|
||||||
%{_bindir}/systemd-sysusers || :
|
systemd-sysusers || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%transfiletriggerin -P 1000700 udev -- /usr/lib/udev/hwdb.d
|
%transfiletriggerin -P 1000700 udev -- /usr/lib/udev/hwdb.d
|
||||||
# This script will automatically invoke hwdb update if files have been
|
# This script will automatically invoke hwdb update if files have been
|
||||||
# installed or updated in /usr/lib/udev/hwdb.d.
|
# installed or updated in /usr/lib/udev/hwdb.d.
|
||||||
if test -d "/run/systemd/system"; then
|
if test -d "/run/systemd/system"; then
|
||||||
%{_bindir}/systemd-hwdb update || :
|
systemd-hwdb update || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%transfiletriggerin -P 1000700 -- /usr/lib/systemd/catalog
|
%transfiletriggerin -P 1000700 -- /usr/lib/systemd/catalog
|
||||||
# This script will automatically invoke journal catalog update if files
|
# This script will automatically invoke journal catalog update if files
|
||||||
# have been installed or updated in /usr/lib/systemd/catalog.
|
# have been installed or updated in /usr/lib/systemd/catalog.
|
||||||
if test -d "/run/systemd/system"; then
|
if test -d "/run/systemd/system"; then
|
||||||
%{_bindir}/journalctl --update-catalog || :
|
journalctl --update-catalog || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%transfiletriggerin -P 1000700 -- /usr/lib/binfmt.d
|
%transfiletriggerin -P 1000700 -- /usr/lib/binfmt.d
|
||||||
@ -71,14 +75,14 @@ fi
|
|||||||
# tmpfiles automatically. The priority is set such that it will run
|
# tmpfiles automatically. The priority is set such that it will run
|
||||||
# after the sysusers file trigger, but before any other triggers.
|
# after the sysusers file trigger, but before any other triggers.
|
||||||
if test -d "/run/systemd/system"; then
|
if test -d "/run/systemd/system"; then
|
||||||
%{_bindir}/systemd-tmpfiles --create || :
|
systemd-tmpfiles --create || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%transfiletriggerin -P 1000600 udev -- /usr/lib/udev/rules.d
|
%transfiletriggerin -P 1000600 udev -- /usr/lib/udev/rules.d
|
||||||
# This script will automatically update udev with new rules if files
|
# This script will automatically update udev with new rules if files
|
||||||
# have been installed or updated in /usr/lib/udev/rules.d.
|
# have been installed or updated in /usr/lib/udev/rules.d.
|
||||||
if test -e /run/udev/control; then
|
if test -e /run/udev/control; then
|
||||||
%{_bindir}/udevadm control --reload || :
|
udevadm control --reload || :
|
||||||
fi
|
fi
|
||||||
|
|
||||||
%transfiletriggerin -P 1000500 -- /usr/lib/sysctl.d
|
%transfiletriggerin -P 1000500 -- /usr/lib/sysctl.d
|
||||||
|
Loading…
Reference in New Issue
Block a user