Version 253.2
This commit is contained in:
parent
1320fc3009
commit
7f6f230506
78
265.patch
78
265.patch
@ -1,78 +0,0 @@
|
||||
From e2f169f816809ad4db9ebca080c73b36810f7bdc Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Fri, 3 Mar 2023 16:08:41 +0100
|
||||
Subject: [PATCH] meson: adjust for removal of gnu-efi compat
|
||||
|
||||
gnu-efi-3.0.11-13.fc39 in Fedora dropped the old include paths.
|
||||
|
||||
/usr/include/efi/efi.h uses 'include "efibind.h"', so we cannot use -isystem.
|
||||
---
|
||||
src/boot/efi/meson.build | 26 +++++++++++++++-----------
|
||||
1 file changed, 15 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/src/boot/efi/meson.build b/src/boot/efi/meson.build
|
||||
index 6c1934d9f1..68c5dd15dc 100644
|
||||
--- a/src/boot/efi/meson.build
|
||||
+++ b/src/boot/efi/meson.build
|
||||
@@ -19,7 +19,7 @@ elif efi_arch == 'x86_64' and '-m32' in get_option('efi-cflags')
|
||||
efi_arch = 'x86'
|
||||
endif
|
||||
efi_arch = {
|
||||
- # host_cc_arch: [efi_arch (see Table 3-2 in UEFI spec), gnu_efi_inc_arch]
|
||||
+ # host_cc_arch: [efi_arch (see Table 3-2 in UEFI spec), obsolete gnu_efi_inc_arch]
|
||||
'x86': ['ia32', 'ia32'],
|
||||
'x86_64': ['x64', 'x86_64'],
|
||||
'arm': ['arm', 'arm'],
|
||||
@@ -28,14 +28,17 @@ efi_arch = {
|
||||
}.get(efi_arch, [])
|
||||
|
||||
efi_incdir = get_option('efi-includedir')
|
||||
-if efi_arch.length() > 0 and not cc.has_header(
|
||||
- '@0@/@1@/efibind.h'.format(efi_incdir, efi_arch[1]),
|
||||
- args: get_option('efi-cflags'))
|
||||
-
|
||||
- efi_arch = []
|
||||
-endif
|
||||
+found = false
|
||||
+foreach efi_arch_candidate : efi_arch
|
||||
+ efi_archdir = efi_incdir / efi_arch_candidate
|
||||
+ if cc.has_header(efi_archdir / 'efibind.h',
|
||||
+ args: get_option('efi-cflags'))
|
||||
+ found = true
|
||||
+ break
|
||||
+ endif
|
||||
+endforeach
|
||||
|
||||
-if efi_arch.length() == 0
|
||||
+if not found
|
||||
if get_option('gnu-efi') == 'true'
|
||||
error('gnu-efi support requested, but headers not found or efi arch is unknown')
|
||||
endif
|
||||
@@ -45,7 +48,8 @@ endif
|
||||
|
||||
if not cc.has_header_symbol('efi.h', 'EFI_IMAGE_MACHINE_X64',
|
||||
args: ['-nostdlib', '-ffreestanding', '-fshort-wchar'] + get_option('efi-cflags'),
|
||||
- include_directories: include_directories(efi_incdir, efi_incdir / efi_arch[1]))
|
||||
+ include_directories: include_directories(efi_incdir,
|
||||
+ efi_archdir))
|
||||
|
||||
if get_option('gnu-efi') == 'true'
|
||||
error('gnu-efi support requested, but found headers are too old (3.0.5+ required)')
|
||||
@@ -184,7 +188,7 @@ efi_cflags = [
|
||||
'-I', meson.current_source_dir(),
|
||||
'-include', efi_config_h,
|
||||
'-include', version_h,
|
||||
- '-isystem', efi_incdir / efi_arch[1],
|
||||
+ '-I', efi_archdir,
|
||||
'-isystem', efi_incdir,
|
||||
'-std=gnu11',
|
||||
'-Wall',
|
||||
@@ -315,7 +319,7 @@ summary({
|
||||
'EFI LD' : efi_ld,
|
||||
'EFI lds' : efi_lds,
|
||||
'EFI crt0' : efi_crt0,
|
||||
- 'EFI include directory' : efi_incdir},
|
||||
+ 'EFI include directory' : efi_archdir},
|
||||
section : 'Extensible Firmware Interface')
|
||||
|
||||
if efi_conf.get('SBAT_DISTRO', '') != ''
|
@ -1,36 +0,0 @@
|
||||
From 465d48dfa23ef01ce1888e440f24b3d22d633a60 Mon Sep 17 00:00:00 2001
|
||||
From: Samanta Navarro <ferivoz@riseup.net>
|
||||
Date: Thu, 16 Feb 2023 11:59:05 +0000
|
||||
Subject: [PATCH] bootctl: Fix debug messages
|
||||
|
||||
Remove duplicate KERNEL_INSTALL_MACHINE_ID from message and also
|
||||
specify the correct origin of layout variable.
|
||||
|
||||
Signed-off-by: Samanta Navarro <ferivoz@riseup.net>
|
||||
(cherry picked from commit 2d5ccb0818a7c9fdc280eb84478a6b89cd46b6fe)
|
||||
---
|
||||
src/boot/bootctl-install.c | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/boot/bootctl-install.c b/src/boot/bootctl-install.c
|
||||
index c795e75bc3..ebb0d486c9 100644
|
||||
--- a/src/boot/bootctl-install.c
|
||||
+++ b/src/boot/bootctl-install.c
|
||||
@@ -67,7 +67,7 @@ static int load_etc_machine_info(void) {
|
||||
if (r < 0)
|
||||
return log_error_errno(r, "Failed to parse KERNEL_INSTALL_MACHINE_ID=%s in /etc/machine-info: %m", s);
|
||||
|
||||
- log_debug("Loaded KERNEL_INSTALL_MACHINE_ID=%s from KERNEL_INSTALL_MACHINE_ID in /etc/machine-info.",
|
||||
+ log_debug("Loaded KERNEL_INSTALL_MACHINE_ID=%s from /etc/machine-info.",
|
||||
SD_ID128_TO_STRING(arg_machine_id));
|
||||
}
|
||||
|
||||
@@ -98,7 +98,7 @@ static int load_etc_kernel_install_conf(void) {
|
||||
return log_error_errno(r, "Failed to parse %s: %m", p);
|
||||
|
||||
if (!isempty(layout)) {
|
||||
- log_debug("layout=%s is specified in /etc/machine-info.", layout);
|
||||
+ log_debug("layout=%s is specified in %s.", layout, p);
|
||||
free_and_replace(arg_install_layout, layout);
|
||||
}
|
||||
|
@ -1,40 +0,0 @@
|
||||
From fef2e88b92287aa97ce21eee22aca0c74dfa6570 Mon Sep 17 00:00:00 2001
|
||||
From: Frantisek Sumsal <frantisek@sumsal.cz>
|
||||
Date: Fri, 3 Mar 2023 12:17:27 +0100
|
||||
Subject: [PATCH] systemctl: explicitly cast the constants to uint64_t
|
||||
|
||||
Otherwise under certain conditions `va_arg()` might get garbage instead
|
||||
of the expected value, i.e.:
|
||||
|
||||
$ sudo build-o0/systemctl disable asdfasfaf
|
||||
sd_bus_message_appendv: Got uint64_t: 0
|
||||
Failed to disable unit: Unit file asdfasfaf.service does not exist.
|
||||
|
||||
$ sudo build-o1/systemctl disable asdfasfaf
|
||||
sd_bus_message_appendv: Got uint64_t: 7954875719681572864
|
||||
Failed to disable unit: Invalid argument
|
||||
|
||||
(reproduced on an armv7hl machine)
|
||||
|
||||
Resolves: #26568
|
||||
Follow-up to: bf1bea43f15
|
||||
Related issue: https://github.com/systemd/systemd/pull/14470#discussion_r362893735
|
||||
|
||||
(cherry picked from commit c63bfd0884cf20e48befbee49d41f667660a8802)
|
||||
---
|
||||
src/systemctl/systemctl-enable.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/systemctl/systemctl-enable.c b/src/systemctl/systemctl-enable.c
|
||||
index 86d9f602fa..f94a286122 100644
|
||||
--- a/src/systemctl/systemctl-enable.c
|
||||
+++ b/src/systemctl/systemctl-enable.c
|
||||
@@ -211,7 +211,7 @@ int verb_enable(int argc, char *argv[], void *userdata) {
|
||||
|
||||
if (send_runtime) {
|
||||
if (streq(method, "DisableUnitFilesWithFlagsAndInstallInfo"))
|
||||
- r = sd_bus_message_append(m, "t", arg_runtime ? UNIT_FILE_RUNTIME : 0);
|
||||
+ r = sd_bus_message_append(m, "t", arg_runtime ? (uint64_t) UNIT_FILE_RUNTIME : UINT64_C(0));
|
||||
else
|
||||
r = sd_bus_message_append(m, "b", arg_runtime);
|
||||
if (r < 0)
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (systemd-253.1.tar.gz) = 4ac7607e0fcedd8612b525ab1fb05e3f5f569d8c1e609577377a54ea8f2aedd07def4012dad70b68a9c449ec7b8d70c6b96cbdafc11c35eb4408e43fc7bb401c
|
||||
SHA512 (systemd-253.2.tar.gz) = bfa8d232055603beb851156cc4dac3f8efa89da648114f97d0e62a4b9d3fda5ce6dd2358eb056c766d475c560645638ea8041794e03a7950613b791e69820280
|
||||
|
@ -28,7 +28,7 @@
|
||||
Name: systemd
|
||||
Url: https://systemd.io
|
||||
%if %{without inplace}
|
||||
Version: 253.1
|
||||
Version: 253.2
|
||||
%else
|
||||
# determine the build information from local checkout
|
||||
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
|
||||
@ -95,11 +95,6 @@ GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2164404
|
||||
Patch0001: https://github.com/systemd/systemd/pull/26494.patch
|
||||
|
||||
# Fix build with gnu-efi-3.0.11-13.fc39
|
||||
Patch0002: https://github.com/systemd/systemd-stable/pull/265.patch
|
||||
|
||||
Patch0003: https://github.com/systemd/systemd-stable/commit/fef2e88b92287aa97ce21eee22aca0c74dfa6570.patch
|
||||
Patch0004: https://github.com/systemd/systemd-stable/commit/465d48dfa23ef01ce1888e440f24b3d22d633a60.patch
|
||||
|
||||
# Those are downstream-only patches, but we don't want them in packit builds:
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
||||
|
Loading…
Reference in New Issue
Block a user