don't build the gtk parts anymore
The GTK apps are moving into the systemd-ui package. Remove a dead patch file.
This commit is contained in:
parent
87c59bda26
commit
7de90b3c5a
@ -1,13 +0,0 @@
|
|||||||
diff --git a/src/journal/sd-journal.c b/src/journal/sd-journal.c
|
|
||||||
index 5e1fd47..baf51db 100644
|
|
||||||
--- a/src/journal/sd-journal.c
|
|
||||||
+++ b/src/journal/sd-journal.c
|
|
||||||
@@ -66,7 +66,7 @@ static void init_location(Location *l, JournalFile *f, Object *o) {
|
|
||||||
l->seqnum_id = f->header->seqnum_id;
|
|
||||||
l->realtime = le64toh(o->entry.realtime);
|
|
||||||
l->monotonic = le64toh(o->entry.monotonic);
|
|
||||||
- l->boot_id = le64toh(o->entry.boot_id);
|
|
||||||
+ l->boot_id = o->entry.boot_id;
|
|
||||||
l->xor_hash = le64toh(o->entry.xor_hash);
|
|
||||||
|
|
||||||
l->seqnum_set = l->realtime_set = l->monotonic_set = l->xor_hash_set = true;
|
|
26
systemd.spec
26
systemd.spec
@ -3,7 +3,7 @@
|
|||||||
Name: systemd
|
Name: systemd
|
||||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 44
|
Version: 44
|
||||||
Release: 1%{?gitcommit:.git%{gitcommit}}%{?dist}
|
Release: 2%{?gitcommit:.git%{gitcommit}}%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Summary: A System and Service Manager
|
Summary: A System and Service Manager
|
||||||
@ -15,14 +15,10 @@ BuildRequires: pam-devel
|
|||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
BuildRequires: audit-libs-devel
|
BuildRequires: audit-libs-devel
|
||||||
BuildRequires: cryptsetup-luks-devel
|
BuildRequires: cryptsetup-luks-devel
|
||||||
|
BuildRequires: dbus-devel
|
||||||
BuildRequires: libxslt
|
BuildRequires: libxslt
|
||||||
BuildRequires: docbook-style-xsl
|
BuildRequires: docbook-style-xsl
|
||||||
BuildRequires: vala >= 0.11
|
|
||||||
BuildRequires: pkgconfig
|
BuildRequires: pkgconfig
|
||||||
BuildRequires: gtk2-devel
|
|
||||||
BuildRequires: glib2-devel
|
|
||||||
BuildRequires: libgee06-devel
|
|
||||||
BuildRequires: libnotify-devel >= 0.7
|
|
||||||
BuildRequires: libacl-devel
|
BuildRequires: libacl-devel
|
||||||
BuildRequires: intltool >= 0.40.0
|
BuildRequires: intltool >= 0.40.0
|
||||||
BuildRequires: gperf
|
BuildRequires: gperf
|
||||||
@ -94,15 +90,6 @@ Requires: %{name} = %{version}-%{release}
|
|||||||
%description devel
|
%description devel
|
||||||
Development headers and auxiliary files for developing applications for systemd.
|
Development headers and auxiliary files for developing applications for systemd.
|
||||||
|
|
||||||
%package gtk
|
|
||||||
Group: System Environment/Base
|
|
||||||
Summary: Graphical frontend for systemd
|
|
||||||
Requires: %{name} = %{version}-%{release}
|
|
||||||
Requires: polkit
|
|
||||||
|
|
||||||
%description gtk
|
|
||||||
Graphical front-end for systemd.
|
|
||||||
|
|
||||||
%package sysv
|
%package sysv
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Summary: SysV tools for systemd
|
Summary: SysV tools for systemd
|
||||||
@ -372,11 +359,6 @@ fi
|
|||||||
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel4.target
|
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel4.target
|
||||||
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel5.target
|
%ghost %config(noreplace) %{_sysconfdir}/systemd/system/runlevel5.target
|
||||||
|
|
||||||
%files gtk
|
|
||||||
%{_bindir}/systemadm
|
|
||||||
%{_bindir}/systemd-gnome-ask-password-agent
|
|
||||||
%{_mandir}/man1/systemadm.*
|
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_libdir}/libsystemd-daemon.so
|
%{_libdir}/libsystemd-daemon.so
|
||||||
%{_libdir}/libsystemd-login.so
|
%{_libdir}/libsystemd-login.so
|
||||||
@ -400,6 +382,10 @@ fi
|
|||||||
%{_bindir}/systemd-analyze
|
%{_bindir}/systemd-analyze
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 20 2012 Michal Schmidt <mschmidt@redhat.com> - 44-2
|
||||||
|
- Don't build the gtk parts anymore. They're moving into systemd-ui.
|
||||||
|
- Remove a dead patch file.
|
||||||
|
|
||||||
* Fri Mar 16 2012 Lennart Poettering <lpoetter@redhat.com> - 44-1
|
* Fri Mar 16 2012 Lennart Poettering <lpoetter@redhat.com> - 44-1
|
||||||
- New upstream release
|
- New upstream release
|
||||||
- Closes #798760, #784921, #783134, #768523, #781735
|
- Closes #798760, #784921, #783134, #768523, #781735
|
||||||
|
Loading…
Reference in New Issue
Block a user