parent
95c9cf61af
commit
7d3e9ecfd7
34
23352.patch
Normal file
34
23352.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From 8b0ebe3aa21fc343e435b7ff72cbf8565149ef00 Mon Sep 17 00:00:00 2001
|
||||
From: Yu Watanabe <watanabe.yu+github@gmail.com>
|
||||
Date: Thu, 12 May 2022 04:11:37 +0900
|
||||
Subject: [PATCH] sd-device-enumerator: fix inverted return value of
|
||||
match_initialized()
|
||||
|
||||
Fixes a bug introduced by d8b50e5df7e01983279e70c6d970fb60d053df97.
|
||||
|
||||
Fixes https://github.com/systemd/systemd/pull/22662#issuecomment-1124163773.
|
||||
Fixes RHBZ#2083374 (https://bugzilla.redhat.com/show_bug.cgi?id=2083374).
|
||||
---
|
||||
src/libsystemd/sd-device/device-enumerator.c | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/libsystemd/sd-device/device-enumerator.c b/src/libsystemd/sd-device/device-enumerator.c
|
||||
index 3af9e36a5a52..39f769c35cf6 100644
|
||||
--- a/src/libsystemd/sd-device/device-enumerator.c
|
||||
+++ b/src/libsystemd/sd-device/device-enumerator.c
|
||||
@@ -537,12 +537,12 @@ static int match_initialized(sd_device_enumerator *enumerator, sd_device *device
|
||||
return true;
|
||||
|
||||
if (sd_device_get_devnum(device, NULL) >= 0)
|
||||
- return true;
|
||||
+ return false;
|
||||
|
||||
if (sd_device_get_ifindex(device, NULL) >= 0)
|
||||
- return true;
|
||||
+ return false;
|
||||
|
||||
- return false;
|
||||
+ return true;
|
||||
}
|
||||
|
||||
return (enumerator->match_initialized == MATCH_INITIALIZED_NO) == (r == 0);
|
10
systemd.spec
10
systemd.spec
@ -31,7 +31,7 @@ Name: systemd
|
||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||
%if %{without inplace}
|
||||
Version: 251~rc2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
%else
|
||||
# determine the build information from local checkout
|
||||
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
|
||||
@ -91,6 +91,11 @@ GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[
|
||||
# than in the next section. Packit CI will drop any patches in this range before
|
||||
# applying upstream pull requests.
|
||||
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=2083374
|
||||
# https://github.com/systemd/systemd/pull/23352
|
||||
# udev: don't report network devices before interface rename
|
||||
Patch0001: 23352.patch
|
||||
|
||||
# This is a downstream-only patch, but we don't want it in packit builds.
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1738828
|
||||
Patch0499: use-bfq-scheduler.patch
|
||||
@ -1018,6 +1023,9 @@ fi
|
||||
%files standalone-sysusers -f .file-list-standalone-sysusers
|
||||
|
||||
%changelog
|
||||
* Wed May 11 2022 Adam Williamson <awilliam@redhat.com> - 251~rc2-2
|
||||
- Backport #23352 to fix RHBZ #2083374
|
||||
|
||||
* Thu May 5 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 251~rc2-1
|
||||
- New upstream prerelease, for details see
|
||||
https://raw.githubusercontent.com/systemd/systemd/v251-rc2/NEWS.
|
||||
|
Loading…
Reference in New Issue
Block a user