New upstream release
This commit is contained in:
parent
d6c21f703a
commit
6f406094c0
@ -1,26 +0,0 @@
|
||||
From 216bd4cea37c101254956f0819baa1dfbd4ee3b3 Mon Sep 17 00:00:00 2001
|
||||
From: Lennart Poettering <lennart@poettering.net>
|
||||
Date: Thu, 12 Aug 2010 04:23:54 +0200
|
||||
Subject: [PATCH] plymouth: call plymouth quit before running the getty, not after
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=623430
|
||||
---
|
||||
units/fedora/plymouth-quit.service | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/units/fedora/plymouth-quit.service b/units/fedora/plymouth-quit.service
|
||||
index e676eca..faf8b4d 100644
|
||||
--- a/units/fedora/plymouth-quit.service
|
||||
+++ b/units/fedora/plymouth-quit.service
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
[Unit]
|
||||
Description=Terminate Plymouth Boot Screen
|
||||
-After=getty@tty1.service
|
||||
+Before=getty@tty1.service
|
||||
|
||||
[Service]
|
||||
ExecStart=-/usr/bin/plymouth quit
|
||||
--
|
||||
1.7.0.1
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 145b66acab96f3a51696e8402d8cb21153868d7c Mon Sep 17 00:00:00 2001
|
||||
From: Lennart Poettering <lennart@poettering.net>
|
||||
Date: Thu, 12 Aug 2010 17:14:20 +0200
|
||||
Subject: [PATCH] unit: move prefdm after livesys
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=623561
|
||||
---
|
||||
units/fedora/prefdm.service | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/units/fedora/prefdm.service b/units/fedora/prefdm.service
|
||||
index 49c06a6..233e00d 100644
|
||||
--- a/units/fedora/prefdm.service
|
||||
+++ b/units/fedora/prefdm.service
|
||||
@@ -7,7 +7,7 @@
|
||||
|
||||
[Unit]
|
||||
Description=Display Manager
|
||||
-After=syslog.target haldaemon.service
|
||||
+After=syslog.target haldaemon.service livesys-late.service
|
||||
|
||||
# On Fedora gdm/X11 is on tty1. We explicitly cancel the getty here to
|
||||
# avoid any races around that.
|
||||
--
|
||||
1.7.0.1
|
||||
|
23
systemd.spec
23
systemd.spec
@ -1,8 +1,8 @@
|
||||
Name: systemd
|
||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Version: 7
|
||||
Release: 3%{?dist}
|
||||
Version: 8
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: A System and Session Manager
|
||||
@ -26,11 +26,9 @@ Requires: udev >= 160
|
||||
Requires: libudev >= 160
|
||||
Requires: initscripts
|
||||
Requires: selinux-policy >= 3.8.7
|
||||
Requires: kernel >= 2.6.35.2-9.fc14
|
||||
Source0: http://www.freedesktop.org/software/systemd/%{name}-%{version}.tar.bz2
|
||||
|
||||
Patch0: 0001-plymouth-call-plymouth-quit-before-running-the-getty.patch
|
||||
Patch1: 0001-unit-move-prefdm-after-livesys.patch
|
||||
|
||||
%description
|
||||
systemd is a system and session manager for Linux, compatible with
|
||||
SysV and LSB init scripts. systemd provides aggressive parallelization
|
||||
@ -79,8 +77,6 @@ Drop-in replacement for the System V init tools of systemd.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
%configure --with-rootdir= --with-distro=fedora
|
||||
@ -110,6 +106,9 @@ rm -r %{buildroot}/etc/systemd/system/*.target.wants
|
||||
# And the default symlink we generate automatically based on inittab
|
||||
rm %{buildroot}/etc/systemd/system/default.target
|
||||
|
||||
sed -i -e 's/^#MountAuto=yes$/MountAuto=no/' \
|
||||
-e 's/^#SwapAuto=yes$/SwapAuto=no/' %{buildroot}/etc/systemd/system.conf
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
@ -186,9 +185,6 @@ fi
|
||||
%{_datadir}/dbus-1/interfaces/org.freedesktop.systemd1.*.xml
|
||||
%{_docdir}/systemd
|
||||
|
||||
# Joint ownership with libcgroup
|
||||
%dir /cgroup
|
||||
|
||||
%files units
|
||||
%defattr(-,root,root,-)
|
||||
%dir %{_sysconfdir}/systemd
|
||||
@ -197,10 +193,6 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/ctrl-alt-del.target
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/display-manager.service
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/kbrequest.target
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/runlevel2.target
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/runlevel3.target
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/runlevel4.target
|
||||
%config(noreplace) %{_sysconfdir}/systemd/system/runlevel5.target
|
||||
%dir /lib/systemd
|
||||
/lib/systemd/system
|
||||
/bin/systemctl
|
||||
@ -231,6 +223,9 @@ fi
|
||||
%{_mandir}/man8/runlevel.*
|
||||
|
||||
%changelog
|
||||
* Wed Aug 25 2010 Lennart Poettering <lpoetter@redhat.com> - 8-1
|
||||
- New upstream release
|
||||
|
||||
* Thu Aug 12 2010 Lennart Poettering <lpoetter@redhat.com> - 7-3
|
||||
- Fix https://bugzilla.redhat.com/show_bug.cgi?id=623561
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user