Version 231
This commit is contained in:
parent
1ed18e5e9d
commit
6153dd9122
@ -1,7 +1,7 @@
|
|||||||
From 4e14900fe25c53275c7d7d0c094ddf1fd477e5ed Mon Sep 17 00:00:00 2001
|
From 108c060c5521309b9448e3a7905b50dd505f36a8 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||||
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
||||||
Subject: [PATCH 1/2] resolved: create /etc/resolv.conf symlink at runtime
|
Subject: [PATCH] resolved: create /etc/resolv.conf symlink at runtime
|
||||||
|
|
||||||
If the symlink doesn't exists, and we are being started, let's
|
If the symlink doesn't exists, and we are being started, let's
|
||||||
create it to provie name resolution.
|
create it to provie name resolution.
|
||||||
@ -18,7 +18,7 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1313085
|
|||||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
||||||
index 161ea03412..ea6750e949 100644
|
index deb75f9ae5..914d3b8a2d 100644
|
||||||
--- a/src/resolve/resolved.c
|
--- a/src/resolve/resolved.c
|
||||||
+++ b/src/resolve/resolved.c
|
+++ b/src/resolve/resolved.c
|
||||||
@@ -67,6 +67,10 @@ int main(int argc, char *argv[]) {
|
@@ -67,6 +67,10 @@ int main(int argc, char *argv[]) {
|
||||||
@ -29,11 +29,11 @@ index 161ea03412..ea6750e949 100644
|
|||||||
+ if (r < 0 && errno != EEXIST)
|
+ if (r < 0 && errno != EEXIST)
|
||||||
+ log_warning_errno(errno, "Could not create /etc/resolv.conf symlink: %m");
|
+ log_warning_errno(errno, "Could not create /etc/resolv.conf symlink: %m");
|
||||||
+
|
+
|
||||||
r = drop_privileges(uid, gid, 0);
|
/* Drop privileges, but keep three caps. Note that we drop those too, later on (see below) */
|
||||||
if (r < 0)
|
r = drop_privileges(uid, gid,
|
||||||
goto finish;
|
(UINT64_C(1) << CAP_NET_RAW)| /* needed for SO_BINDTODEVICE */
|
||||||
diff --git a/tmpfiles.d/etc.conf.m4 b/tmpfiles.d/etc.conf.m4
|
diff --git a/tmpfiles.d/etc.conf.m4 b/tmpfiles.d/etc.conf.m4
|
||||||
index ef7b9b9541..928105ea8d 100644
|
index 064eae94f1..928105ea8d 100644
|
||||||
--- a/tmpfiles.d/etc.conf.m4
|
--- a/tmpfiles.d/etc.conf.m4
|
||||||
+++ b/tmpfiles.d/etc.conf.m4
|
+++ b/tmpfiles.d/etc.conf.m4
|
||||||
@@ -13,9 +13,6 @@ L+ /etc/mtab - - - - ../proc/self/mounts
|
@@ -13,9 +13,6 @@ L+ /etc/mtab - - - - ../proc/self/mounts
|
||||||
@ -41,11 +41,11 @@ index ef7b9b9541..928105ea8d 100644
|
|||||||
t /etc/mtab - - - - security.SMACK64=_
|
t /etc/mtab - - - - security.SMACK64=_
|
||||||
)m4_dnl
|
)m4_dnl
|
||||||
-m4_ifdef(`ENABLE_RESOLVED',
|
-m4_ifdef(`ENABLE_RESOLVED',
|
||||||
-L! /etc/resolv.conf - - - - ../run/systemd/resolve/resolv.conf
|
-L! /etc/resolv.conf - - - - ../usr/lib/systemd/resolv.conf
|
||||||
-)m4_dnl
|
-)m4_dnl
|
||||||
C /etc/nsswitch.conf - - - -
|
C /etc/nsswitch.conf - - - -
|
||||||
m4_ifdef(`HAVE_PAM',
|
m4_ifdef(`HAVE_PAM',
|
||||||
C /etc/pam.d - - - -
|
C /etc/pam.d - - - -
|
||||||
--
|
--
|
||||||
2.7.2
|
2.9.2
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
cc3ab3f02aced98a2778b5d01d09cddf systemd-ea68351.tar.gz
|
e6fa7f4a9c06f0427ff0539a90c69390 systemd-231.tar.gz
|
||||||
|
18
systemd.spec
18
systemd.spec
@ -1,5 +1,5 @@
|
|||||||
%global gitcommit ea683512f9b82f2257770f0ed56d819eea230fc2
|
#global gitcommit ea683512f9b82f2257770f0ed56d819eea230fc2
|
||||||
%global gitcommitshort %(c=%{gitcommit}; echo ${c:0:7})
|
#global gitcommitshort %(c=%{gitcommit}; echo ${c:0:7})
|
||||||
|
|
||||||
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
||||||
# strip the automatically generated dep here and instead co-own the
|
# strip the automatically generated dep here and instead co-own the
|
||||||
@ -11,8 +11,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 230
|
Version: 231
|
||||||
Release: 3%{?gitcommit:.git%{gitcommitshort}}%{?dist}
|
Release: 1%{?gitcommit:.git%{gitcommitshort}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: A System and Service Manager
|
Summary: A System and Service Manager
|
||||||
@ -239,8 +239,6 @@ CONFIGURE_OPTS=(
|
|||||||
--with-sysvinit-path=/etc/rc.d/init.d
|
--with-sysvinit-path=/etc/rc.d/init.d
|
||||||
--with-rc-local-script-path-start=/etc/rc.d/rc.local
|
--with-rc-local-script-path-start=/etc/rc.d/rc.local
|
||||||
--with-ntp-servers='0.%{ntpvendor}.pool.ntp.org 1.%{ntpvendor}.pool.ntp.org 2.%{ntpvendor}.pool.ntp.org 3.%{ntpvendor}.pool.ntp.org'
|
--with-ntp-servers='0.%{ntpvendor}.pool.ntp.org 1.%{ntpvendor}.pool.ntp.org 2.%{ntpvendor}.pool.ntp.org 3.%{ntpvendor}.pool.ntp.org'
|
||||||
--disable-kdbus
|
|
||||||
--disable-terminal
|
|
||||||
--without-kill-user-processes
|
--without-kill-user-processes
|
||||||
)
|
)
|
||||||
|
|
||||||
@ -255,6 +253,9 @@ make %{?_smp_mflags} GCC_COLORS="" V=1
|
|||||||
|
|
||||||
find %{buildroot} \( -name '*.a' -o -name '*.la' \) -delete
|
find %{buildroot} \( -name '*.a' -o -name '*.la' \) -delete
|
||||||
|
|
||||||
|
# remove .so file for the shared library, it's not supposed to be used
|
||||||
|
rm %{buildroot}%{pkgdir}/libsystemd-shared.so
|
||||||
|
|
||||||
# udev links
|
# udev links
|
||||||
mkdir -p %{buildroot}/%{_sbindir}
|
mkdir -p %{buildroot}/%{_sbindir}
|
||||||
ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
|
ln -sf ../bin/udevadm %{buildroot}%{_sbindir}/udevadm
|
||||||
@ -617,8 +618,10 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_bindir}/localectl
|
%{_bindir}/localectl
|
||||||
%{_bindir}/timedatectl
|
%{_bindir}/timedatectl
|
||||||
%{pkgdir}/systemd
|
%{pkgdir}/systemd
|
||||||
|
%{pkgdir}/libsystemd-shared-%{version}.so
|
||||||
%{system_unit_dir}
|
%{system_unit_dir}
|
||||||
%{pkgdir}/user
|
%{pkgdir}/user
|
||||||
|
%{pkgdir}/resolv.conf
|
||||||
%exclude %{system_unit_dir}/*udev*
|
%exclude %{system_unit_dir}/*udev*
|
||||||
%exclude %{system_unit_dir}/*/*udev*
|
%exclude %{system_unit_dir}/*/*udev*
|
||||||
%exclude %{system_unit_dir}/*hwdb*
|
%exclude %{system_unit_dir}/*hwdb*
|
||||||
@ -926,6 +929,9 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_mandir}/man[1578]/systemd-nspawn.*
|
%{_mandir}/man[1578]/systemd-nspawn.*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jul 26 2016 Zbigniew Jędrzejewski-Szmek <zbyszek@bupkis> - 231-1
|
||||||
|
- Update to latest version
|
||||||
|
|
||||||
* Wed Jun 8 2016 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 230-3
|
* Wed Jun 8 2016 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 230-3
|
||||||
- Update to latest git snapshot (fixes for systemctl set-default,
|
- Update to latest git snapshot (fixes for systemctl set-default,
|
||||||
polkit lingering policy, reversal of the framebuffer rules,
|
polkit lingering policy, reversal of the framebuffer rules,
|
||||||
|
Loading…
Reference in New Issue
Block a user