import systemd-239-51.el8_5.2
This commit is contained in:
parent
02cc916713
commit
5a26f68386
@ -1,27 +0,0 @@
|
||||
From 21c071fbd05d112ccd92b7a49e53bf8d38cdbd06 Mon Sep 17 00:00:00 2001
|
||||
From: David Tardon <dtardon@redhat.com>
|
||||
Date: Wed, 8 Dec 2021 09:49:24 +0100
|
||||
Subject: [PATCH] Do not fail if the same alt. name is set again
|
||||
|
||||
This is a workaround for a kernel bug.
|
||||
|
||||
RHEL-only
|
||||
|
||||
Resolves: #2030027
|
||||
---
|
||||
src/udev/net/link-config.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/udev/net/link-config.c b/src/udev/net/link-config.c
|
||||
index 5220f247f0..9046c5bd2a 100644
|
||||
--- a/src/udev/net/link-config.c
|
||||
+++ b/src/udev/net/link-config.c
|
||||
@@ -526,7 +526,7 @@ int link_config_apply(link_config_ctx *ctx, link_config *config,
|
||||
strv_uniq(altnames);
|
||||
strv_sort(altnames);
|
||||
r = rtnl_set_link_alternative_names(&ctx->rtnl, ifindex, altnames);
|
||||
- if (r == -EOPNOTSUPP)
|
||||
+ if (IN_SET(r, -EOPNOTSUPP, -EEXIST))
|
||||
log_debug_errno(r, "Could not set AlternativeName= or apply AlternativeNamesPolicy= on %s, ignoring: %m", old_name);
|
||||
else if (r < 0)
|
||||
return log_warning_errno(r, "Could not set AlternativeName= or apply AlternativeNamesPolicy= on %s: %m", old_name);
|
@ -1,38 +0,0 @@
|
||||
From 0e03f2192cd80e6a4a1bf83f0238cc6d133b8475 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Thu, 7 Nov 2019 11:32:26 +0100
|
||||
Subject: [PATCH] meson: avoid bogus meson warning
|
||||
|
||||
With meson-0.52.0-1.module_f31+6771+f5d842eb.noarch I get:
|
||||
src/test/meson.build:19: WARNING: Overriding previous value of environment variable 'PATH' with a new one
|
||||
|
||||
When we're using *prepend*, the whole point is to modify an existing variable,
|
||||
so meson shouldn't warn. But let's set avoid the warning and shorten things by
|
||||
setting the final value immediately.
|
||||
|
||||
(cherry picked from commit cbe804947482998cc767bfb0c169e6263a6ef097)
|
||||
|
||||
Related: #2030027
|
||||
---
|
||||
src/test/meson.build | 5 ++---
|
||||
1 file changed, 2 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/test/meson.build b/src/test/meson.build
|
||||
index 7b310d4ec7..4bbc67d367 100644
|
||||
--- a/src/test/meson.build
|
||||
+++ b/src/test/meson.build
|
||||
@@ -10,12 +10,11 @@ test_hashmap_ordered_c = custom_target(
|
||||
|
||||
test_include_dir = include_directories('.')
|
||||
|
||||
-path = run_command('sh', ['-c', 'echo "$PATH"']).stdout()
|
||||
+path = run_command('sh', ['-c', 'echo "$PATH"']).stdout().strip()
|
||||
test_env = environment()
|
||||
test_env.set('SYSTEMD_KBD_MODEL_MAP', kbd_model_map)
|
||||
test_env.set('SYSTEMD_LANGUAGE_FALLBACK_MAP', language_fallback_map)
|
||||
-test_env.set('PATH', path)
|
||||
-test_env.prepend('PATH', meson.build_root())
|
||||
+test_env.set('PATH', '@0@:@1@'.format(meson.build_root(), path))
|
||||
|
||||
############################################################
|
||||
|
@ -1,54 +0,0 @@
|
||||
From 112de8e094470d2a8df4f7c9b8ca62bd68c96a70 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||
Date: Mon, 12 Apr 2021 14:03:32 +0200
|
||||
Subject: [PATCH] meson: do not fail if rsync is not installed with meson
|
||||
0.57.2
|
||||
|
||||
https://github.com/mesonbuild/meson/issues/8641
|
||||
|
||||
Our CI started to fail. Even if the change is reverted in meson,
|
||||
we need a quick workaround here.
|
||||
|
||||
(cherry picked from commit 7c5fd25119a495009ea62f79e5daec34cc464628)
|
||||
|
||||
Related: #2030027
|
||||
---
|
||||
man/meson.build | 25 ++++++++++++++-----------
|
||||
1 file changed, 14 insertions(+), 11 deletions(-)
|
||||
|
||||
diff --git a/man/meson.build b/man/meson.build
|
||||
index a953d34098..efc8836d0c 100644
|
||||
--- a/man/meson.build
|
||||
+++ b/man/meson.build
|
||||
@@ -178,17 +178,20 @@ html = custom_target(
|
||||
depends : html_pages,
|
||||
command : ['echo'])
|
||||
|
||||
-run_target(
|
||||
- 'doc-sync',
|
||||
- depends : man_pages + html_pages,
|
||||
- command : ['rsync', '-rlv',
|
||||
- '--delete-excluded',
|
||||
- '--include=man',
|
||||
- '--include=*.html',
|
||||
- '--exclude=*',
|
||||
- '--omit-dir-times',
|
||||
- meson.current_build_dir(),
|
||||
- get_option('www-target')])
|
||||
+rsync = find_program('rsync', required : false)
|
||||
+if rsync.found()
|
||||
+ run_target(
|
||||
+ 'doc-sync',
|
||||
+ depends : man_pages + html_pages,
|
||||
+ command : [rsync, '-rlv',
|
||||
+ '--delete-excluded',
|
||||
+ '--include=man',
|
||||
+ '--include=*.html',
|
||||
+ '--exclude=*',
|
||||
+ '--omit-dir-times',
|
||||
+ meson.current_build_dir(),
|
||||
+ get_option('www-target')])
|
||||
+endif
|
||||
|
||||
############################################################
|
||||
|
@ -13,7 +13,7 @@
|
||||
Name: systemd
|
||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||
Version: 239
|
||||
Release: 51%{?dist}.3
|
||||
Release: 51%{?dist}.2
|
||||
# For a breakdown of the licensing, see README
|
||||
License: LGPLv2+ and MIT and GPLv2+
|
||||
Summary: System and Service Manager
|
||||
@ -715,9 +715,6 @@ Patch0662: 0662-test-seccomp-accept-ENOSYS-from-sysctl-2-too.patch
|
||||
Patch0663: 0663-Disable-libpitc-to-fix-CentOS-Stream-CI.patch
|
||||
Patch0664: 0664-test-accept-that-char-device-0-0-can-now-be-created-.patch
|
||||
Patch0665: 0665-core-return-true-from-cg_is_empty-on-ENOENT.patch
|
||||
Patch0666: 0666-Do-not-fail-if-the-same-alt.-name-is-set-again.patch
|
||||
Patch0667: 0667-meson-avoid-bogus-meson-warning.patch
|
||||
Patch0668: 0668-meson-do-not-fail-if-rsync-is-not-installed-with-mes.patch
|
||||
|
||||
|
||||
%ifarch %{ix86} x86_64 aarch64
|
||||
@ -1345,11 +1342,6 @@ fi
|
||||
%files tests -f .file-list-tests
|
||||
|
||||
%changelog
|
||||
* Fri Dec 10 2021 systemd maintenance team <systemd-maint@redhat.com> - 239-51.3
|
||||
- Do not fail if the same alt. name is set again (#2030027)
|
||||
- meson: avoid bogus meson warning (#2030027)
|
||||
- meson: do not fail if rsync is not installed with meson 0.57.2 (#2030027)
|
||||
|
||||
* Fri Dec 03 2021 systemd maintenance team <systemd-maint@redhat.com> - 239-51.2
|
||||
- core: return true from cg_is_empty* on ENOENT (#2024903)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user