Update to v240
This commit is contained in:
parent
3a45ccbeb1
commit
47d443ea5d
@ -1,4 +1,4 @@
|
|||||||
From b727694500d24d19ac0d7c51c1eb67c281f2f301 Mon Sep 17 00:00:00 2001
|
From 86aa208e639b119007332718aa4f453af2a061d0 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||||
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
||||||
Subject: [PATCH] resolved: create /etc/resolv.conf symlink at runtime
|
Subject: [PATCH] resolved: create /etc/resolv.conf symlink at runtime
|
||||||
@ -18,11 +18,11 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1313085
|
|||||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
||||||
index a4cda0b5ef..68bca80777 100644
|
index f4efddf8e5..3386e3bf67 100644
|
||||||
--- a/src/resolve/resolved.c
|
--- a/src/resolve/resolved.c
|
||||||
+++ b/src/resolve/resolved.c
|
+++ b/src/resolve/resolved.c
|
||||||
@@ -71,6 +71,10 @@ int main(int argc, char *argv[]) {
|
@@ -45,6 +45,10 @@ static int run(int argc, char *argv[]) {
|
||||||
/* Drop privileges, but only if we have been started as root. If we are not running as root we assume all
|
/* Drop privileges, but only if we have been started as root. If we are not running as root we assume most
|
||||||
* privileges are already dropped. */
|
* privileges are already dropped. */
|
||||||
if (getuid() == 0) {
|
if (getuid() == 0) {
|
||||||
+ r = symlink("../run/systemd/resolve/resolv.conf", "/etc/resolv.conf");
|
+ r = symlink("../run/systemd/resolve/resolv.conf", "/etc/resolv.conf");
|
||||||
@ -46,3 +46,6 @@ index df8d42101c..928105ea8d 100644
|
|||||||
C /etc/nsswitch.conf - - - -
|
C /etc/nsswitch.conf - - - -
|
||||||
m4_ifdef(`HAVE_PAM',
|
m4_ifdef(`HAVE_PAM',
|
||||||
C /etc/pam.d - - - -
|
C /etc/pam.d - - - -
|
||||||
|
--
|
||||||
|
2.19.2
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (systemd-3bf819c.tar.gz) = 3fb79707d6af4a0f885f6d168060dc11810c175b3a214f007c8268035dc2ab74b597612139ac2c20bcb30afe926eb6fc9ed3f4dc584e1f3bae8417b3fa4c58ad
|
SHA512 (systemd-240.tar.gz) = da7467781b16f65d868931ae88fd07554db61542aec7f11dbec9f7279b529f900301edfea2d3813ddb64eeb3fdcfb7be86e540c65212dd7cfdcdebbc80de2ff5
|
||||||
|
16
systemd.spec
16
systemd.spec
@ -1,7 +1,7 @@
|
|||||||
%global commit 3bf819c4ca718a6bc4b3b871cf52a0d1b518967d
|
#global commit a188229ade906a1374efea4d1851b510d6216c38
|
||||||
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
||||||
|
|
||||||
%global stable 1
|
#global stable 1
|
||||||
|
|
||||||
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
||||||
# strip the automatically generated dep here and instead co-own the
|
# strip the automatically generated dep here and instead co-own the
|
||||||
@ -14,8 +14,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 239
|
Version: 240%{?commit:~0.git%{shortcommit}}
|
||||||
Release: 10%{?commit:.git%{shortcommit}}%{?dist}
|
Release: 1%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: System and Service Manager
|
Summary: System and Service Manager
|
||||||
@ -100,6 +100,8 @@ BuildRequires: libseccomp-devel
|
|||||||
BuildRequires: git
|
BuildRequires: git
|
||||||
BuildRequires: meson >= 0.43
|
BuildRequires: meson >= 0.43
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
|
# We use RUNNING_ON_VALGRIND in tests, so the headers need to be available
|
||||||
|
BuildRequires: valgrind-devel
|
||||||
|
|
||||||
Requires(post): coreutils
|
Requires(post): coreutils
|
||||||
Requires(post): sed
|
Requires(post): sed
|
||||||
@ -414,6 +416,8 @@ install -Dm0755 -t %{buildroot}%{_prefix}/lib/kernel/install.d/ %{SOURCE11}
|
|||||||
|
|
||||||
install -D -t %{buildroot}/usr/lib/systemd/ %{SOURCE3}
|
install -D -t %{buildroot}/usr/lib/systemd/ %{SOURCE3}
|
||||||
|
|
||||||
|
sed -i 's|#!/usr/bin/env python3|#!%{__python3}|' %{buildroot}/usr/lib/systemd/tests/run-unit-tests.py
|
||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
# Split files in build root into rpms. See split-files.py for the
|
# Split files in build root into rpms. See split-files.py for the
|
||||||
@ -675,6 +679,10 @@ fi
|
|||||||
%files tests -f .file-list-tests
|
%files tests -f .file-list-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 21 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 240-1
|
||||||
|
- Update to latest release
|
||||||
|
See https://github.com/systemd/systemd/blob/master/NEWS for the list of changes.
|
||||||
|
|
||||||
* Mon Dec 17 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 239-10.git9f3aed1
|
* Mon Dec 17 2018 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 239-10.git9f3aed1
|
||||||
- Hibernation checks for resume= are rescinded (#1645870)
|
- Hibernation checks for resume= are rescinded (#1645870)
|
||||||
- Various patches:
|
- Various patches:
|
||||||
|
Loading…
Reference in New Issue
Block a user