Version 251-rc1
This commit is contained in:
parent
98684a818d
commit
3c4f9413a7
29
21705.patch
29
21705.patch
@ -1,29 +0,0 @@
|
|||||||
From ca52de3b56d5e70232bee29314cd84f5596c1e7f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Daan De Meyer <daan.j.demeyer@gmail.com>
|
|
||||||
Date: Thu, 9 Dec 2021 15:46:13 +0100
|
|
||||||
Subject: [PATCH] process-util: Fix memory leak
|
|
||||||
|
|
||||||
---
|
|
||||||
src/basic/process-util.c | 9 ++++++---
|
|
||||||
1 file changed, 6 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/basic/process-util.c b/src/basic/process-util.c
|
|
||||||
index 1b96d3ca8543..c97185215847 100644
|
|
||||||
--- a/src/basic/process-util.c
|
|
||||||
+++ b/src/basic/process-util.c
|
|
||||||
@@ -221,9 +221,12 @@ int get_process_cmdline(pid_t pid, size_t max_columns, ProcessCmdlineFlags flags
|
|
||||||
return -ENOMEM;
|
|
||||||
|
|
||||||
/* Drop trailing empty strings. See issue #21186. */
|
|
||||||
- STRV_FOREACH_BACKWARDS(p, args)
|
|
||||||
- if (isempty(*p))
|
|
||||||
- *p = mfree(*p);
|
|
||||||
+ STRV_FOREACH_BACKWARDS(p, args) {
|
|
||||||
+ if (!isempty(*p))
|
|
||||||
+ break;
|
|
||||||
+
|
|
||||||
+ *p = mfree(*p);
|
|
||||||
+ }
|
|
||||||
|
|
||||||
ans = quote_command_line(args, shflags);
|
|
||||||
if (!ans)
|
|
@ -1,3 +1,3 @@
|
|||||||
[suppress_file]
|
[suppress_file]
|
||||||
# This shared object is private to systemd
|
# Those shared objects are private to systemd
|
||||||
file_name_regexp=libsystemd-shared-.*.so
|
file_name_regexp=libsystemd-(shared|core)-.*.so
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (systemd-250.4.tar.gz) = 307ed0920da660b6c45d909fea66864fb98db8b2f6905d629fb2012fc4bf64dd25fd61168c22bf4098200be541be9b0e815fbde98806a99c85cb33d49d8b63d0
|
SHA512 (systemd-251-rc1.tar.gz) = 724de2d923acfca8c1ebf5dd3042fa9d212c2d7aa5c0fcc528abec0c872af53af9d5f829aac63fe51af29a62d6f7ba9f215b32ebf05e84aa6ee89d723c7341e7
|
||||||
|
@ -58,7 +58,7 @@ for file in files(buildroot):
|
|||||||
o = o_rpm_macros
|
o = o_rpm_macros
|
||||||
elif '/usr/lib/systemd/tests' in n:
|
elif '/usr/lib/systemd/tests' in n:
|
||||||
o = o_tests
|
o = o_tests
|
||||||
elif re.search(r'/libsystemd-shared-.*\.so$', n):
|
elif re.search(r'/libsystemd-(shared|core)-.*\.so$', n):
|
||||||
o = o_main
|
o = o_main
|
||||||
elif re.search(r'/libcryptsetup-token-systemd-.*\.so$', n):
|
elif re.search(r'/libcryptsetup-token-systemd-.*\.so$', n):
|
||||||
o = o_udev
|
o = o_udev
|
||||||
|
14
systemd.spec
14
systemd.spec
@ -1,7 +1,7 @@
|
|||||||
#global commit c4b843473a75fb38ed5bf54e9d3cfb1cb3719efa
|
#global commit c4b843473a75fb38ed5bf54e9d3cfb1cb3719efa
|
||||||
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
%{?commit:%global shortcommit %(c=%{commit}; echo ${c:0:7})}
|
||||||
|
|
||||||
%global stable 1
|
#global stable 1
|
||||||
|
|
||||||
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
||||||
# strip the automatically generated dep here and instead co-own the
|
# strip the automatically generated dep here and instead co-own the
|
||||||
@ -30,8 +30,8 @@
|
|||||||
Name: systemd
|
Name: systemd
|
||||||
Url: https://www.freedesktop.org/wiki/Software/systemd
|
Url: https://www.freedesktop.org/wiki/Software/systemd
|
||||||
%if %{without inplace}
|
%if %{without inplace}
|
||||||
Version: 250.4
|
Version: 251~rc1
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
%else
|
%else
|
||||||
# determine the build information from local checkout
|
# determine the build information from local checkout
|
||||||
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
|
Version: %(tools/meson-vcs-tag.sh . error | sed -r 's/-([0-9])/.^\1/; s/-g/_g/')
|
||||||
@ -518,7 +518,9 @@ CONFIGURE_OPTS=(
|
|||||||
-Db_lto=%[%{with lto}?"true":"false"]
|
-Db_lto=%[%{with lto}?"true":"false"]
|
||||||
-Db_ndebug=false
|
-Db_ndebug=false
|
||||||
-Dman=true
|
-Dman=true
|
||||||
-Dversion-tag=v%{version}-%{release}
|
-Dversion-tag=v%{version_no_tilde}-%{release}
|
||||||
|
# https://bugzilla.redhat.com/show_bug.cgi?id=1906010
|
||||||
|
-Dshared-lib-tag=%{version_no_tilde}-%{release}
|
||||||
-Dfallback-hostname=%[0%{?fedora}?"fedora":"localhost"]
|
-Dfallback-hostname=%[0%{?fedora}?"fedora":"localhost"]
|
||||||
-Ddefault-dnssec=no
|
-Ddefault-dnssec=no
|
||||||
-Ddefault-dns-over-tls=no
|
-Ddefault-dns-over-tls=no
|
||||||
@ -1004,6 +1006,10 @@ fi
|
|||||||
%files standalone-sysusers -f .file-list-standalone-sysusers
|
%files standalone-sysusers -f .file-list-standalone-sysusers
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Mar 29 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 251~rc1-1
|
||||||
|
- First release candidate in the new cycle
|
||||||
|
- Fixes rhbz#1449751, rhbz#1906010
|
||||||
|
|
||||||
* Fri Mar 18 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 250.4-2
|
* Fri Mar 18 2022 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 250.4-2
|
||||||
- Fix the wrong file assignment done in previous version
|
- Fix the wrong file assignment done in previous version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user