rebuild against newer libnotify, vala
This commit is contained in:
parent
3f1bed4cae
commit
32dccb8013
13
notify.patch
Normal file
13
notify.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff -up systemd-11/src/ask-password-agent.vala.notify systemd-11/src/ask-password-agent.vala
|
||||
--- systemd-11/src/ask-password-agent.vala.notify 2010-11-12 20:27:39.535719001 -0500
|
||||
+++ systemd-11/src/ask-password-agent.vala 2010-11-12 20:27:52.233719001 -0500
|
||||
@@ -181,8 +181,7 @@ public class MyStatusIcon : StatusIcon {
|
||||
|
||||
set_visible(true);
|
||||
|
||||
- Notification n = new Notification(title, message, icon, null);
|
||||
- n.attach_to_status_icon(this);
|
||||
+ Notification n = new Notification(title, message, icon);
|
||||
n.set_timeout(5000);
|
||||
n.show();
|
||||
|
12
systemd.spec
12
systemd.spec
@ -2,7 +2,7 @@ Name: systemd
|
||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
Version: 11
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
Group: System Environment/Base
|
||||
Summary: A System and Session Manager
|
||||
@ -40,6 +40,11 @@ Obsoletes: upstart < 0.6.5-9
|
||||
Obsoletes: upstart-sysvinit < 0.6.5-9
|
||||
Conflicts: upstart-sysvinit
|
||||
|
||||
# build with libnotify 0.7.0
|
||||
Patch0: notify.patch
|
||||
# build with vala 0.11.2
|
||||
Patch1: vala-build.patch
|
||||
|
||||
%description
|
||||
systemd is a system and session manager for Linux, compatible with
|
||||
SysV and LSB init scripts. systemd provides aggressive parallelization
|
||||
@ -72,6 +77,8 @@ Graphical front-end for systemd.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1 -b .notify
|
||||
%patch1 -p1 -b .vala
|
||||
|
||||
%build
|
||||
%configure --with-rootdir= --with-distro=fedora
|
||||
@ -229,6 +236,9 @@ fi
|
||||
%{_mandir}/man1/systemadm.*
|
||||
|
||||
%changelog
|
||||
* Fri Nov 12 2010 Matthias Clasen <mclasen@redhat.com> - 11-2
|
||||
- Rebuild with newer vala, libnotify
|
||||
|
||||
* Thu Oct 7 2010 Lennart Poettering <lpoetter@redhat.com> - 11-1
|
||||
- New upstream release
|
||||
|
||||
|
12
vala-build.patch
Normal file
12
vala-build.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up systemd-11/src/ask-password-agent.vala.vala-build systemd-11/src/ask-password-agent.vala
|
||||
--- systemd-11/src/ask-password-agent.vala.vala-build 2010-11-12 20:51:53.579719000 -0500
|
||||
+++ systemd-11/src/ask-password-agent.vala 2010-11-12 20:52:06.288719002 -0500
|
||||
@@ -225,7 +225,7 @@ public class MyStatusIcon : StatusIcon {
|
||||
|
||||
OutputStream stream = new UnixOutputStream(to_process, true);
|
||||
|
||||
- stream.write(password, password.length, null);
|
||||
+ stream.write(password.data, null);
|
||||
}
|
||||
}
|
||||
|
Loading…
Reference in New Issue
Block a user