Update to v236
This commit is contained in:
parent
f314ba8790
commit
1eeb98d33d
@ -1,4 +1,4 @@
|
|||||||
From 67ba0816708038ad282fcb38f250a54bb781866a Mon Sep 17 00:00:00 2001
|
From b727694500d24d19ac0d7c51c1eb67c281f2f301 Mon Sep 17 00:00:00 2001
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
||||||
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
Date: Fri, 11 Mar 2016 17:06:17 -0500
|
||||||
Subject: [PATCH] resolved: create /etc/resolv.conf symlink at runtime
|
Subject: [PATCH] resolved: create /etc/resolv.conf symlink at runtime
|
||||||
@ -18,10 +18,10 @@ https://bugzilla.redhat.com/show_bug.cgi?id=1313085
|
|||||||
2 files changed, 4 insertions(+), 3 deletions(-)
|
2 files changed, 4 insertions(+), 3 deletions(-)
|
||||||
|
|
||||||
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
diff --git a/src/resolve/resolved.c b/src/resolve/resolved.c
|
||||||
index 2eb7bfd030..75e2f7928c 100644
|
index a4cda0b5ef..68bca80777 100644
|
||||||
--- a/src/resolve/resolved.c
|
--- a/src/resolve/resolved.c
|
||||||
+++ b/src/resolve/resolved.c
|
+++ b/src/resolve/resolved.c
|
||||||
@@ -70,6 +70,10 @@ int main(int argc, char *argv[]) {
|
@@ -71,6 +71,10 @@ int main(int argc, char *argv[]) {
|
||||||
/* Drop privileges, but only if we have been started as root. If we are not running as root we assume all
|
/* Drop privileges, but only if we have been started as root. If we are not running as root we assume all
|
||||||
* privileges are already dropped. */
|
* privileges are already dropped. */
|
||||||
if (getuid() == 0) {
|
if (getuid() == 0) {
|
||||||
@ -33,7 +33,7 @@ index 2eb7bfd030..75e2f7928c 100644
|
|||||||
/* Drop privileges, but keep three caps. Note that we drop those too, later on (see below) */
|
/* Drop privileges, but keep three caps. Note that we drop those too, later on (see below) */
|
||||||
r = drop_privileges(uid, gid,
|
r = drop_privileges(uid, gid,
|
||||||
diff --git a/tmpfiles.d/etc.conf.m4 b/tmpfiles.d/etc.conf.m4
|
diff --git a/tmpfiles.d/etc.conf.m4 b/tmpfiles.d/etc.conf.m4
|
||||||
index 35e3809f57..928105ea8d 100644
|
index df8d42101c..928105ea8d 100644
|
||||||
--- a/tmpfiles.d/etc.conf.m4
|
--- a/tmpfiles.d/etc.conf.m4
|
||||||
+++ b/tmpfiles.d/etc.conf.m4
|
+++ b/tmpfiles.d/etc.conf.m4
|
||||||
@@ -13,9 +13,6 @@ L+ /etc/mtab - - - - ../proc/self/mounts
|
@@ -13,9 +13,6 @@ L+ /etc/mtab - - - - ../proc/self/mounts
|
||||||
@ -41,11 +41,8 @@ index 35e3809f57..928105ea8d 100644
|
|||||||
t /etc/mtab - - - - security.SMACK64=_
|
t /etc/mtab - - - - security.SMACK64=_
|
||||||
)m4_dnl
|
)m4_dnl
|
||||||
-m4_ifdef(`ENABLE_RESOLVE',
|
-m4_ifdef(`ENABLE_RESOLVE',
|
||||||
-L! /etc/resolv.conf - - - - ../usr/lib/systemd/resolv.conf
|
-L! /etc/resolv.conf - - - - ../run/systemd/resolve/stub-resolv.conf
|
||||||
-)m4_dnl
|
-)m4_dnl
|
||||||
C /etc/nsswitch.conf - - - -
|
C /etc/nsswitch.conf - - - -
|
||||||
m4_ifdef(`HAVE_PAM',
|
m4_ifdef(`HAVE_PAM',
|
||||||
C /etc/pam.d - - - -
|
C /etc/pam.d - - - -
|
||||||
--
|
|
||||||
2.13.6
|
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (systemd-235.tar.gz) = 243f2eb5340fa37dd1286eaa63e83387bda9e03953af266cd6196a37535a13491482caf14c6ab10608bba4ed23b6c41923608e52017e0c26988ed72ddd2b9993
|
SHA512 (systemd-236.tar.gz) = 1a9672960e03e05c09e41fb8cfe9b0f25e867fd43f37f8371515ddddfdbd4270afd746a6da733f6d1d3b2cc43db1ecc7a9f2245f2dac2ec233db74e9e70e4f6d
|
||||||
|
11
systemd.spec
11
systemd.spec
@ -1,4 +1,4 @@
|
|||||||
%global gitcommit 4a0e9289bf443fec9fc56af25f90e2a100ba7a41
|
#global gitcommit 4a0e9289bf443fec9fc56af25f90e2a100ba7a41
|
||||||
%{?gitcommit:%global gitcommitshort %(c=%{gitcommit}; echo ${c:0:7})}
|
%{?gitcommit:%global gitcommitshort %(c=%{gitcommit}; echo ${c:0:7})}
|
||||||
|
|
||||||
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
# We ship a .pc file but don't want to have a dep on pkg-config. We
|
||||||
@ -12,8 +12,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 235
|
Version: 236
|
||||||
Release: 5%{?gitcommit:.git%{gitcommitshort}}%{?dist}
|
Release: 1%{?gitcommit:.git%{gitcommitshort}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: System and Service Manager
|
Summary: System and Service Manager
|
||||||
@ -47,7 +47,7 @@ i=1; for j in 00*patch; do printf "Patch%04d: %s\n" $i $j; i=$((i+1));done|
|
|||||||
GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[67]* hwdb/parse_hwdb.py > hwdb.patch
|
GIT_DIR=../../src/systemd/.git git diffab -M v233..master@{2017-06-15} -- hwdb/[67]* hwdb/parse_hwdb.py > hwdb.patch
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
#Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
Patch0998: 0998-resolved-create-etc-resolv.conf-symlink-at-runtime.patch
|
||||||
|
|
||||||
%global num_patches %{lua: c=0; for i,p in ipairs(patches) do c=c+1; end; print(c);}
|
%global num_patches %{lua: c=0; for i,p in ipairs(patches) do c=c+1; end; print(c);}
|
||||||
|
|
||||||
@ -684,6 +684,9 @@ fi
|
|||||||
%files tests -f .file-list-tests
|
%files tests -f .file-list-tests
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 15 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 236-1
|
||||||
|
- Update to latest version
|
||||||
|
|
||||||
* Mon Dec 11 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 235-5.git4a0e928
|
* Mon Dec 11 2017 Zbigniew Jędrzejewski-Szmek <zbyszek@in.waw.pl> - 235-5.git4a0e928
|
||||||
- Update to latest git snapshot, do not build for realz
|
- Update to latest git snapshot, do not build for realz
|
||||||
- Switch to libidn2 again (#1449145)
|
- Switch to libidn2 again (#1449145)
|
||||||
|
Loading…
Reference in New Issue
Block a user