New upstream release
This commit is contained in:
parent
1439d1a9f2
commit
132b843d2e
@ -1,24 +0,0 @@
|
|||||||
From e2c8b07dcb50c2adf64cdfb22e4a496fc76576fb Mon Sep 17 00:00:00 2001
|
|
||||||
From: Lennart Poettering <lennart@poettering.net>
|
|
||||||
Date: Sat, 22 Sep 2012 00:16:13 +0200
|
|
||||||
Subject: [PATCH] journal: bring mmap cache prototype in sync
|
|
||||||
|
|
||||||
---
|
|
||||||
src/journal/mmap-cache.h | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/journal/mmap-cache.h b/src/journal/mmap-cache.h
|
|
||||||
index de34634..0c42fb8 100644
|
|
||||||
--- a/src/journal/mmap-cache.h
|
|
||||||
+++ b/src/journal/mmap-cache.h
|
|
||||||
@@ -31,6 +31,6 @@ MMapCache* mmap_cache_new(void);
|
|
||||||
MMapCache* mmap_cache_ref(MMapCache *m);
|
|
||||||
MMapCache* mmap_cache_unref(MMapCache *m);
|
|
||||||
|
|
||||||
-int mmap_cache_get(MMapCache *m, int fd, int prot, unsigned context, bool keep_always, uint64_t offset, uint64_t size, struct stat *st, void **ret);
|
|
||||||
+int mmap_cache_get(MMapCache *m, int fd, int prot, unsigned context, bool keep_always, uint64_t offset, size_t size, struct stat *st, void **ret);
|
|
||||||
void mmap_cache_close_fd(MMapCache *m, int fd);
|
|
||||||
void mmap_cache_close_context(MMapCache *m, unsigned context);
|
|
||||||
--
|
|
||||||
1.7.12
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
a5e4bfaf900a9e2480827feaf58556cb systemd-191.tar.xz
|
e8692055923e87f7f9cb634d44314edb systemd-192.tar.xz
|
||||||
|
10
systemd.spec
10
systemd.spec
@ -21,8 +21,8 @@ Url: http://www.freedesktop.org/wiki/Software/systemd
|
|||||||
# AGAIN: DO NOT BLINDLY UPDATE RAWHIDE PACKAGES TOO WHEN YOU UPDATE
|
# AGAIN: DO NOT BLINDLY UPDATE RAWHIDE PACKAGES TOO WHEN YOU UPDATE
|
||||||
# THIS PACKAGE FOR A NON-RAWHIDE DEVELOPMENT DISTRIBUTION!
|
# THIS PACKAGE FOR A NON-RAWHIDE DEVELOPMENT DISTRIBUTION!
|
||||||
|
|
||||||
Version: 191
|
Version: 192
|
||||||
Release: 2%{?gitcommit:.git%{gitcommit}}%{?dist}
|
Release: 1%{?gitcommit:.git%{gitcommit}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: A System and Service Manager
|
Summary: A System and Service Manager
|
||||||
@ -81,8 +81,6 @@ Source3: udlfb.conf
|
|||||||
# Stop-gap, just to ensure things work fine with rsyslog without having to change the package right-away
|
# Stop-gap, just to ensure things work fine with rsyslog without having to change the package right-away
|
||||||
Source4: listen.conf
|
Source4: listen.conf
|
||||||
|
|
||||||
Patch1: 0001-journal-bring-mmap-cache-prototype-in-sync.patch
|
|
||||||
|
|
||||||
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
|
Obsoletes: SysVinit < 2.86-24, sysvinit < 2.86-24
|
||||||
Provides: SysVinit = 2.86-24, sysvinit = 2.86-24
|
Provides: SysVinit = 2.86-24, sysvinit = 2.86-24
|
||||||
Provides: sysvinit-userspace
|
Provides: sysvinit-userspace
|
||||||
@ -189,7 +187,6 @@ glib-based applications using libudev functionality.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q %{?gitcommit:-n %{name}-git%{gitcommit}}
|
%setup -q %{?gitcommit:-n %{name}-git%{gitcommit}}
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%{?gitcommit: ./autogen.sh }
|
%{?gitcommit: ./autogen.sh }
|
||||||
@ -583,6 +580,9 @@ fi
|
|||||||
%{_libdir}/pkgconfig/gudev-1.0*
|
%{_libdir}/pkgconfig/gudev-1.0*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 25 2012 Lennart Poettering <lpoetter@redhat.com> - 192-1
|
||||||
|
- New upstream release
|
||||||
|
|
||||||
* Fri Sep 21 2012 Lennart Poettering <lpoetter@redhat.com> - 191-2
|
* Fri Sep 21 2012 Lennart Poettering <lpoetter@redhat.com> - 191-2
|
||||||
- Fix journal mmap header prototype definition to fix compilation on 32bit
|
- Fix journal mmap header prototype definition to fix compilation on 32bit
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user