New upstream release
This commit is contained in:
parent
b4bdea39fb
commit
064fee0cbb
@ -1,53 +0,0 @@
|
|||||||
From 6ae61e265d8becff0960c0911e8bd37b0df42386 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fedora systemd team <systemd-maint@redhat.com>
|
|
||||||
Date: Thu, 18 Dec 2014 15:21:22 +0100
|
|
||||||
Subject: [PATCH] nspawn: fix invocation of the raw clone() system call on s390
|
|
||||||
and cris
|
|
||||||
|
|
||||||
Since the order of the first and second arguments of the raw clone() system
|
|
||||||
call is reversed on s390 and cris it needs to be invoked differently.
|
|
||||||
|
|
||||||
(cherry-picked from 60e1651a31c9c0ed1caef1a63f5e3a87156b0b1e)
|
|
||||||
---
|
|
||||||
src/nspawn/nspawn.c | 6 +++---
|
|
||||||
src/shared/missing.h | 10 ++++++++++
|
|
||||||
2 files changed, 13 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/nspawn/nspawn.c b/src/nspawn/nspawn.c
|
|
||||||
index 0466ddb..2f57e65 100644
|
|
||||||
--- a/src/nspawn/nspawn.c
|
|
||||||
+++ b/src/nspawn/nspawn.c
|
|
||||||
@@ -2982,9 +2982,9 @@ int main(int argc, char *argv[]) {
|
|
||||||
goto finish;
|
|
||||||
}
|
|
||||||
|
|
||||||
- pid = syscall(__NR_clone, SIGCHLD|CLONE_NEWNS|
|
|
||||||
- (arg_share_system ? 0 : CLONE_NEWIPC|CLONE_NEWPID|CLONE_NEWUTS)|
|
|
||||||
- (arg_private_network ? CLONE_NEWNET : 0), NULL);
|
|
||||||
+ pid = raw_clone(SIGCHLD|CLONE_NEWNS|
|
|
||||||
+ (arg_share_system ? 0 : CLONE_NEWIPC|CLONE_NEWPID|CLONE_NEWUTS)|
|
|
||||||
+ (arg_private_network ? CLONE_NEWNET : 0), NULL);
|
|
||||||
if (pid < 0) {
|
|
||||||
if (errno == EINVAL)
|
|
||||||
log_error_errno(errno, "clone() failed, do you have namespace support enabled in your kernel? (You need UTS, IPC, PID and NET namespacing built in): %m");
|
|
||||||
diff --git a/src/shared/missing.h b/src/shared/missing.h
|
|
||||||
index 478988c..8ea3807 100644
|
|
||||||
--- a/src/shared/missing.h
|
|
||||||
+++ b/src/shared/missing.h
|
|
||||||
@@ -631,3 +631,13 @@ static inline int setns(int fd, int nstype) {
|
|
||||||
#ifndef CAP_AUDIT_READ
|
|
||||||
#define CAP_AUDIT_READ 37
|
|
||||||
#endif
|
|
||||||
+
|
|
||||||
+static inline long raw_clone(unsigned long flags, void *child_stack) {
|
|
||||||
+#if defined(__s390__) || defined(__CRIS__)
|
|
||||||
+ /* On s390 and cris the order of the first and second arguments
|
|
||||||
+ * of the raw clone() system call is reversed. */
|
|
||||||
+ return syscall(__NR_clone, child_stack, flags);
|
|
||||||
+#else
|
|
||||||
+ return syscall(__NR_clone, flags, child_stack);
|
|
||||||
+#endif
|
|
||||||
+}
|
|
||||||
--
|
|
||||||
2.2.0
|
|
||||||
|
|
@ -1,216 +0,0 @@
|
|||||||
From 8ea1f4267bae6b37a4a4d474aec2692a4d211621 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fedora systemd team <systemd-maint@redhat.com>
|
|
||||||
Date: Wed, 7 Jan 2015 13:34:02 +0100
|
|
||||||
Subject: [PATCH] journald: when we detect the journal file we are about to
|
|
||||||
write to has been deleted, rotate
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1171719
|
|
||||||
|
|
||||||
(cherry-picked from 2678031a179a9b91fc799f8ef951a548c66c4b49)
|
|
||||||
---
|
|
||||||
src/journal/journal-file.c | 65 ++++++++++++++++++++++++++++++----------
|
|
||||||
src/journal/journal-file.h | 1 +
|
|
||||||
src/journal/journald-server.c | 6 +++-
|
|
||||||
src/journal/test-journal-flush.c | 3 +-
|
|
||||||
4 files changed, 57 insertions(+), 18 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/journal/journal-file.c b/src/journal/journal-file.c
|
|
||||||
index c5d2d19..a99265b 100644
|
|
||||||
--- a/src/journal/journal-file.c
|
|
||||||
+++ b/src/journal/journal-file.c
|
|
||||||
@@ -68,6 +68,9 @@
|
|
||||||
/* How much to increase the journal file size at once each time we allocate something new. */
|
|
||||||
#define FILE_SIZE_INCREASE (8ULL*1024ULL*1024ULL) /* 8MB */
|
|
||||||
|
|
||||||
+/* Reread fstat() of the file for detecting deletions at least this often */
|
|
||||||
+#define LAST_STAT_REFRESH_USEC (5*USEC_PER_SEC)
|
|
||||||
+
|
|
||||||
static int journal_file_set_online(JournalFile *f) {
|
|
||||||
assert(f);
|
|
||||||
|
|
||||||
@@ -312,6 +315,22 @@ static int journal_file_verify_header(JournalFile *f) {
|
|
||||||
return 0;
|
|
||||||
}
|
|
||||||
|
|
||||||
+static int journal_file_fstat(JournalFile *f) {
|
|
||||||
+ assert(f);
|
|
||||||
+ assert(f->fd >= 0);
|
|
||||||
+
|
|
||||||
+ if (fstat(f->fd, &f->last_stat) < 0)
|
|
||||||
+ return -errno;
|
|
||||||
+
|
|
||||||
+ f->last_stat_usec = now(CLOCK_MONOTONIC);
|
|
||||||
+
|
|
||||||
+ /* Refuse appending to files that are already deleted */
|
|
||||||
+ if (f->last_stat.st_nlink <= 0)
|
|
||||||
+ return -EIDRM;
|
|
||||||
+
|
|
||||||
+ return 0;
|
|
||||||
+}
|
|
||||||
+
|
|
||||||
static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size) {
|
|
||||||
uint64_t old_size, new_size;
|
|
||||||
int r;
|
|
||||||
@@ -330,8 +349,21 @@ static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size)
|
|
||||||
if (new_size < le64toh(f->header->header_size))
|
|
||||||
new_size = le64toh(f->header->header_size);
|
|
||||||
|
|
||||||
- if (new_size <= old_size)
|
|
||||||
- return 0;
|
|
||||||
+ if (new_size <= old_size) {
|
|
||||||
+
|
|
||||||
+ /* We already pre-allocated enough space, but before
|
|
||||||
+ * we write to it, let's check with fstat() if the
|
|
||||||
+ * file got deleted, in order make sure we don't throw
|
|
||||||
+ * away the data immediately. Don't check fstat() for
|
|
||||||
+ * all writes though, but only once ever 10s. */
|
|
||||||
+
|
|
||||||
+ if (f->last_stat_usec + LAST_STAT_REFRESH_USEC > now(CLOCK_MONOTONIC))
|
|
||||||
+ return 0;
|
|
||||||
+
|
|
||||||
+ return journal_file_fstat(f);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
+ /* Allocate more space. */
|
|
||||||
|
|
||||||
if (f->metrics.max_size > 0 && new_size > f->metrics.max_size)
|
|
||||||
return -E2BIG;
|
|
||||||
@@ -366,15 +398,14 @@ static int journal_file_allocate(JournalFile *f, uint64_t offset, uint64_t size)
|
|
||||||
if (r != 0)
|
|
||||||
return -r;
|
|
||||||
|
|
||||||
- if (fstat(f->fd, &f->last_stat) < 0)
|
|
||||||
- return -errno;
|
|
||||||
-
|
|
||||||
f->header->arena_size = htole64(new_size - le64toh(f->header->header_size));
|
|
||||||
|
|
||||||
- return 0;
|
|
||||||
+ return journal_file_fstat(f);
|
|
||||||
}
|
|
||||||
|
|
||||||
static int journal_file_move_to(JournalFile *f, int context, bool keep_always, uint64_t offset, uint64_t size, void **ret) {
|
|
||||||
+ int r;
|
|
||||||
+
|
|
||||||
assert(f);
|
|
||||||
assert(ret);
|
|
||||||
|
|
||||||
@@ -386,8 +417,11 @@ static int journal_file_move_to(JournalFile *f, int context, bool keep_always, u
|
|
||||||
/* Hmm, out of range? Let's refresh the fstat() data
|
|
||||||
* first, before we trust that check. */
|
|
||||||
|
|
||||||
- if (fstat(f->fd, &f->last_stat) < 0 ||
|
|
||||||
- offset + size > (uint64_t) f->last_stat.st_size)
|
|
||||||
+ r = journal_file_fstat(f);
|
|
||||||
+ if (r < 0)
|
|
||||||
+ return r;
|
|
||||||
+
|
|
||||||
+ if (offset + size > (uint64_t) f->last_stat.st_size)
|
|
||||||
return -EADDRNOTAVAIL;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -2511,10 +2545,9 @@ int journal_file_open(
|
|
||||||
goto fail;
|
|
||||||
}
|
|
||||||
|
|
||||||
- if (fstat(f->fd, &f->last_stat) < 0) {
|
|
||||||
- r = -errno;
|
|
||||||
+ r = journal_file_fstat(f);
|
|
||||||
+ if (r < 0)
|
|
||||||
goto fail;
|
|
||||||
- }
|
|
||||||
|
|
||||||
if (f->last_stat.st_size == 0 && f->writable) {
|
|
||||||
uint64_t crtime;
|
|
||||||
@@ -2546,10 +2579,9 @@ int journal_file_open(
|
|
||||||
if (r < 0)
|
|
||||||
goto fail;
|
|
||||||
|
|
||||||
- if (fstat(f->fd, &f->last_stat) < 0) {
|
|
||||||
- r = -errno;
|
|
||||||
+ r = journal_file_fstat(f);
|
|
||||||
+ if (r < 0)
|
|
||||||
goto fail;
|
|
||||||
- }
|
|
||||||
|
|
||||||
newly_created = true;
|
|
||||||
}
|
|
||||||
@@ -2657,8 +2689,11 @@ int journal_file_rotate(JournalFile **f, bool compress, bool seal) {
|
|
||||||
if (r < 0)
|
|
||||||
return -ENOMEM;
|
|
||||||
|
|
||||||
+ /* Try to rename the file to the archived version. If the file
|
|
||||||
+ * already was deleted, we'll get ENOENT, let's ignore that
|
|
||||||
+ * case. */
|
|
||||||
r = rename(old_file->path, p);
|
|
||||||
- if (r < 0)
|
|
||||||
+ if (r < 0 && errno != ENOENT)
|
|
||||||
return -errno;
|
|
||||||
|
|
||||||
old_file->header->state = STATE_ARCHIVED;
|
|
||||||
diff --git a/src/journal/journal-file.h b/src/journal/journal-file.h
|
|
||||||
index 211e121..15f1301 100644
|
|
||||||
--- a/src/journal/journal-file.h
|
|
||||||
+++ b/src/journal/journal-file.h
|
|
||||||
@@ -66,6 +66,7 @@ typedef struct JournalFile {
|
|
||||||
|
|
||||||
char *path;
|
|
||||||
struct stat last_stat;
|
|
||||||
+ usec_t last_stat_usec;
|
|
||||||
|
|
||||||
Header *header;
|
|
||||||
HashItem *data_hash_table;
|
|
||||||
diff --git a/src/journal/journald-server.c b/src/journal/journald-server.c
|
|
||||||
index 80c9736..24c4d3c 100644
|
|
||||||
--- a/src/journal/journald-server.c
|
|
||||||
+++ b/src/journal/journald-server.c
|
|
||||||
@@ -315,6 +315,7 @@ static int do_rotate(Server *s, JournalFile **f, const char* name,
|
|
||||||
name);
|
|
||||||
else
|
|
||||||
server_fix_perms(s, *f, uid);
|
|
||||||
+
|
|
||||||
return r;
|
|
||||||
}
|
|
||||||
|
|
||||||
@@ -457,7 +458,8 @@ bool shall_try_append_again(JournalFile *f, int r) {
|
|
||||||
-EPROTONOSUPPORT Unsupported feature
|
|
||||||
-EBADMSG Corrupted
|
|
||||||
-ENODATA Truncated
|
|
||||||
- -ESHUTDOWN Already archived */
|
|
||||||
+ -ESHUTDOWN Already archived
|
|
||||||
+ -EIDRM Journal file has been deleted */
|
|
||||||
|
|
||||||
if (r == -E2BIG || r == -EFBIG || r == -EDQUOT || r == -ENOSPC)
|
|
||||||
log_debug("%s: Allocation limit reached, rotating.", f->path);
|
|
||||||
@@ -469,6 +471,8 @@ bool shall_try_append_again(JournalFile *f, int r) {
|
|
||||||
log_info("%s: Unsupported feature, rotating.", f->path);
|
|
||||||
else if (r == -EBADMSG || r == -ENODATA || r == ESHUTDOWN)
|
|
||||||
log_warning("%s: Journal file corrupted, rotating.", f->path);
|
|
||||||
+ else if (r == -EIDRM)
|
|
||||||
+ log_warning("%s: Journal file has been deleted, rotating.", f->path);
|
|
||||||
else
|
|
||||||
return false;
|
|
||||||
|
|
||||||
diff --git a/src/journal/test-journal-flush.c b/src/journal/test-journal-flush.c
|
|
||||||
index 0ca24e0..40ede4a 100644
|
|
||||||
--- a/src/journal/test-journal-flush.c
|
|
||||||
+++ b/src/journal/test-journal-flush.c
|
|
||||||
@@ -39,8 +39,6 @@ int main(int argc, char *argv[]) {
|
|
||||||
r = journal_file_open(fn, O_CREAT|O_RDWR, 0644, false, false, NULL, NULL, NULL, &new_journal);
|
|
||||||
assert_se(r >= 0);
|
|
||||||
|
|
||||||
- unlink(fn);
|
|
||||||
-
|
|
||||||
r = sd_journal_open(&j, 0);
|
|
||||||
assert_se(r >= 0);
|
|
||||||
|
|
||||||
@@ -68,6 +66,7 @@ int main(int argc, char *argv[]) {
|
|
||||||
|
|
||||||
journal_file_close(new_journal);
|
|
||||||
|
|
||||||
+ unlink(fn);
|
|
||||||
assert_se(rmdir(dn) == 0);
|
|
||||||
|
|
||||||
return 0;
|
|
||||||
--
|
|
||||||
2.2.0
|
|
||||||
|
|
@ -1,119 +0,0 @@
|
|||||||
From 85dcfad639fab203564eca0070ce3303c5942bde Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fedora systemd team <systemd-maint@redhat.com>
|
|
||||||
Date: Thu, 5 Feb 2015 08:55:03 +0100
|
|
||||||
Subject: [PATCH] hwdb: add a touchpad hwdb
|
|
||||||
|
|
||||||
Currently used to tag devices in the new Lenovo *50 series and the X1 Carbon
|
|
||||||
3rd. These laptops re-introduced the physical trackpoint buttons that were
|
|
||||||
missing from the *40 series but those buttons are now wired up to the
|
|
||||||
touchpad.
|
|
||||||
|
|
||||||
The touchpad now sends BTN_0, BTN_1 and BTN_2 for the trackpoint. The same
|
|
||||||
button codes were used in older touchpads that had dedicated scroll up/down
|
|
||||||
buttons. Input drivers need to work around this and thus know what they're
|
|
||||||
dealing with.
|
|
||||||
|
|
||||||
For the previous gen we introduced INPUT_PROP_TOPBUTTONPAD in the kernel, but
|
|
||||||
the resulting mess showed that these per-device quirks should really live in
|
|
||||||
userspace.
|
|
||||||
|
|
||||||
The list currently includes the X1 Carbon 3rd PNPID, others will be added as
|
|
||||||
get to know which PNPID they have.
|
|
||||||
|
|
||||||
(Cherry-picked from 001a247324b44c0e0b8fdba41a6fc66e7465b8b6)
|
|
||||||
---
|
|
||||||
Makefile.am | 4 +++-
|
|
||||||
hwdb/70-touchpad.hwdb | 39 +++++++++++++++++++++++++++++++++++++++
|
|
||||||
rules/70-touchpad.rules | 12 ++++++++++++
|
|
||||||
3 files changed, 54 insertions(+), 1 deletion(-)
|
|
||||||
create mode 100644 hwdb/70-touchpad.hwdb
|
|
||||||
create mode 100644 rules/70-touchpad.rules
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index ac7924e..2b0128f 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -3389,6 +3389,7 @@ dist_udevrules_DATA += \
|
|
||||||
rules/60-drm.rules \
|
|
||||||
rules/60-keyboard.rules \
|
|
||||||
rules/70-mouse.rules \
|
|
||||||
+ rules/70-touchpad.rules \
|
|
||||||
rules/60-persistent-storage-tape.rules \
|
|
||||||
rules/60-persistent-serial.rules \
|
|
||||||
rules/60-persistent-input.rules \
|
|
||||||
@@ -3416,7 +3417,8 @@ dist_udevhwdb_DATA = \
|
|
||||||
hwdb/20-OUI.hwdb \
|
|
||||||
hwdb/20-net-ifname.hwdb \
|
|
||||||
hwdb/60-keyboard.hwdb \
|
|
||||||
- hwdb/70-mouse.hwdb
|
|
||||||
+ hwdb/70-mouse.hwdb \
|
|
||||||
+ hwdb/70-touchpad.hwdb
|
|
||||||
|
|
||||||
udevconfdir = $(sysconfdir)/udev
|
|
||||||
dist_udevconf_DATA = \
|
|
||||||
diff --git a/hwdb/70-touchpad.hwdb b/hwdb/70-touchpad.hwdb
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..bbf44db
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/hwdb/70-touchpad.hwdb
|
|
||||||
@@ -0,0 +1,39 @@
|
|
||||||
+# This file is part of systemd.
|
|
||||||
+#
|
|
||||||
+# The lookup keys are composed in:
|
|
||||||
+# 70-touchpad.rules
|
|
||||||
+#
|
|
||||||
+# Note: The format of the "touchpad:" prefix match key is a
|
|
||||||
+# contract between the rules file and the hardware data, it might
|
|
||||||
+# change in later revisions to support more or better matches, it
|
|
||||||
+# is not necessarily expected to be a stable ABI.
|
|
||||||
+#
|
|
||||||
+# Match string format:
|
|
||||||
+# touchpad:pnpid:<pnpid>:
|
|
||||||
+#
|
|
||||||
+# To add local entries, create a new file
|
|
||||||
+# /etc/udev/hwdb.d/71-touchpad-local.hwdb
|
|
||||||
+# and add your rules there. To load the new rules execute (as root):
|
|
||||||
+# udevadm hwdb --update
|
|
||||||
+# udevadm trigger /dev/input/eventXX
|
|
||||||
+# where /dev/input/eventXX is the touchpad in question. If in
|
|
||||||
+# doubt, simply use /dev/input/event* to reload all input rules.
|
|
||||||
+#
|
|
||||||
+# If your changes are generally applicable, open a bug report on
|
|
||||||
+# http://bugs.freedesktop.org/enter_bug.cgi?product=systemd
|
|
||||||
+# and include your new rules, a description of the device, and the
|
|
||||||
+# output of
|
|
||||||
+# udevadm info /dev/input/eventXX
|
|
||||||
+# (or /dev/input/event*).
|
|
||||||
+#
|
|
||||||
+# Allowed properties are:
|
|
||||||
+# TOUCHPAD_HAS_TRACKPOINT_BUTTONS=1
|
|
||||||
+#
|
|
||||||
+# If the TOUCHPAD_HAS_TRACKPOINT_BUTTONS property is set, this
|
|
||||||
+# device has # the trackpoint buttons wired up to the touchpad as
|
|
||||||
+# BTN_0, BTN_1 and BTN_2. This affects the Lenovo X1 Carbon 3rd
|
|
||||||
+# and the *50 series (T450, T550, etc.)
|
|
||||||
+
|
|
||||||
+# Lenovo X1 Carbon 3rd
|
|
||||||
+touchpad:pnpid:*LEN0048*:
|
|
||||||
+ TOUCHPAD_HAS_TRACKPOINT_BUTTONS=1
|
|
||||||
diff --git a/rules/70-touchpad.rules b/rules/70-touchpad.rules
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000..88e6fd2
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/rules/70-touchpad.rules
|
|
||||||
@@ -0,0 +1,12 @@
|
|
||||||
+# do not edit this file, it will be overwritten on update
|
|
||||||
+
|
|
||||||
+ACTION=="remove", GOTO="touchpad_end"
|
|
||||||
+KERNEL!="event*", GOTO="touchpad_end"
|
|
||||||
+ENV{ID_INPUT_TOUCHPAD}=="", GOTO="touchpad_end"
|
|
||||||
+
|
|
||||||
+# touchpad:pnpid:<pnpid>:*
|
|
||||||
+KERNELS=="serio1", \
|
|
||||||
+ IMPORT{builtin}="hwdb 'touchpad:pnpid:$attr{firmware_id}:'", \
|
|
||||||
+ GOTO="touchpad_end"
|
|
||||||
+
|
|
||||||
+LABEL="touchpad_end"
|
|
||||||
--
|
|
||||||
2.1.0
|
|
||||||
|
|
@ -1,87 +0,0 @@
|
|||||||
From 30353eb466fe1ef768dc7bc1ccc1239b97dab70c Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Tue, 7 Oct 2014 01:49:10 -0400
|
|
||||||
Subject: [PATCH] fedora: add bridge sysctl configuration
|
|
||||||
|
|
||||||
Udev rule is added to load those settings when the bridge
|
|
||||||
module is loaded.
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=634736
|
|
||||||
---
|
|
||||||
Makefile.am | 8 ++++++--
|
|
||||||
rules/.gitignore | 1 +
|
|
||||||
rules/99-bridge.rules.in | 9 +++++++++
|
|
||||||
sysctl.d/50-bridge.conf | 4 ++++
|
|
||||||
4 files changed, 20 insertions(+), 2 deletions(-)
|
|
||||||
create mode 100644 rules/99-bridge.rules.in
|
|
||||||
create mode 100644 sysctl.d/50-bridge.conf
|
|
||||||
|
|
||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index e52db1793b..41e94575ef 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -445,7 +445,8 @@ CLEANFILES += \
|
|
||||||
$(nodist_zshcompletion_DATA)
|
|
||||||
|
|
||||||
dist_sysctl_DATA = \
|
|
||||||
- sysctl.d/50-default.conf
|
|
||||||
+ sysctl.d/50-default.conf \
|
|
||||||
+ sysctl.d/50-bridge.conf
|
|
||||||
|
|
||||||
dist_systemunit_DATA = \
|
|
||||||
units/graphical.target \
|
|
||||||
@@ -3281,7 +3282,8 @@ dist_udevrules_DATA += \
|
|
||||||
rules/95-udev-late.rules
|
|
||||||
|
|
||||||
nodist_udevrules_DATA += \
|
|
||||||
- rules/99-systemd.rules
|
|
||||||
+ rules/99-systemd.rules \
|
|
||||||
+ rules/99-bridge.rules
|
|
||||||
|
|
||||||
dist_udevhwdb_DATA = \
|
|
||||||
hwdb/20-pci-vendor-model.hwdb \
|
|
||||||
@@ -3306,10 +3308,12 @@ sharepkgconfig_DATA = \
|
|
||||||
|
|
||||||
EXTRA_DIST += \
|
|
||||||
rules/99-systemd.rules.in \
|
|
||||||
+ rules/99-bridge.rules.in \
|
|
||||||
src/udev/udev.pc.in
|
|
||||||
|
|
||||||
CLEANFILES += \
|
|
||||||
rules/99-systemd.rules \
|
|
||||||
+ rules/99-bridge.rules \
|
|
||||||
src/udev/udev.pc
|
|
||||||
|
|
||||||
EXTRA_DIST += \
|
|
||||||
diff --git a/rules/.gitignore b/rules/.gitignore
|
|
||||||
index 93a50ddd80..46c7f3ce91 100644
|
|
||||||
--- a/rules/.gitignore
|
|
||||||
+++ b/rules/.gitignore
|
|
||||||
@@ -1 +1,2 @@
|
|
||||||
/99-systemd.rules
|
|
||||||
+/99-bridge.rules
|
|
||||||
diff --git a/rules/99-bridge.rules.in b/rules/99-bridge.rules.in
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000..f46f96bd2e
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/rules/99-bridge.rules.in
|
|
||||||
@@ -0,0 +1,9 @@
|
|
||||||
+# This file is part of systemd.
|
|
||||||
+#
|
|
||||||
+# systemd is free software; you can redistribute it and/or modify it
|
|
||||||
+# under the terms of the GNU Lesser General Public License as published by
|
|
||||||
+# the Free Software Foundation; either version 2.1 of the License, or
|
|
||||||
+# (at your option) any later version.
|
|
||||||
+
|
|
||||||
+# Apply sysctl settings to bridges
|
|
||||||
+ACTION=="add", SUBSYSTEM=="module", KERNEL=="bridge", RUN+="@rootlibexecdir@/systemd-sysctl --prefix=/net/bridge"
|
|
||||||
diff --git a/sysctl.d/50-bridge.conf b/sysctl.d/50-bridge.conf
|
|
||||||
new file mode 100644
|
|
||||||
index 0000000000..b586bf15fa
|
|
||||||
--- /dev/null
|
|
||||||
+++ b/sysctl.d/50-bridge.conf
|
|
||||||
@@ -0,0 +1,4 @@
|
|
||||||
+# Disable netfilter on bridges.
|
|
||||||
+net.bridge.bridge-nf-call-ip6tables = 0
|
|
||||||
+net.bridge.bridge-nf-call-iptables = 0
|
|
||||||
+net.bridge.bridge-nf-call-arptables = 0
|
|
@ -1,22 +0,0 @@
|
|||||||
From 6da80d4bbfaa3d8a2a8952995a108d6dbd6a1e3f Mon Sep 17 00:00:00 2001
|
|
||||||
From: =?UTF-8?q?Zbigniew=20J=C4=99drzejewski-Szmek?= <zbyszek@in.waw.pl>
|
|
||||||
Date: Fri, 3 Oct 2014 21:34:14 -0400
|
|
||||||
Subject: [PATCH] fedora: disable resolv.conf symlink
|
|
||||||
|
|
||||||
---
|
|
||||||
tmpfiles.d/etc.conf.m4 | 3 ---
|
|
||||||
1 file changed, 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/tmpfiles.d/etc.conf.m4 b/tmpfiles.d/etc.conf.m4
|
|
||||||
index f567c8d6ea..125d6e0a17 100644
|
|
||||||
--- a/tmpfiles.d/etc.conf.m4
|
|
||||||
+++ b/tmpfiles.d/etc.conf.m4
|
|
||||||
@@ -10,8 +10,5 @@
|
|
||||||
L /etc/os-release - - - - ../usr/lib/os-release
|
|
||||||
L /etc/localtime - - - - ../usr/share/zoneinfo/UTC
|
|
||||||
L+ /etc/mtab - - - - ../proc/self/mounts
|
|
||||||
-m4_ifdef(`ENABLE_RESOLVED',
|
|
||||||
-L /etc/resolv.conf - - - - ../run/systemd/resolve/resolv.conf
|
|
||||||
-)
|
|
||||||
C /etc/nsswitch.conf - - - -
|
|
||||||
C /etc/pam.d - - - -
|
|
@ -1 +0,0 @@
|
|||||||
$SystemLogSocketName /run/systemd/journal/syslog
|
|
36
systemd.spec
36
systemd.spec
@ -15,8 +15,8 @@
|
|||||||
|
|
||||||
Name: systemd
|
Name: systemd
|
||||||
Url: http://www.freedesktop.org/wiki/Software/systemd
|
Url: http://www.freedesktop.org/wiki/Software/systemd
|
||||||
Version: 218
|
Version: 219
|
||||||
Release: 6%{?gitcommit:.git%{gitcommit}}%{?dist}
|
Release: 1%{?gitcommit:.git%{gitcommit}}%{?dist}
|
||||||
# For a breakdown of the licensing, see README
|
# For a breakdown of the licensing, see README
|
||||||
License: LGPLv2+ and MIT and GPLv2+
|
License: LGPLv2+ and MIT and GPLv2+
|
||||||
Summary: A System and Service Manager
|
Summary: A System and Service Manager
|
||||||
@ -38,15 +38,9 @@ Source6: sysctl.conf.README
|
|||||||
Source7: systemd-journal-remote.xml
|
Source7: systemd-journal-remote.xml
|
||||||
Source8: systemd-journal-gatewayd.xml
|
Source8: systemd-journal-gatewayd.xml
|
||||||
|
|
||||||
# Patch series is available from http://cgit.freedesktop.org/systemd/systemd-stable/log/?h=v218-stable
|
# Patch series is available from http://cgit.freedesktop.org/systemd/systemd-stable/log/?h=v219-stable
|
||||||
# GIT_DIR=~/src/systemd/.git git format-patch-ab -M -N --no-signature v218..v218-stable
|
# GIT_DIR=~/src/systemd/.git git format-patch-ab -M -N --no-signature v219..v219-stable
|
||||||
# i=1; for p in 0*patch;do printf "Patch%04d: %s\n" $i $p; ((i++));done
|
# i=1; for p in 0*patch;do printf "Patch%04d: %s\n" $i $p; ((i++));done
|
||||||
Patch0001: 0001-nspawn-fix-invocation-of-the-raw-clone-system-call-o.patch
|
|
||||||
Patch0002: 0002-journald-when-we-detect-the-journal-file-we-are-abou.patch
|
|
||||||
Patch0003: 0003-hwdb-add-a-touchpad-hwdb.patch
|
|
||||||
|
|
||||||
Patch0998: fedora-disable-resolv.conf-symlink.patch
|
|
||||||
Patch0999: fedora-add-bridge-sysctl-configuration.patch
|
|
||||||
|
|
||||||
# kernel-install patch for grubby, drop if grubby is obsolete
|
# kernel-install patch for grubby, drop if grubby is obsolete
|
||||||
Patch1000: kernel-install-grubby.patch
|
Patch1000: kernel-install-grubby.patch
|
||||||
@ -435,6 +429,10 @@ install -Dm0644 %{SOURCE8} %{buildroot}/usr/lib/firewalld/services/
|
|||||||
|
|
||||||
%find_lang %{name}
|
%find_lang %{name}
|
||||||
|
|
||||||
|
%check
|
||||||
|
make -C build2 check
|
||||||
|
make -C build3 check
|
||||||
|
|
||||||
%pre
|
%pre
|
||||||
getent group cdrom >/dev/null 2>&1 || groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
|
getent group cdrom >/dev/null 2>&1 || groupadd -r -g 11 cdrom >/dev/null 2>&1 || :
|
||||||
getent group utmp >/dev/null 2>&1 || groupadd -r -g 22 utmp >/dev/null 2>&1 || :
|
getent group utmp >/dev/null 2>&1 || groupadd -r -g 22 utmp >/dev/null 2>&1 || :
|
||||||
@ -644,6 +642,8 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.timedate1.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.machine1.conf
|
||||||
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.resolve1.conf
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.resolve1.conf
|
||||||
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.import1.conf
|
||||||
|
%config(noreplace) %{_sysconfdir}/dbus-1/system.d/org.freedesktop.network1.conf
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/system.conf
|
%config(noreplace) %{_sysconfdir}/systemd/system.conf
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/user.conf
|
%config(noreplace) %{_sysconfdir}/systemd/user.conf
|
||||||
%config(noreplace) %{_sysconfdir}/systemd/logind.conf
|
%config(noreplace) %{_sysconfdir}/systemd/logind.conf
|
||||||
@ -693,6 +693,7 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_bindir}/systemd-path
|
%{_bindir}/systemd-path
|
||||||
%{_bindir}/systemd-sysusers
|
%{_bindir}/systemd-sysusers
|
||||||
%{_bindir}/systemd-firstboot
|
%{_bindir}/systemd-firstboot
|
||||||
|
%{_bindir}/systemd-hwdb
|
||||||
%{_bindir}/hostnamectl
|
%{_bindir}/hostnamectl
|
||||||
%{_bindir}/localectl
|
%{_bindir}/localectl
|
||||||
%{_bindir}/timedatectl
|
%{_bindir}/timedatectl
|
||||||
@ -716,7 +717,6 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_prefix}/lib/tmpfiles.d/etc.conf
|
%{_prefix}/lib/tmpfiles.d/etc.conf
|
||||||
%{_prefix}/lib/sysctl.d/50-default.conf
|
%{_prefix}/lib/sysctl.d/50-default.conf
|
||||||
%{_prefix}/lib/sysctl.d/50-coredump.conf
|
%{_prefix}/lib/sysctl.d/50-coredump.conf
|
||||||
%{_prefix}/lib/sysctl.d/50-bridge.conf
|
|
||||||
%{_prefix}/lib/sysusers.d/basic.conf
|
%{_prefix}/lib/sysusers.d/basic.conf
|
||||||
%{_prefix}/lib/sysusers.d/systemd.conf
|
%{_prefix}/lib/sysusers.d/systemd.conf
|
||||||
%{_prefix}/lib/systemd/system-preset/85-display-manager.preset
|
%{_prefix}/lib/systemd/system-preset/85-display-manager.preset
|
||||||
@ -726,6 +726,7 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_prefix}/lib/systemd/catalog/systemd.catalog
|
%{_prefix}/lib/systemd/catalog/systemd.catalog
|
||||||
%{_prefix}/lib/kernel/install.d/50-depmod.install
|
%{_prefix}/lib/kernel/install.d/50-depmod.install
|
||||||
%{_prefix}/lib/kernel/install.d/90-loaderentry.install
|
%{_prefix}/lib/kernel/install.d/90-loaderentry.install
|
||||||
|
%{_prefix}/lib/systemd/import-pubring.gpg
|
||||||
%{_sbindir}/init
|
%{_sbindir}/init
|
||||||
%{_sbindir}/reboot
|
%{_sbindir}/reboot
|
||||||
%{_sbindir}/halt
|
%{_sbindir}/halt
|
||||||
@ -744,6 +745,7 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_datadir}/factory/etc/pam.d/other
|
%{_datadir}/factory/etc/pam.d/other
|
||||||
%{_datadir}/factory/etc/pam.d/system-auth
|
%{_datadir}/factory/etc/pam.d/system-auth
|
||||||
%{_datadir}/systemd/kbd-model-map
|
%{_datadir}/systemd/kbd-model-map
|
||||||
|
%{_datadir}/systemd/language-fallback-map
|
||||||
%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
|
%{_datadir}/dbus-1/services/org.freedesktop.systemd1.service
|
||||||
%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
|
%{_datadir}/dbus-1/system-services/org.freedesktop.systemd1.service
|
||||||
%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
|
%{_datadir}/dbus-1/system-services/org.freedesktop.hostname1.service
|
||||||
@ -752,6 +754,8 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
|
%{_datadir}/dbus-1/system-services/org.freedesktop.timedate1.service
|
||||||
%{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
|
%{_datadir}/dbus-1/system-services/org.freedesktop.machine1.service
|
||||||
%{_datadir}/dbus-1/system-services/org.freedesktop.resolve1.service
|
%{_datadir}/dbus-1/system-services/org.freedesktop.resolve1.service
|
||||||
|
%{_datadir}/dbus-1/system-services/org.freedesktop.import1.service
|
||||||
|
%{_datadir}/dbus-1/system-services/org.freedesktop.network1.service
|
||||||
%dir %{_datadir}/polkit-1
|
%dir %{_datadir}/polkit-1
|
||||||
%dir %{_datadir}/polkit-1/actions
|
%dir %{_datadir}/polkit-1/actions
|
||||||
%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.systemd1.policy
|
||||||
@ -759,7 +763,9 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.login1.policy
|
||||||
%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.locale1.policy
|
||||||
%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
|
%{_datadir}/polkit-1/actions/org.freedesktop.timedate1.policy
|
||||||
%{_datadir}/pkgconfig/systemd.pc
|
%{_datadir}/polkit-1/actions/org.freedesktop.import1.policy
|
||||||
|
%{_datadir}/polkit-1/actions/org.freedesktop.machine1.policy
|
||||||
|
%{_libdir}/pkgconfig/systemd.pc
|
||||||
%{_datadir}/pkgconfig/udev.pc
|
%{_datadir}/pkgconfig/udev.pc
|
||||||
%{_datadir}/bash-completion/completions/*
|
%{_datadir}/bash-completion/completions/*
|
||||||
%{_datadir}/zsh/site-functions/*
|
%{_datadir}/zsh/site-functions/*
|
||||||
@ -848,6 +854,12 @@ getent passwd systemd-journal-upload >/dev/null 2>&1 || useradd -r -l -g systemd
|
|||||||
/usr/lib/firewalld/services/*
|
/usr/lib/firewalld/services/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 16 2015 Lennart Poettering <lpoetter@redhat.com> - 219-1
|
||||||
|
- New upstream release
|
||||||
|
- This removes the sysctl/bridge hack, a different solution needs to be found for this (see #634736)
|
||||||
|
- This removes the /etc/resolv.conf hack, anaconda needs to fix their handling of /etc/resolv.conf as symlink
|
||||||
|
- This enables "%check"
|
||||||
|
|
||||||
* Mon Feb 16 2015 Peter Robinson <pbrobinson@fedoraproject.org> 218-6
|
* Mon Feb 16 2015 Peter Robinson <pbrobinson@fedoraproject.org> 218-6
|
||||||
- aarch64 now has seccomp support
|
- aarch64 now has seccomp support
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user