RHEL 9.0.0 Alpha bootstrap
The content of this branch was automatically imported from Fedora ELN with the following as its source: https://src.fedoraproject.org/rpms/system-storage-manager#85317500ec6888437df93a36b83904bf889f87cf
This commit is contained in:
parent
580f43e46b
commit
1e41302b07
5
.gitignore
vendored
5
.gitignore
vendored
@ -0,0 +1,5 @@
|
||||
/system-storage-manager-0.2.tar.gz
|
||||
/system-storage-manager-0.4.tar.gz
|
||||
/system-storage-manager-0.5.tar.gz
|
||||
/system-storage-manager-1.0.tar.gz
|
||||
/system-storage-manager-1.3.tar.gz
|
23
python3-sphinx.patch
Normal file
23
python3-sphinx.patch
Normal file
@ -0,0 +1,23 @@
|
||||
diff --git a/doc/Makefile b/doc/Makefile
|
||||
index 135bfb4..efe5f22 100644
|
||||
--- a/doc/Makefile
|
||||
+++ b/doc/Makefile
|
||||
@@ -3,7 +3,7 @@
|
||||
|
||||
# You can set these variables from the command line.
|
||||
SPHINXOPTS =
|
||||
-SPHINXBUILD = sphinx-build
|
||||
+SPHINXBUILD = sphinx-build-3
|
||||
PAPER = a4
|
||||
BUILDDIR = _build
|
||||
|
||||
diff --git a/doc/generate_usage_includes.py b/doc/generate_usage_includes.py
|
||||
index 257ba51..0182116 100755
|
||||
--- a/doc/generate_usage_includes.py
|
||||
+++ b/doc/generate_usage_includes.py
|
||||
@@ -1,4 +1,4 @@
|
||||
-#!/usr/bin/env python
|
||||
+#!/usr/bin/env python3
|
||||
|
||||
import re
|
||||
import sys, os
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (system-storage-manager-1.3.tar.gz) = f7b113f6bb5bffc8f9f510bc3dae4528ccffb05aad5a66e7ace1af60b7c8210e2e88c2310ed4415e6adc7ff45e004c016547ef293b8e090a46392af0592a2b7c
|
181
system-storage-manager.spec
Normal file
181
system-storage-manager.spec
Normal file
@ -0,0 +1,181 @@
|
||||
%{!?_pkgdocdir: %global _pkgdocdir %{_docdir}/%{name}-%{version}}
|
||||
|
||||
Name: system-storage-manager
|
||||
Version: 1.3
|
||||
Release: 8%{?dist}
|
||||
Summary: A single tool to manage your storage
|
||||
|
||||
License: GPLv2+
|
||||
URL: https://system-storage-manager.github.io/
|
||||
Source0: https://github.com/system-storage-manager/ssm/archive/%{name}-%{version}.tar.gz
|
||||
|
||||
Patch1: python3-sphinx.patch
|
||||
|
||||
BuildArch: noarch
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-sphinx
|
||||
BuildRequires: python3-pwquality
|
||||
Requires: util-linux
|
||||
Requires: which
|
||||
Requires: xfsprogs
|
||||
Requires: e2fsprogs
|
||||
Requires: python3-pwquality
|
||||
|
||||
|
||||
%description
|
||||
System Storage Manager provides an easy to use command line interface to manage
|
||||
your storage using various technologies like lvm, btrfs, encrypted volumes and
|
||||
more.
|
||||
|
||||
In more sophisticated enterprise storage environments, management with Device
|
||||
Mapper (dm), Logical Volume Manager (LVM), or Multiple Devices (md) is becoming
|
||||
increasingly more difficult. With file systems added to the mix, the number of
|
||||
tools needed to configure and manage storage has grown so large that it is
|
||||
simply not user friendly. With so many options for a system administrator to
|
||||
consider, the opportunity for errors and problems is large.
|
||||
|
||||
The btrfs administration tools have shown us that storage management can be
|
||||
simplified, and we are working to bring that ease of use to Linux file systems
|
||||
in general.
|
||||
|
||||
You should install the ssm if you need to manage your storage with various
|
||||
technologies via a single unified interface.
|
||||
|
||||
|
||||
%prep
|
||||
%setup -q -n ssm-%{name}-%{version}
|
||||
|
||||
# fedora-specific issue with the name of python3-sphinx binaries
|
||||
%patch1 -p1
|
||||
|
||||
|
||||
%build
|
||||
make docs
|
||||
|
||||
|
||||
%install
|
||||
rm -rf ${RPM_BUILD_ROOT}
|
||||
%{__python3} setup.py install --root=${RPM_BUILD_ROOT}
|
||||
if [ "%{_pkgdocdir}" != "%{_docdir}/%{name}-%{version}" ]; then
|
||||
mv ${RPM_BUILD_ROOT}/{%{_docdir}/%{name}-%{version},%{_pkgdocdir}}
|
||||
fi
|
||||
|
||||
%check
|
||||
%{__python3} test.py || :
|
||||
|
||||
|
||||
%files
|
||||
%{_bindir}/ssm
|
||||
%{_pkgdocdir}/
|
||||
%{_mandir}/man8/ssm.8*
|
||||
%{python3_sitelib}/ssmlib/
|
||||
%{python3_sitelib}/*.egg-info
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Tue May 26 2020 Miro Hrončok <mhroncok@redhat.com> - 1.3-7
|
||||
- Rebuilt for Python 3.9
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Thu Oct 03 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3-5
|
||||
- Rebuilt for Python 3.8.0rc1 (#1748018)
|
||||
|
||||
* Mon Aug 19 2019 Miro Hrončok <mhroncok@redhat.com> - 1.3-4
|
||||
- Rebuilt for Python 3.8
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 1.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Mon Dec 10 2018 Jan Tulak <jtulak@redhat.com> - 1.3-1
|
||||
- New upstream stable version 1.3
|
||||
|
||||
* Mon Aug 13 2018 Jan Tulak <jtulak@redhat.com> - 1.2-1
|
||||
- New upstream stable version 1.2
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Jul 02 2018 Miro Hrončok <mhroncok@redhat.com> - 1.0-1
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Tue Jun 19 2018 Jan Tulak <jtulak@redhat.com> - 1.0-0
|
||||
- New upstream stable version 1.0
|
||||
|
||||
* Tue Jun 19 2018 Miro Hrončok <mhroncok@redhat.com> - 0.5-2
|
||||
- Rebuilt for Python 3.7
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5-1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Mon Oct 30 2017 Jan Tulak <jtulak@redhat.com> - 0.5-0
|
||||
- New upstream stable version 0.5
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Dec 19 2016 Miro Hrončok <mhroncok@redhat.com> - 0.4-12
|
||||
- Rebuild for Python 3.6
|
||||
|
||||
* Tue Jul 19 2016 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4-11
|
||||
- https://fedoraproject.org/wiki/Changes/Automatic_Provides_for_Python_RPM_Packages
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.4-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Nov 10 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/python3.5
|
||||
|
||||
|
||||
* Mon Jul 27 2015 Lukas Czerner <lczerner@redhat.com> 0.4-7
|
||||
- Big upstream update
|
||||
- Python3 support (#1239016)
|
||||
- Error out if file system is not supported (#1196428)
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Jan 20 2014 Lukas Czerner <lczerner@redhat.com> 0.4-4
|
||||
- Update to a new upstream release v0.4
|
||||
- Remove btrfs resize support
|
||||
- Unmount all btrfs subvolumes when removing a filesystem
|
||||
- Fix size argument parsing for create and snapshot command
|
||||
- Fix list output for some cases
|
||||
- Add support to create encrypted volumes with crypt backend
|
||||
- Add dry-run option
|
||||
- Fix removing volumes with crypt backend
|
||||
- Add raid1 and raid10 support for lvm backend
|
||||
- Allow to check btrfs volumes
|
||||
- Fix error handling when trying to resize btrfs subvolume
|
||||
- Fix ssm mount command so it detects directory properly
|
||||
- Suppress backtrace when a command fails
|
||||
- Fix ssm to recognize units in new btrfs output properly
|
||||
- Use correct sysfs file to get size for a partition
|
||||
- Fix ssm to be able add a device with signature to btrfs file system
|
||||
- Resognize btrfs devices from new btrfs output properly
|
||||
|
||||
|
||||
* Mon Dec 16 2013 Ville Skyttä <ville.skytta@iki.fi> - 0.2-4
|
||||
- Install docs to %%{_pkgdocdir} where available (#994122).
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Fri Jun 1 2012 Lukas Czerner <lczerner@redhat.com> 0.2-1
|
||||
- Initial version of the package
|
Loading…
Reference in New Issue
Block a user