system-config-printer/system-config-printer-no-epydoc.patch
2010-01-19 12:58:15 +00:00

57 lines
2.1 KiB
Diff

diff -up system-config-printer-1.1.16/Makefile.am.no-epydoc system-config-printer-1.1.16/Makefile.am
--- system-config-printer-1.1.16/Makefile.am.no-epydoc 2009-12-22 14:44:19.000000000 +0000
+++ system-config-printer-1.1.16/Makefile.am 2010-01-19 12:50:09.018955351 +0000
@@ -256,7 +256,9 @@ $(man_MANS): $(top_srcdir)/man/system-co
html: $(EXPORT_MODULES)
rm -rf html
- epydoc -o html --html $(EXPORT_MODULES)
+ $(MKDIR_P) html
+ pydoc -w $(EXPORT_MODULES)
+ mv $(patsubst %,%.html,$(EXPORT_MODULES)) html
distcheck-hook: update-po
diff -up system-config-printer-1.1.16/Makefile.in.no-epydoc system-config-printer-1.1.16/Makefile.in
--- system-config-printer-1.1.16/Makefile.in.no-epydoc 2009-12-22 14:44:34.000000000 +0000
+++ system-config-printer-1.1.16/Makefile.in 2010-01-19 12:50:09.020955776 +0000
@@ -1440,7 +1440,9 @@ $(man_MANS): $(top_srcdir)/man/system-co
html: $(EXPORT_MODULES)
rm -rf html
- epydoc -o html --html $(EXPORT_MODULES)
+ $(MKDIR_P) html
+ pydoc -w $(EXPORT_MODULES)
+ mv $(patsubst %,%.html,$(EXPORT_MODULES)) html
distcheck-hook: update-po
diff -up system-config-printer-1.1.16/pycups-1.9.48/Makefile.no-epydoc system-config-printer-1.1.16/pycups-1.9.48/Makefile
--- system-config-printer-1.1.16/pycups-1.9.48/Makefile.no-epydoc 2010-01-19 12:34:47.000000000 +0000
+++ system-config-printer-1.1.16/pycups-1.9.48/Makefile 2010-01-19 12:50:30.098955294 +0000
@@ -14,7 +14,9 @@ cups.so: $(SOURCES)
doc: cups.so
rm -rf html
- epydoc -o html --html $<
+ mkdir -p html
+ pydoc -w $(patsubst %.so,%,$<)
+ mv $(patsubst %.so,%.html,$<) html
clean:
-rm -rf build cups.so *.pyc *~
diff -up system-config-printer-1.1.16/pysmbc-1.0.6/Makefile.no-epydoc system-config-printer-1.1.16/pysmbc-1.0.6/Makefile
--- system-config-printer-1.1.16/pysmbc-1.0.6/Makefile.no-epydoc 2008-10-20 15:51:14.000000000 +0100
+++ system-config-printer-1.1.16/pysmbc-1.0.6/Makefile 2010-01-19 12:50:30.100081172 +0000
@@ -12,7 +12,9 @@ smbc.so: $(SOURCES)
doc: smbc.so
rm -rf html
- epydoc -o html --html $<
+ mkdir -p html
+ pydoc -w $(patsubst %.so,%,$<)
+ mv $(patsubst %.so,%.html,$<) html
clean:
-rm -rf build smbc.so *.pyc *~