- Fixed pycups build with new distutils.
- Fixed reconnection error handling in IPPAuthOperation class (bug #575198).
This commit is contained in:
parent
fd124d9dc4
commit
f95818ce06
12
system-config-printer-pycups-build.patch
Normal file
12
system-config-printer-pycups-build.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -up pycups-1.9.49/Makefile.pycups-build pycups-1.9.49/Makefile
|
||||||
|
--- pycups-1.9.49/Makefile.pycups-build 2010-03-22 12:46:31.351447572 +0000
|
||||||
|
+++ pycups-1.9.49/Makefile 2010-03-22 12:46:41.155449391 +0000
|
||||||
|
@@ -31,7 +31,7 @@ dist:
|
||||||
|
install:
|
||||||
|
ROOT= ; \
|
||||||
|
if [ -n "$$DESTDIR" ]; then ROOT="--root $$DESTDIR"; fi; \
|
||||||
|
- python setup.py install $$ROOT
|
||||||
|
+ CFLAGS=-DVERSION=\\\"$(VERSION)\\\" python setup.py install $$ROOT
|
||||||
|
|
||||||
|
.PHONY: doc clean dist install
|
||||||
|
|
29
system-config-printer-reconnect-error.patch
Normal file
29
system-config-printer-reconnect-error.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
diff -up system-config-printer-1.2.0/asyncipp.py.reconnect-error system-config-printer-1.2.0/asyncipp.py
|
||||||
|
--- system-config-printer-1.2.0/asyncipp.py.reconnect-error 2010-01-27 11:17:44.000000000 +0000
|
||||||
|
+++ system-config-printer-1.2.0/asyncipp.py 2010-03-22 11:54:54.320452998 +0000
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
#!/usr/bin/env python
|
||||||
|
|
||||||
|
-## Copyright (C) 2007, 2008, 2009 Red Hat, Inc.
|
||||||
|
+## Copyright (C) 2007, 2008, 2009, 2010 Red Hat, Inc.
|
||||||
|
## Copyright (C) 2008 Novell, Inc.
|
||||||
|
## Author: Tim Waugh <twaugh@redhat.com>
|
||||||
|
|
||||||
|
@@ -333,7 +333,7 @@ class _IPPAuthOperation:
|
||||||
|
# This is the initial "connection" operation, or a
|
||||||
|
# subsequent reconnection attempt.
|
||||||
|
debugprint ("Connection/reconnection failed")
|
||||||
|
- return self._reconnect_error (exc)
|
||||||
|
+ return self._reconnect_error (conn, exc)
|
||||||
|
|
||||||
|
if self._cancel:
|
||||||
|
return self._error (exc)
|
||||||
|
@@ -353,7 +353,7 @@ class _IPPAuthOperation:
|
||||||
|
e == cups.IPP_FORBIDDEN):
|
||||||
|
forbidden = (e == cups.IPP_FORBIDDEN)
|
||||||
|
elif e == cups.IPP_SERVICE_UNAVAILABLE:
|
||||||
|
- return self._reconnect_error (exc)
|
||||||
|
+ return self._reconnect_error (conn, exc)
|
||||||
|
else:
|
||||||
|
return self._error (exc)
|
||||||
|
elif type (exc) == cups.HTTPError:
|
@ -7,7 +7,7 @@
|
|||||||
Summary: A printer administration tool
|
Summary: A printer administration tool
|
||||||
Name: system-config-printer
|
Name: system-config-printer
|
||||||
Version: 1.2.0
|
Version: 1.2.0
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: http://cyberelk.net/tim/software/system-config-printer/
|
URL: http://cyberelk.net/tim/software/system-config-printer/
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
@ -23,6 +23,9 @@ Patch3: system-config-printer-cdi-no-drivers.patch
|
|||||||
Patch4: system-config-printer-cdi-cmd.patch
|
Patch4: system-config-printer-cdi-cmd.patch
|
||||||
Patch5: system-config-printer-kyocera-mita.patch
|
Patch5: system-config-printer-kyocera-mita.patch
|
||||||
Patch6: system-config-printer-cdi-filename.patch
|
Patch6: system-config-printer-cdi-filename.patch
|
||||||
|
Patch7: system-config-printer-reconnect-error.patch
|
||||||
|
|
||||||
|
Patch100: system-config-printer-pycups-build.patch
|
||||||
|
|
||||||
BuildRequires: cups-devel >= 1.2
|
BuildRequires: cups-devel >= 1.2
|
||||||
BuildRequires: python-devel >= 2.4
|
BuildRequires: python-devel >= 2.4
|
||||||
@ -100,6 +103,16 @@ printers.
|
|||||||
# check-device-ids.py: Fixed driver-URI to filename mapping.
|
# check-device-ids.py: Fixed driver-URI to filename mapping.
|
||||||
%patch6 -p1 -b .cdi-filename
|
%patch6 -p1 -b .cdi-filename
|
||||||
|
|
||||||
|
# Fixed reconnection error handling in IPPAuthOperation class (bug #575198).
|
||||||
|
%patch7 -p1 -b .reconnect-error
|
||||||
|
|
||||||
|
pushd pycups-%{pycups_version}
|
||||||
|
|
||||||
|
# Fixed pycups build with new distutils.
|
||||||
|
%patch100 -p1 -b .pycups-build
|
||||||
|
|
||||||
|
popd
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-udev-rules
|
%configure --with-udev-rules
|
||||||
|
|
||||||
@ -215,6 +228,10 @@ rm -rf %buildroot
|
|||||||
exit 0
|
exit 0
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Mar 22 2010 Tim Waugh <twaugh@redhat.com> - 1.2.0-5
|
||||||
|
- Fixed pycups build with new distutils.
|
||||||
|
- Fixed reconnection error handling in IPPAuthOperation class (bug #575198).
|
||||||
|
|
||||||
* Fri Mar 19 2010 Tim Waugh <twaugh@redhat.com> - 1.2.0-4
|
* Fri Mar 19 2010 Tim Waugh <twaugh@redhat.com> - 1.2.0-4
|
||||||
- check-device-ids.py: Fixed driver-URI to filename mapping.
|
- check-device-ids.py: Fixed driver-URI to filename mapping.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user