- Fixed small UI problem in SMB browser.
This commit is contained in:
parent
b752856d66
commit
ef133e7380
41
system-config-printer-scanning.patch
Normal file
41
system-config-printer-scanning.patch
Normal file
@ -0,0 +1,41 @@
|
||||
From 13c584b417496be4a99560a71bf0950cf9ec5269 Mon Sep 17 00:00:00 2001
|
||||
From: Tim Waugh <twaugh@redhat.com>
|
||||
Date: Fri, 23 May 2008 16:17:03 +0100
|
||||
Subject: [PATCH] Removed Scanning... label when SMB browsing shows no workgroups.
|
||||
|
||||
---
|
||||
ChangeLog | 4 ++++
|
||||
system-config-printer.py | 2 +-
|
||||
2 files changed, 5 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/ChangeLog b/ChangeLog
|
||||
index 9b10f43..3d7c547 100644
|
||||
--- a/ChangeLog
|
||||
+++ b/ChangeLog
|
||||
@@ -1,5 +1,9 @@
|
||||
2008-05-23 Tim Waugh <twaugh@redhat.com>
|
||||
|
||||
+ * system-config-printer.py
|
||||
+ (NewPrinterGUI.browse_smb_hosts_thread): Remove the 'Scanning...'
|
||||
+ label when browsing is unsuccessful.
|
||||
+
|
||||
* configure.in: Version 0.9.93.
|
||||
|
||||
2008-05-23 Tim Waugh <twaugh@redhat.com>
|
||||
diff --git a/system-config-printer.py b/system-config-printer.py
|
||||
index a793ef1..6564de8 100755
|
||||
--- a/system-config-printer.py
|
||||
+++ b/system-config-printer.py
|
||||
@@ -3355,8 +3355,8 @@ class NewPrinterGUI(GtkGUI):
|
||||
store.set_value (iter, 0, d['DOMAIN'])
|
||||
store.set_value (iter, 2, d)
|
||||
else:
|
||||
+ store.clear ()
|
||||
if workgroups:
|
||||
- store.clear ()
|
||||
for workgroup in workgroups:
|
||||
iter = store.append (None, [workgroup])
|
||||
i = store.append (iter)
|
||||
--
|
||||
1.5.4.3
|
||||
|
@ -6,13 +6,14 @@
|
||||
Summary: A printer administration tool
|
||||
Name: system-config-printer
|
||||
Version: 0.9.93
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
License: GPLv2+
|
||||
URL: http://cyberelk.net/tim/software/system-config-printer/
|
||||
Group: System Environment/Base
|
||||
Source0: http://cyberelk.net/tim/data/system-config-printer/system-config-printer-%{version}.tar.bz2
|
||||
Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
|
||||
Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
|
||||
Patch1: system-config-printer-scanning.patch
|
||||
|
||||
BuildRequires: cups-devel >= 1.2
|
||||
BuildRequires: python-devel >= 2.4
|
||||
@ -58,6 +59,7 @@ the configuration tool.
|
||||
|
||||
%prep
|
||||
%setup -q -a 1 -a 2
|
||||
%patch1 -p1 -b .scanning
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -141,6 +143,9 @@ rm -rf %buildroot
|
||||
exit 0
|
||||
|
||||
%changelog
|
||||
* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-2
|
||||
- Fixed small UI problem in SMB browser.
|
||||
|
||||
* Fri May 23 2008 Tim Waugh <twaugh@redhat.com> 0.9.93-1
|
||||
- 0.9.93.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user