diff --git a/system-config-printer-0.7.74.x.patch b/system-config-printer-0.7.74.x.patch
new file mode 100644
index 0000000..b8da9e5
--- /dev/null
+++ b/system-config-printer-0.7.74.x.patch
@@ -0,0 +1,267 @@
+Index: po/sr@Latn.po
+===================================================================
+Index: po/as.po
+===================================================================
+Index: po/bs.po
+===================================================================
+Index: po/cs.po
+===================================================================
+Index: po/pt_BR.po
+===================================================================
+Index: po/mk.po
+===================================================================
+Index: po/es.po
+===================================================================
+Index: po/ko.po
+===================================================================
+Index: po/lo.po
+===================================================================
+Index: po/is.po
+===================================================================
+Index: po/no.po
+===================================================================
+Index: po/sk.po
+===================================================================
+Index: po/ms.po
+===================================================================
+Index: po/uk.po
+===================================================================
+Index: po/ro.po
+===================================================================
+Index: po/system-config-printer.pot
+===================================================================
+Index: po/nb.po
+===================================================================
+Index: po/bn.po
+===================================================================
+Index: po/ar.po
+===================================================================
+Index: po/fr.po
+===================================================================
+Index: po/kn.po
+===================================================================
+Index: po/hr.po
+===================================================================
+Index: po/nn.po
+===================================================================
+Index: po/mr.po
+===================================================================
+Index: po/or.po
+===================================================================
+Index: po/lv.po
+===================================================================
+Index: po/ca.po
+===================================================================
+Index: po/sr.po
+===================================================================
+Index: po/da.po
+===================================================================
+Index: po/bn_IN.po
+===================================================================
+Index: po/tr.po
+===================================================================
+Index: po/fa.po
+===================================================================
+Index: po/de.po
+===================================================================
+Index: po/sv.po
+===================================================================
+Index: po/ja.po
+===================================================================
+Index: po/ka.po
+===================================================================
+Index: po/zh_TW.po
+===================================================================
+Index: po/fi.po
+===================================================================
+Index: po/pa.po
+===================================================================
+Index: po/hi.po
+===================================================================
+Index: po/zh_CN.po
+===================================================================
+Index: po/ta.po
+===================================================================
+Index: po/te.po
+===================================================================
+Index: po/en_GB.po
+===================================================================
+Index: po/si.po
+===================================================================
+Index: po/cy.po
+===================================================================
+Index: po/gu.po
+===================================================================
+Index: po/hu.po
+===================================================================
+Index: po/vi.po
+===================================================================
+Index: po/hy.po
+===================================================================
+Index: po/my.po
+===================================================================
+Index: po/ru.po
+===================================================================
+Index: po/id.po
+===================================================================
+Index: po/el.po
+===================================================================
+Index: po/ml.po
+===================================================================
+Index: po/et.po
+===================================================================
+Index: po/nl.po
+===================================================================
+Index: po/pl.po
+===================================================================
+Index: po/it.po
+===================================================================
+Index: po/sl.po
+===================================================================
+Index: po/pt.po
+===================================================================
+Index: po/bg.po
+===================================================================
+Index: system-config-printer.glade
+===================================================================
+--- system-config-printer.glade (.../tags/0.7.74.2) (revision 1571)
++++ system-config-printer.glade (.../branches/0.7.74.x) (revision 1571)
+@@ -432,6 +432,40 @@
+
+
+
++
++ True
++ 0.5
++ 0.5
++ 1
++ 1
++ 0
++ 0
++ 12
++ 0
++
++
++
++ True
++ True
++ Allow printing from the Internet
++ True
++ GTK_RELIEF_NORMAL
++ True
++ False
++ False
++ True
++
++
++
++
++
++ 0
++ False
++ False
++
++
++
++
+
+ True
+ True
+Index: ChangeLog
+===================================================================
+--- ChangeLog (.../tags/0.7.74.2) (revision 1571)
++++ ChangeLog (.../branches/0.7.74.x) (revision 1571)
+@@ -1,3 +1,18 @@
++2007-09-04 Tim Waugh
++
++ * system-config-printer.py (GUI.setConnected): Set sensitivity for
++ new check-box.
++ (GUI.fillServerTab): Show setting for new check-box.
++ (GUI.on_server_changed): Set sensitivity for new check-box.
++ (GUI.save_serversettings): Set server setting from check-box.
++
++ * system-config-printer.glade: New check-box for 'Allow printing
++ from the Internet'.
++
++2007-09-21 Tim Waugh
++
++ * po/ko.po: Updated (from 0.7.32.x POT; needs further updating).
++
+ 2007-09-19 Tim Waugh
+
+ * configure.in: Version 0.7.74.2.
+Index: system-config-printer.py
+===================================================================
+--- system-config-printer.py (.../tags/0.7.74.2) (revision 1571)
++++ system-config-printer.py (.../branches/0.7.74.x) (revision 1571)
+@@ -74,6 +74,12 @@
+ ready_cursor = gtk.gdk.Cursor(gtk.gdk.LEFT_PTR)
+ ellipsis = unichr(0x2026)
+
++try:
++ try_CUPS_SERVER_REMOTE_ANY = cups.CUPS_SERVER_REMOTE_ANY
++except AttributeError:
++ # cups module was compiled with CUPS < 1.3
++ try_CUPS_SERVER_REMOTE_ANY = "_remote_any"
++
+ def nonfatalException ():
+ print "Caught non-fatal exception. Traceback:"
+ (type, value, tb) = sys.exc_info ()
+@@ -135,6 +141,7 @@
+ "btnApply", "btnRevert", "btnConflict",
+
+ "chkServerBrowse", "chkServerShare",
++ "chkServerShareAny",
+ "chkServerRemoteAdmin", "chkServerAllowCancelAll",
+ "chkServerLogDebug",
+
+@@ -607,6 +614,9 @@
+ self.chkServerLogDebug):
+ widget.set_sensitive(connected)
+
++ sharing = self.chkServerShare.get_active ()
++ self.chkServerShareAny.set_sensitive (sharing)
++
+ try:
+ del self.server_settings
+ except:
+@@ -3625,15 +3635,17 @@
+ for widget, setting in [
+ (self.chkServerBrowse, cups.CUPS_SERVER_REMOTE_PRINTERS),
+ (self.chkServerShare, cups.CUPS_SERVER_SHARE_PRINTERS),
++ (self.chkServerShareAny, try_CUPS_SERVER_REMOTE_ANY),
+ (self.chkServerRemoteAdmin, cups.CUPS_SERVER_REMOTE_ADMIN),
+ (self.chkServerAllowCancelAll, cups.CUPS_SERVER_USER_CANCEL_ANY),
+ (self.chkServerLogDebug, cups.CUPS_SERVER_DEBUG_LOGGING),]:
+ widget.set_data("setting", setting)
+ if self.server_settings.has_key(setting):
+ widget.set_active(int(self.server_settings[setting]))
+- widget.show()
++ widget.set_sensitive(True)
+ else:
+- widget.hide()
++ widget.set_active(False)
++ widget.set_sensitive(False)
+ self.setDataButtonState()
+
+ def on_server_changed(self, widget):
+@@ -3642,6 +3654,11 @@
+ self.changed.discard(widget)
+ else:
+ self.changed.add(widget)
++
++ sharing = self.chkServerShare.get_active ()
++ self.chkServerShareAny.set_sensitive (
++ sharing and self.server_settings.has_key(try_CUPS_SERVER_REMOTE_ANY))
++
+ self.setDataButtonState()
+
+ def save_serversettings(self):
+@@ -3649,6 +3666,7 @@
+ for widget, setting in [
+ (self.chkServerBrowse, cups.CUPS_SERVER_REMOTE_PRINTERS),
+ (self.chkServerShare, cups.CUPS_SERVER_SHARE_PRINTERS),
++ (self.chkServerShareAny, try_CUPS_SERVER_REMOTE_ANY),
+ (self.chkServerRemoteAdmin, cups.CUPS_SERVER_REMOTE_ADMIN),
+ (self.chkServerAllowCancelAll, cups.CUPS_SERVER_USER_CANCEL_ANY),
+ (self.chkServerLogDebug, cups.CUPS_SERVER_DEBUG_LOGGING),]:
diff --git a/system-config-printer.spec b/system-config-printer.spec
index dac6075..f7635c1 100644
--- a/system-config-printer.spec
+++ b/system-config-printer.spec
@@ -3,7 +3,7 @@
Summary: A printer administration tool
Name: system-config-printer
Version: 0.7.74.2
-Release: 1%{?dist}
+Release: 2%{?dist}
License: GPLv2+
URL: http://cyberelk.net/tim/software/system-config-printer/
Group: System Environment/Base
@@ -11,6 +11,7 @@ Source0: system-config-printer-%{version}.tar.bz2
Source1: pycups-%{pycups_version}.tar.bz2
Source2: system-config-printer.pam
Source3: system-config-printer.console
+Patch0: system-config-printer-0.7.74.x.patch
BuildRequires: cups-devel >= 1.2
BuildRequires: python-devel >= 2.4
@@ -51,6 +52,7 @@ the configuration tool.
%prep
%setup -q -a 1
+%patch0 -p0 -b .0.7.74.x
%build
%configure
@@ -128,6 +130,10 @@ if [ "$1" = "0" ]; then
fi
%changelog
+* Fri Sep 21 2007 Tim Waugh 0.7.74.2-2
+- Pull in SVN patch from stable branch for 'Allow printing from
+ the Internet' check-box (bug #221003).
+
* Wed Sep 19 2007 Tim Waugh 0.7.74.2-1
- Updated pycups to 1.9.27.
- 0.7.74.2: