- Updated pycups to 1.9.51 (bug #584991).

This commit is contained in:
Tim Waugh 2010-06-25 16:22:55 +00:00
parent 4e3e619ada
commit a4e37c5d29
4 changed files with 8 additions and 63 deletions

View File

@ -221,3 +221,4 @@ system-config-printer-1.2.2.tar.xz
pysmbc-1.0.7.tar.bz2
pycups-1.9.50.tar.bz2
system-config-printer-1.2.3.tar.xz
pycups-1.9.51.tar.bz2

View File

@ -1,3 +1,4 @@
89e6fd9129f1700eec16156bdbf60dda pysmbc-1.0.7.tar.bz2
cae67ab1207f5ffa93edc9b5867738bb pycups-1.9.50.tar.bz2
e9ab97e4b0fdff5a75e1a5874808c2c1 system-config-printer-1.2.3.tar.xz
7e9de64bce9496ce2d36ab513dd69dd5 pycups-1.9.51.tar.bz2

View File

@ -1,56 +0,0 @@
diff -up system-config-printer-1.2.2/Makefile.am.no-epydoc system-config-printer-1.2.2/Makefile.am
--- system-config-printer-1.2.2/Makefile.am.no-epydoc 2010-05-07 15:19:03.000000000 +0100
+++ system-config-printer-1.2.2/Makefile.am 2010-05-18 12:57:39.219065881 +0100
@@ -248,7 +248,9 @@ $(man_MANS): $(top_srcdir)/man/system-co
html: $(EXPORT_MODULES)
rm -rf html
- epydoc -o html --html $(EXPORT_MODULES)
+ $(MKDIR_P) html
+ pydoc -w $(EXPORT_MODULES)
+ mv $(patsubst %,%.html,$(EXPORT_MODULES)) html
distcheck-hook: update-po missing-imports
diff -up system-config-printer-1.2.2/Makefile.in.no-epydoc system-config-printer-1.2.2/Makefile.in
--- system-config-printer-1.2.2/Makefile.in.no-epydoc 2010-05-07 15:26:09.000000000 +0100
+++ system-config-printer-1.2.2/Makefile.in 2010-05-18 12:57:39.222067064 +0100
@@ -1431,7 +1431,9 @@ $(man_MANS): $(top_srcdir)/man/system-co
html: $(EXPORT_MODULES)
rm -rf html
- epydoc -o html --html $(EXPORT_MODULES)
+ $(MKDIR_P) html
+ pydoc -w $(EXPORT_MODULES)
+ mv $(patsubst %,%.html,$(EXPORT_MODULES)) html
distcheck-hook: update-po missing-imports
diff -up system-config-printer-1.2.2/pycups-1.9.50/Makefile.no-epydoc system-config-printer-1.2.2/pycups-1.9.50/Makefile
--- system-config-printer-1.2.2/pycups-1.9.50/Makefile.no-epydoc 2010-03-10 09:45:10.000000000 +0000
+++ system-config-printer-1.2.2/pycups-1.9.50/Makefile 2010-05-18 12:57:39.226942671 +0100
@@ -14,7 +14,9 @@ cups.so: $(SOURCES)
doc: cups.so
rm -rf html
- epydoc -o html --html $<
+ mkdir -p html
+ pydoc -w $(patsubst %.so,%,$<)
+ mv $(patsubst %.so,%.html,$<) html
clean:
-rm -rf build cups.so *.pyc *~
diff -up system-config-printer-1.2.2/pysmbc-1.0.7/Makefile.no-epydoc system-config-printer-1.2.2/pysmbc-1.0.7/Makefile
--- system-config-printer-1.2.2/pysmbc-1.0.7/Makefile.no-epydoc 2010-05-18 11:59:35.000000000 +0100
+++ system-config-printer-1.2.2/pysmbc-1.0.7/Makefile 2010-05-18 12:58:28.680066521 +0100
@@ -8,7 +8,9 @@ smbc.so: $(SOURCES)
doc: smbc.so
rm -rf html
- epydoc -o html --html $<
+ mkdir -p html
+ pydoc -w $(patsubst %.so,%,$<)
+ mv $(patsubst %.so,%.html,$<) html
clean:
-rm -rf build smbc.so *.pyc tests/*.pyc *~ tests/*~

View File

@ -1,4 +1,4 @@
%global pycups_version 1.9.50
%global pycups_version 1.9.51
%global pysmbc_version 1.0.7
%{!?python_sitelib: %global python_sitelib %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
%{!?python_sitearch: %global python_sitearch %(%{__python} -c "from distutils.sysconfig import get_python_lib; print get_python_lib(1)")}
@ -7,7 +7,7 @@
Summary: A printer administration tool
Name: system-config-printer
Version: 1.2.3
Release: 1%{?dist}
Release: 3%{?dist}
License: GPLv2+
URL: http://cyberelk.net/tim/software/system-config-printer/
Group: System Environment/Base
@ -17,8 +17,6 @@ Source1: http://cyberelk.net/tim/data/pycups/pycups-%{pycups_version}.tar.bz2
# Python bindings for libsmbclient
Source2: http://cyberelk.net/tim/data/pysmbc/pysmbc-%{pysmbc_version}.tar.bz2
Patch1: system-config-printer-no-epydoc.patch
BuildRequires: cups-devel >= 1.2
BuildRequires: python-devel >= 2.4
BuildRequires: libsmbclient-devel >= 3.2
@ -26,7 +24,7 @@ BuildRequires: desktop-file-utils >= 0.2.92
BuildRequires: gettext-devel
BuildRequires: intltool
BuildRequires: libusb-devel, libudev-devel, glib2-devel
BuildRequires: xmlto
BuildRequires: epydoc, xmlto
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -76,8 +74,6 @@ printers.
%prep
%setup -q -a 1 -a 2
# Don't require epydoc.
%patch1 -p1 -b .no-epydoc
%build
%configure --with-udev-rules
@ -197,6 +193,9 @@ rm -rf %buildroot
exit 0
%changelog
* Fri Jun 25 2010 Tim Waugh <twaugh@redhat.com> - 1.2.3-3
- Updated pycups to 1.9.51 (bug #584991).
* Thu Jun 24 2010 Tim Waugh <twaugh@redhat.com> - 1.2.3-1
- Updated to 1.2.3:
- Use toolbar instead of menubar in JobsViewer (trac #205).