- Avoid epydoc dependency.

This commit is contained in:
Tim Waugh 2009-10-30 12:32:02 +00:00
parent 0b57565b58
commit 7b7a93c0dd
2 changed files with 61 additions and 1 deletions

View File

@ -0,0 +1,56 @@
diff -up system-config-printer-1.1.13/Makefile.am.no-epydoc system-config-printer-1.1.13/Makefile.am
--- system-config-printer-1.1.13/Makefile.am.no-epydoc 2009-09-04 10:35:47.000000000 +0100
+++ system-config-printer-1.1.13/Makefile.am 2009-10-30 11:32:02.265645319 +0000
@@ -251,7 +251,9 @@ $(man_MANS): $(top_srcdir)/man/system-co
html: $(EXPORT_MODULES)
rm -rf html
- epydoc -o html --html $(EXPORT_MODULES)
+ $(MKDIR_P) html
+ pydoc -w $(EXPORT_MODULES)
+ mv $(patsubst %,%.html,$(EXPORT_MODULES)) html
distcheck-hook: update-po
diff -up system-config-printer-1.1.13/Makefile.in.no-epydoc system-config-printer-1.1.13/Makefile.in
--- system-config-printer-1.1.13/Makefile.in.no-epydoc 2009-09-14 15:14:03.000000000 +0100
+++ system-config-printer-1.1.13/Makefile.in 2009-10-30 11:32:02.266644059 +0000
@@ -1435,7 +1435,9 @@ $(man_MANS): $(top_srcdir)/man/system-co
html: $(EXPORT_MODULES)
rm -rf html
- epydoc -o html --html $(EXPORT_MODULES)
+ $(MKDIR_P) html
+ pydoc -w $(EXPORT_MODULES)
+ mv $(patsubst %,%.html,$(EXPORT_MODULES)) html
distcheck-hook: update-po
diff -up system-config-printer-1.1.13/pycups-1.9.46/Makefile.no-epydoc system-config-printer-1.1.13/pycups-1.9.46/Makefile
--- system-config-printer-1.1.13/pycups-1.9.46/Makefile.no-epydoc 2009-10-30 11:32:53.089519286 +0000
+++ system-config-printer-1.1.13/pycups-1.9.46/Makefile 2009-10-30 11:33:07.606519162 +0000
@@ -14,7 +14,9 @@ cups.so: $(SOURCES)
doc: cups.so
rm -rf html
- epydoc -o html --html $<
+ mkdir -p html
+ pydoc -w $(patsubst %.so,%,$<)
+ mv $(patsubst %.so,%.html,$<) html
clean:
-rm -rf build cups.so *.pyc *~
diff -up system-config-printer-1.1.13/pysmbc-1.0.6/Makefile.no-epydoc system-config-printer-1.1.13/pysmbc-1.0.6/Makefile
--- system-config-printer-1.1.13/pysmbc-1.0.6/Makefile.no-epydoc 2009-10-30 11:32:18.597519903 +0000
+++ system-config-printer-1.1.13/pysmbc-1.0.6/Makefile 2009-10-30 11:32:43.671520242 +0000
@@ -12,7 +12,9 @@ smbc.so: $(SOURCES)
doc: smbc.so
rm -rf html
- epydoc -o html --html $<
+ mkdir -p html
+ pydoc -w $(patsubst %.so,%,$<)
+ mv $(patsubst %.so,%.html,$<) html
clean:
-rm -rf build smbc.so *.pyc *~

View File

@ -31,6 +31,7 @@ Patch13: system-config-printer-strip-zxs-pcl3.patch
Patch14: system-config-printer-troubleshoot-network-printers.patch
Patch15: system-config-printer-strip-zjs.patch
Patch16: system-config-printer-custom-state-reasons.patch
Patch17: system-config-printer-no-epydoc.patch
BuildRequires: cups-devel >= 1.2
BuildRequires: python-devel >= 2.4
@ -40,7 +41,6 @@ BuildRequires: gettext-devel
BuildRequires: intltool
BuildRequires: libusb-devel, libudev-devel
BuildRequires: xmlto
BuildRequires: epydoc
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@ -107,6 +107,7 @@ printers.
%patch14 -p1 -b .troubleshoot-network-printers
%patch15 -p1 -b .strip-zjs
%patch16 -p1 -b .custom-state-reasons
%patch17 -p1 -b .no-epydoc
%build
%configure --with-udev-rules --with-polkit-1
@ -218,6 +219,9 @@ rm -rf %buildroot
exit 0
%changelog
* Fri Oct 30 2009 Tim Waugh <twaugh@redhat.com> 1.1.13-6
- Avoid epydoc dependency.
* Thu Oct 29 2009 Tim Waugh <twaugh@redhat.com> 1.1.13-5
- Added upstream patch for custom state reasons (bug #531872).
- Strip 'zjs' from make-and-model as well (bug #531869).