- Updated from git:

- Better make/model discovery for multiple devices (bug #484130).
This commit is contained in:
Tim Waugh 2009-02-10 18:35:55 +00:00
parent 972ff65857
commit 6dc8cf7b3d
2 changed files with 41 additions and 11 deletions

View File

@ -1,6 +1,6 @@
diff -up system-config-printer-1.1.3/authconn.py.git-1.1.x system-config-printer-1.1.3/authconn.py
--- system-config-printer-1.1.3/authconn.py.git-1.1.x 2009-02-02 17:49:39.000000000 +0000
+++ system-config-printer-1.1.3/authconn.py 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/authconn.py 2009-02-10 18:35:04.000000000 +0000
@@ -19,8 +19,10 @@
import threading
@ -59,7 +59,7 @@ diff -up system-config-printer-1.1.3/authconn.py.git-1.1.x system-config-printer
self._failed (e == cups.IPP_FORBIDDEN)
diff -U0 system-config-printer-1.1.3/ChangeLog.git-1.1.x system-config-printer-1.1.3/ChangeLog
--- system-config-printer-1.1.3/ChangeLog.git-1.1.x 2009-02-02 17:49:39.000000000 +0000
+++ system-config-printer-1.1.3/ChangeLog 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/ChangeLog 2009-02-10 18:35:04.000000000 +0000
@@ -0,0 +1,19 @@
+2009-02-10 Tim Waugh <twaugh@redhat.com>
+
@ -82,7 +82,7 @@ diff -U0 system-config-printer-1.1.3/ChangeLog.git-1.1.x system-config-printer-1
+
diff -up /dev/null system-config-printer-1.1.3/cupspk.py
--- /dev/null 2009-02-10 09:39:07.061189340 +0000
+++ system-config-printer-1.1.3/cupspk.py 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/cupspk.py 2009-02-10 18:35:04.000000000 +0000
@@ -0,0 +1,732 @@
+# vim: set ts=4 sw=4 et: coding=UTF-8
+#
@ -818,7 +818,7 @@ diff -up /dev/null system-config-printer-1.1.3/cupspk.py
+# printFiles
diff -up system-config-printer-1.1.3/jobviewer.py.git-1.1.x system-config-printer-1.1.3/jobviewer.py
--- system-config-printer-1.1.3/jobviewer.py.git-1.1.x 2009-02-03 12:30:29.000000000 +0000
+++ system-config-printer-1.1.3/jobviewer.py 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/jobviewer.py 2009-02-10 18:35:04.000000000 +0000
@@ -1,5 +1,4 @@
-
@ -863,7 +863,7 @@ diff -up system-config-printer-1.1.3/jobviewer.py.git-1.1.x system-config-printe
jobdata = self.jobs[jobid]
diff -up system-config-printer-1.1.3/Makefile.am.git-1.1.x system-config-printer-1.1.3/Makefile.am
--- system-config-printer-1.1.3/Makefile.am.git-1.1.x 2009-02-02 17:49:39.000000000 +0000
+++ system-config-printer-1.1.3/Makefile.am 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/Makefile.am 2009-02-10 18:35:04.000000000 +0000
@@ -68,6 +68,7 @@ nobase_pkgdata_DATA= \
AdvancedServerSettings.py \
authconn.py \
@ -872,9 +872,35 @@ diff -up system-config-printer-1.1.3/Makefile.am.git-1.1.x system-config-printer
debug.py \
errordialogs.py \
HIG.py \
diff -up system-config-printer-1.1.3/PhysicalDevice.py.git-1.1.x system-config-printer-1.1.3/PhysicalDevice.py
--- system-config-printer-1.1.3/PhysicalDevice.py.git-1.1.x 2009-01-12 16:46:56.000000000 +0000
+++ system-config-printer-1.1.3/PhysicalDevice.py 2009-02-10 18:35:04.000000000 +0000
@@ -1,7 +1,7 @@
#!/usr/bin/env python
-## Copyright (C) 2008 Tim Waugh <twaugh@redhat.com>
-## Copyright (C) 2008 Red Hat, Inc.
+## Copyright (C) 2008, 2009 Tim Waugh <twaugh@redhat.com>
+## Copyright (C) 2008, 2009 Red Hat, Inc.
## This program is free software; you can redistribute it and/or modify
## it under the terms of the GNU General Public License as published by
@@ -31,7 +31,11 @@ class PhysicalDevice:
if mfg == '':
return ('', '')
- make_and_model = "%s %s" % (mfg, mdl)
+ if mdl.lower ().startswith (mfg.lower ()):
+ make_and_model = mdl
+ else:
+ make_and_model = "%s %s" % (mfg, mdl)
+
return cupshelpers.ppds.ppdMakeModelSplit (make_and_model)
def add_device (self, device):
diff -up system-config-printer-1.1.3/po/fi.po.git-1.1.x system-config-printer-1.1.3/po/fi.po
--- system-config-printer-1.1.3/po/fi.po.git-1.1.x 2009-02-03 12:33:33.000000000 +0000
+++ system-config-printer-1.1.3/po/fi.po 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/po/fi.po 2009-02-10 18:35:04.000000000 +0000
@@ -3,59 +3,58 @@
#
# Mikko Ikola <ikola@iki.fi>, 2004.
@ -3726,7 +3752,7 @@ diff -up system-config-printer-1.1.3/po/fi.po.git-1.1.x system-config-printer-1.
#~ msgstr "Luo uusi tulostinryhmä"
diff -up system-config-printer-1.1.3/po/ko.po.git-1.1.x system-config-printer-1.1.3/po/ko.po
--- system-config-printer-1.1.3/po/ko.po.git-1.1.x 2009-02-03 12:33:33.000000000 +0000
+++ system-config-printer-1.1.3/po/ko.po 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/po/ko.po 2009-02-10 18:35:04.000000000 +0000
@@ -7,15 +7,15 @@ msgid ""
msgstr ""
"Project-Id-Version: system-config-printer.1.1.x\n"
@ -4368,7 +4394,7 @@ diff -up system-config-printer-1.1.3/po/ko.po.git-1.1.x system-config-printer-1.
-#~ msgstr "프린터 상태"
diff -up system-config-printer-1.1.3/po/sk.po.git-1.1.x system-config-printer-1.1.3/po/sk.po
--- system-config-printer-1.1.3/po/sk.po.git-1.1.x 2009-02-03 12:33:33.000000000 +0000
+++ system-config-printer-1.1.3/po/sk.po 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/po/sk.po 2009-02-10 18:35:04.000000000 +0000
@@ -5,20 +5,20 @@
#
# Mike Karas <zoliqe@gmail.com>, 2005.
@ -5340,7 +5366,7 @@ diff -up system-config-printer-1.1.3/po/sk.po.git-1.1.x system-config-printer-1.
msgid "System tray icon for managing print jobs"
diff -up system-config-printer-1.1.3/po/zh_CN.po.git-1.1.x system-config-printer-1.1.3/po/zh_CN.po
--- system-config-printer-1.1.3/po/zh_CN.po.git-1.1.x 2009-02-03 12:33:33.000000000 +0000
+++ system-config-printer-1.1.3/po/zh_CN.po 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/po/zh_CN.po 2009-02-10 18:35:04.000000000 +0000
@@ -1,4 +1,4 @@
-# translation of system-config-printer.1.0.x.po to Simplified Chinese
+# translation of system-config-printer.1.1.x.po to Simplified Chinese
@ -5717,7 +5743,7 @@ diff -up system-config-printer-1.1.3/po/zh_CN.po.git-1.1.x system-config-printer
msgid "Printer Location"
diff -up system-config-printer-1.1.3/system-config-printer.py.git-1.1.x system-config-printer-1.1.3/system-config-printer.py
--- system-config-printer-1.1.3/system-config-printer.py.git-1.1.x 2009-02-03 12:30:29.000000000 +0000
+++ system-config-printer-1.1.3/system-config-printer.py 2009-02-10 16:54:17.000000000 +0000
+++ system-config-printer-1.1.3/system-config-printer.py 2009-02-10 18:35:04.000000000 +0000
@@ -854,6 +854,8 @@ class GUI(GtkGUI, monitor.Watcher):
name = unicode (model.get_value (iter, 2))
if name == queue:

View File

@ -7,7 +7,7 @@
Summary: A printer administration tool
Name: system-config-printer
Version: 1.1.3
Release: 5%{?dist}
Release: 6%{?dist}
License: GPLv2+
URL: http://cyberelk.net/tim/software/system-config-printer/
Group: System Environment/Base
@ -169,6 +169,10 @@ rm -rf %buildroot
exit 0
%changelog
* Tue Feb 10 2009 Tim Waugh <twaugh@redhat.com> 1.1.3-6
- Updated from git:
- Better make/model discovery for multiple devices (bug #484130).
* Tue Feb 10 2009 Tim Waugh <twaugh@redhat.com> 1.1.3-5
- Updated from git:
- Handle D-Bus failures when querying Jockey (bug #484402).