2178027 - fix crash in options.py

This commit is contained in:
Zdenek Dohnal 2023-03-14 14:53:36 +01:00
parent 940702d8fa
commit 345fa66ba9
2 changed files with 44 additions and 1 deletions

View File

@ -0,0 +1,38 @@
From 399b3334d6519639cfe7f1c0457e2475b8ee5230 Mon Sep 17 00:00:00 2001
From: Zdenek Dohnal <zdohnal@redhat.com>
Date: Thu, 13 Oct 2022 14:03:37 +0200
Subject: [PATCH] Fix debugprint() in options.py (fixes #291)
---
NEWS | 4 ++++
options.py | 2 +-
2 files changed, 5 insertions(+), 1 deletion(-)
diff --git a/NEWS b/NEWS
index a6438482..910e4696 100644
--- a/NEWS
+++ b/NEWS
@@ -1,3 +1,7 @@
+1.5.19 changes
+--------------
+- Fix `debugprint()` call in options.py (Issue #291)
+
1.5.18 changes
--------------
- Add <launchable/> into the .appdata.xml file (#269)
diff --git a/options.py b/options.py
index d756f98d..d7c236de 100644
--- a/options.py
+++ b/options.py
@@ -423,7 +423,7 @@ class OptionSelectOne(Option):
debugprint("Unknown value for %s: %s" % (name, value))
debugprint("Choices: %s" % (supported))
if len(supported) > 0:
- debugprint("Selecting from choices:", supported[0])
+ debugprint("Selecting from choices: %s" % supported[0])
self.selector.set_active(0)
self.selector.connect("changed", self.changed)
--
2.39.2

View File

@ -9,12 +9,13 @@
Summary: A printer administration tool
Name: system-config-printer
Version: 1.5.18
Release: 2%{?dist}
Release: 3%{?dist}
License: GPLv2+
URL: https://github.com/%{username}/%{name}
Source0: %{url}/releases/download/%{version}/%{name}-%{version}.tar.xz
# all upstream patches, remove with new release
Patch0001: 0001-Fix-debugprint-in-options.py-fixes-291.patch
# needed for macro AM_GNU_GETTEXT in configure.ac
@ -41,6 +42,7 @@ BuildRequires: make
BuildRequires: pkgconfig(glib-2.0)
# for python3 API
BuildRequires: python3-devel
BuildRequires: python3-setuptools
# for automatic USB printer setup tool - udev-configure-printer
BuildRequires: systemd
BuildRequires: systemd-devel
@ -290,6 +292,9 @@ exit 0
%endif
%changelog
* Tue Mar 14 2023 Zdenek Dohnal <zdohnal@redhat.com> - 1.5.18-3
- 2178027 - fix crash in options.py
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 1.5.18-2
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild