- Pull in SVN patch from stable branch for foomatic recommended drivers

(bug #292021).
This commit is contained in:
Tim Waugh 2007-09-25 11:41:06 +00:00
parent abadf11e30
commit 2eb131c2de
2 changed files with 53 additions and 8 deletions

View File

@ -124,8 +124,8 @@ Index: po/bg.po
===================================================================
Index: system-config-printer.glade
===================================================================
--- system-config-printer.glade (.../tags/0.7.74.2) (revision 1571)
+++ system-config-printer.glade (.../branches/0.7.74.x) (revision 1571)
--- system-config-printer.glade (.../tags/0.7.74.2) (revision 1574)
+++ system-config-printer.glade (.../branches/0.7.74.x) (revision 1574)
@@ -432,6 +432,40 @@
</child>
@ -169,9 +169,17 @@ Index: system-config-printer.glade
<property name="can_focus">True</property>
Index: ChangeLog
===================================================================
--- ChangeLog (.../tags/0.7.74.2) (revision 1571)
+++ ChangeLog (.../branches/0.7.74.x) (revision 1571)
@@ -1,3 +1,18 @@
--- ChangeLog (.../tags/0.7.74.2) (revision 1574)
+++ ChangeLog (.../branches/0.7.74.x) (revision 1574)
@@ -1,3 +1,26 @@
+2007-09-25 Tim Waugh <twaugh@redhat.com>
+
+ * ppds.py (getDriverType): Fix foomatic recommended driver
+ discovery (requires CUPS patch to prevent '(recommended)' string
+ getting stripped).
+ (PPDs.getDriverTypeWithBias): Let getDriverType have access to the
+ PPDs object.
+
+2007-09-04 Tim Waugh <twaugh@redhat.com>
+
+ * system-config-printer.py (GUI.setConnected): Set sensitivity for
@ -190,10 +198,43 @@ Index: ChangeLog
2007-09-19 Tim Waugh <twaugh@redhat.com>
* configure.in: Version 0.7.74.2.
Index: ppds.py
===================================================================
--- ppds.py (.../tags/0.7.74.2) (revision 1574)
+++ ppds.py (.../branches/0.7.74.x) (revision 1574)
@@ -112,7 +112,7 @@
DRIVER_TYPE_CUPS = 80
DRIVER_TYPE_FOOMATIC_GENERIC = 90
DRIVER_DOES_NOT_WORK = 999
-def getDriverType (ppdname):
+def getDriverType (ppdname, ppds=None):
"""Decides which of the above types ppdname is."""
if ppdname.startswith ("gutenprint"):
if ppdname.find ("/simple/") != -1:
@@ -128,7 +128,9 @@
# Foomatic (generated) -- but which driver?
if ppdname.find ("Generic")!= -1:
return DRIVER_TYPE_FOOMATIC_GENERIC
- if ppdname.find ("(recommended)")!= -1:
+ if (ppds != None and
+ ppds.getInfoFromPPDName (ppdname).\
+ get ('ppd-make-and-model', '').find ("(recommended)") != -1):
return DRIVER_TYPE_FOOMATIC_RECOMMENDED
if ppdname.find ("-Postscript")!= -1:
return DRIVER_TYPE_FOOMATIC_PS
@@ -234,7 +236,7 @@
make_model = dict['ppd-make-and-model']
mfg, mdl = ppdMakeModelSplit (make_model)
def getDriverTypeWithBias (x, mfg):
- t = getDriverType (x)
+ t = getDriverType (x, ppds=self)
if mfg == "HP":
if t == DRIVER_TYPE_FOOMATIC_HPIJS:
# Prefer HPIJS for HP devices.
Index: system-config-printer.py
===================================================================
--- system-config-printer.py (.../tags/0.7.74.2) (revision 1571)
+++ system-config-printer.py (.../branches/0.7.74.x) (revision 1571)
--- system-config-printer.py (.../tags/0.7.74.2) (revision 1574)
+++ system-config-printer.py (.../branches/0.7.74.x) (revision 1574)
@@ -74,6 +74,12 @@
ready_cursor = gtk.gdk.Cursor(gtk.gdk.LEFT_PTR)
ellipsis = unichr(0x2026)

View File

@ -3,7 +3,7 @@
Summary: A printer administration tool
Name: system-config-printer
Version: 0.7.74.2
Release: 2%{?dist}
Release: 3%{?dist}
License: GPLv2+
URL: http://cyberelk.net/tim/software/system-config-printer/
Group: System Environment/Base
@ -130,6 +130,10 @@ if [ "$1" = "0" ]; then
fi
%changelog
* Tue Sep 25 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-3
- Pull in SVN patch from stable branch for foomatic recommended
drivers (bug #292021).
* Fri Sep 21 2007 Tim Waugh <twaugh@redhat.com> 0.7.74.2-2
- Pull in SVN patch from stable branch for 'Allow printing from
the Internet' check-box (bug #221003).