Use _smp_mflags for consistency's sake (patch from upstream needed).
This commit is contained in:
parent
6a55f6117e
commit
2235cbbc47
48
system-config-printer-smp-mflags.patch
Normal file
48
system-config-printer-smp-mflags.patch
Normal file
@ -0,0 +1,48 @@
|
|||||||
|
diff -up system-config-printer-1.4.3/Makefile.am.smp-mflags system-config-printer-1.4.3/Makefile.am
|
||||||
|
--- system-config-printer-1.4.3/Makefile.am.smp-mflags 2013-10-22 16:33:25.000000000 +0100
|
||||||
|
+++ system-config-printer-1.4.3/Makefile.am 2013-12-06 11:33:40.227525218 +0000
|
||||||
|
@@ -82,6 +82,7 @@ clean-local:
|
||||||
|
done; \
|
||||||
|
fi
|
||||||
|
rm -f .stamp-distutils-in-builddir
|
||||||
|
+ rm -f .stamp-man-pages-built
|
||||||
|
|
||||||
|
nobase_pkgdata_SCRIPTS= \
|
||||||
|
check-device-ids.py \
|
||||||
|
@@ -281,8 +282,11 @@ EXTRA_DIST=\
|
||||||
|
@INTLTOOL_DESKTOP_RULE@
|
||||||
|
|
||||||
|
# The man pages are generated from DocBook XML.
|
||||||
|
-$(man_MANS): $(top_srcdir)/man/system-config-printer.xml
|
||||||
|
+.stamp-man-pages-built: $(top_srcdir)/man/system-config-printer.xml
|
||||||
|
xmlto man -o man $<
|
||||||
|
+ touch .stamp-man-pages-built
|
||||||
|
+
|
||||||
|
+$(man_MANS): .stamp-man-pages-built
|
||||||
|
|
||||||
|
html: $(EXPORT_MODULES) $(EXPORT_MODULES_GEN)
|
||||||
|
rm -rf html
|
||||||
|
diff -up system-config-printer-1.4.3/Makefile.in.smp-mflags system-config-printer-1.4.3/Makefile.in
|
||||||
|
--- system-config-printer-1.4.3/Makefile.in.smp-mflags 2013-10-22 16:44:44.000000000 +0100
|
||||||
|
+++ system-config-printer-1.4.3/Makefile.in 2013-12-06 11:33:43.648541700 +0000
|
||||||
|
@@ -1922,6 +1922,7 @@ clean-local:
|
||||||
|
done; \
|
||||||
|
fi
|
||||||
|
rm -f .stamp-distutils-in-builddir
|
||||||
|
+ rm -f .stamp-man-pages-built
|
||||||
|
|
||||||
|
@HAVE_SYSTEMD_TRUE@@UDEV_RULES_TRUE@%.service: %.service.in
|
||||||
|
@HAVE_SYSTEMD_TRUE@@UDEV_RULES_TRUE@ $(AM_V_GEN)sed -e 's,@udevhelperdir\@,$(udevhelperdir),g' $< > $@
|
||||||
|
@@ -1951,8 +1952,11 @@ uninstall-desktopDATA:
|
||||||
|
@INTLTOOL_DESKTOP_RULE@
|
||||||
|
|
||||||
|
# The man pages are generated from DocBook XML.
|
||||||
|
-$(man_MANS): $(top_srcdir)/man/system-config-printer.xml
|
||||||
|
+.stamp-man-pages-built: $(top_srcdir)/man/system-config-printer.xml
|
||||||
|
xmlto man -o man $<
|
||||||
|
+ touch .stamp-man-pages-built
|
||||||
|
+
|
||||||
|
+$(man_MANS): .stamp-man-pages-built
|
||||||
|
|
||||||
|
html: $(EXPORT_MODULES) $(EXPORT_MODULES_GEN)
|
||||||
|
rm -rf html
|
@ -8,6 +8,7 @@ Group: System Environment/Base
|
|||||||
Source0: http://cyberelk.net/tim/data/system-config-printer/1.4/%{name}-%{version}.tar.xz
|
Source0: http://cyberelk.net/tim/data/system-config-printer/1.4/%{name}-%{version}.tar.xz
|
||||||
Patch1: system-config-printer-no-applet-in-gnome.patch
|
Patch1: system-config-printer-no-applet-in-gnome.patch
|
||||||
Patch2: system-config-printer-decorator.patch
|
Patch2: system-config-printer-decorator.patch
|
||||||
|
Patch3: system-config-printer-smp-mflags.patch
|
||||||
|
|
||||||
BuildRequires: cups-devel >= 1.2
|
BuildRequires: cups-devel >= 1.2
|
||||||
BuildRequires: desktop-file-utils >= 0.2.92
|
BuildRequires: desktop-file-utils >= 0.2.92
|
||||||
@ -73,6 +74,9 @@ printers.
|
|||||||
# Fixed typo in D-Bus signature decorator (bug #1023449).
|
# Fixed typo in D-Bus signature decorator (bug #1023449).
|
||||||
%patch2 -p1 -b .decorator
|
%patch2 -p1 -b .decorator
|
||||||
|
|
||||||
|
# Fixed makefile to work with _smp_mflags (patch from upstream).
|
||||||
|
%patch3 -p1 -b .smp-mflags
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure --with-udev-rules
|
%configure --with-udev-rules
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
@ -174,7 +178,7 @@ exit 0
|
|||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
* Fri Dec 6 2013 Tim Waugh <twaugh@redhat.com> 1.4.3-6
|
* Fri Dec 6 2013 Tim Waugh <twaugh@redhat.com> 1.4.3-6
|
||||||
- Use _smp_mflags for consistency's sake.
|
- Use _smp_mflags for consistency's sake (patch from upstream needed).
|
||||||
|
|
||||||
* Thu Dec 5 2013 Tim Waugh <twaugh@redhat.com> 1.4.3-5
|
* Thu Dec 5 2013 Tim Waugh <twaugh@redhat.com> 1.4.3-5
|
||||||
- Actually run make in the %%build section.
|
- Actually run make in the %%build section.
|
||||||
|
Loading…
Reference in New Issue
Block a user