Update to 3.37.90
This commit is contained in:
parent
8ca4c4f971
commit
fdb3871eda
29
24.patch
29
24.patch
@ -1,29 +0,0 @@
|
|||||||
From 5dea152c7728f5a37370ad8a229115833e36b4f6 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Rasmus Thomsen <oss@cogitri.dev>
|
|
||||||
Date: Sat, 7 Mar 2020 10:44:16 +0100
|
|
||||||
Subject: [PATCH] tests: use G_GSIZE_FORMAT instead of G_GUINT64_FORMAT for
|
|
||||||
gsize
|
|
||||||
|
|
||||||
This fixes the build on 32-bit platforms with -Werror-format
|
|
||||||
|
|
||||||
fixes #32
|
|
||||||
---
|
|
||||||
src/tests/allocs-by-size.c | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/tests/allocs-by-size.c b/src/tests/allocs-by-size.c
|
|
||||||
index 666113a..6260d4b 100644
|
|
||||||
--- a/src/tests/allocs-by-size.c
|
|
||||||
+++ b/src/tests/allocs-by-size.c
|
|
||||||
@@ -109,7 +109,7 @@ allocs_by_size (SysprofCaptureReader *reader)
|
|
||||||
{
|
|
||||||
const Item *item = &g_array_index (ar, Item, i);
|
|
||||||
|
|
||||||
- g_print ("%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT",%"G_GUINT64_FORMAT"\n",
|
|
||||||
+ g_print ("%"G_GSIZE_FORMAT",%"G_GSIZE_FORMAT",%"G_GSIZE_FORMAT"\n",
|
|
||||||
item->size, item->cmp, item->count);
|
|
||||||
}
|
|
||||||
}
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (sysprof-3.36.0.tar.xz) = 41f99cc3446a6624ea74fcdecd7a29a2e5e2d4086383d59a9064c4a3df5d9b8d08f4903ff4dcc85ffa9c6d42bd84dec5c03f6010fffd4415cc8fecf4dc0b23f4
|
SHA512 (sysprof-3.37.90.tar.xz) = 0ee3dcba15a584a220719b335e325da5eb307f31154fae444e5010a502a33f957e2cfb732bb3c5aa90a4fba28a2bb6c8c566ed66e848c86e8690112afac4603d
|
||||||
|
29
sysprof.spec
29
sysprof.spec
@ -1,16 +1,13 @@
|
|||||||
%global glib2_version 2.61.3
|
%global glib2_version 2.61.3
|
||||||
|
|
||||||
Name: sysprof
|
Name: sysprof
|
||||||
Version: 3.36.0
|
Version: 3.37.90
|
||||||
Release: 2%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A system-wide Linux profiler
|
Summary: A system-wide Linux profiler
|
||||||
|
|
||||||
License: GPLv3+
|
License: GPLv3+
|
||||||
URL: http://www.sysprof.com
|
URL: http://www.sysprof.com
|
||||||
Source0: https://download.gnome.org/sources/sysprof/3.36/sysprof-%{version}.tar.xz
|
Source0: https://download.gnome.org/sources/sysprof/3.37/sysprof-%{version}.tar.xz
|
||||||
# Fix the build on 32 bit hosts
|
|
||||||
# https://gitlab.gnome.org/GNOME/sysprof/-/merge_requests/24
|
|
||||||
Patch0: 24.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
BuildRequires: gcc-c++
|
BuildRequires: gcc-c++
|
||||||
@ -97,8 +94,9 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
|||||||
%files cli -f %{name}.lang
|
%files cli -f %{name}.lang
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%{_bindir}/sysprof-cli
|
%{_bindir}/sysprof-cli
|
||||||
%{_libdir}/libsysprof-3.so
|
%{_libdir}/libsysprof-4.so
|
||||||
%{_libdir}/libsysprof-memory-3.so
|
%{_libdir}/libsysprof-memory-4.so
|
||||||
|
%{_libdir}/libsysprof-speedtrack-4.so
|
||||||
%{_libexecdir}/sysprofd
|
%{_libexecdir}/sysprofd
|
||||||
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof2.xml
|
||||||
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
|
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
|
||||||
@ -113,17 +111,20 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
|||||||
|
|
||||||
%files -n libsysprof-ui
|
%files -n libsysprof-ui
|
||||||
%license COPYING
|
%license COPYING
|
||||||
%{_libdir}/libsysprof-ui-3.so
|
%{_libdir}/libsysprof-ui-4.so
|
||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/sysprof-3/
|
%{_includedir}/sysprof-4/
|
||||||
%{_libdir}/pkgconfig/sysprof-3.pc
|
%{_libdir}/pkgconfig/sysprof-4.pc
|
||||||
%{_libdir}/pkgconfig/sysprof-capture-3.pc
|
%{_libdir}/pkgconfig/sysprof-capture-4.pc
|
||||||
%{_libdir}/pkgconfig/sysprof-ui-3.pc
|
%{_libdir}/pkgconfig/sysprof-ui-4.pc
|
||||||
%{_libdir}/libsysprof-capture-3.a
|
%{_libdir}/libsysprof-capture-4.a
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 17 2020 Kalev Lember <klember@redhat.com> - 3.37.90-1
|
||||||
|
- Update to 3.37.90
|
||||||
|
|
||||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.36.0-2
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 3.36.0-2
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user