Update to 3.33.3
This commit is contained in:
parent
899d28324c
commit
f584a2ac11
42
0001-build-fix-some-32-bit-build-issues.patch
Normal file
42
0001-build-fix-some-32-bit-build-issues.patch
Normal file
@ -0,0 +1,42 @@
|
||||
From ce7b11695f906aeeb1e4f88a9b6ed9161ffc0af9 Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hergert <chergert@redhat.com>
|
||||
Date: Tue, 2 Jul 2019 17:00:44 -0700
|
||||
Subject: [PATCH] build: fix some 32-bit build issues
|
||||
|
||||
---
|
||||
src/helpers.c | 2 +-
|
||||
src/libsysprof/sysprof-symbol-map.c | 4 ++--
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/src/helpers.c b/src/helpers.c
|
||||
index 3673df3..828f88f 100644
|
||||
--- a/src/helpers.c
|
||||
+++ b/src/helpers.c
|
||||
@@ -110,7 +110,7 @@ helpers_perf_event_open (GVariant *options,
|
||||
gint32 pid,
|
||||
gint32 cpu,
|
||||
gint group_fd,
|
||||
- gulong flags,
|
||||
+ guint64 flags,
|
||||
gint *out_fd)
|
||||
{
|
||||
#ifndef __linux__
|
||||
diff --git a/src/libsysprof/sysprof-symbol-map.c b/src/libsysprof/sysprof-symbol-map.c
|
||||
index d0b0ebc..4367cd9 100644
|
||||
--- a/src/libsysprof/sysprof-symbol-map.c
|
||||
+++ b/src/libsysprof/sysprof-symbol-map.c
|
||||
@@ -342,9 +342,9 @@ sysprof_symbol_map_printf (SysprofSymbolMap *self)
|
||||
Element *ele = g_ptr_array_index (self->samples, i);
|
||||
|
||||
if (ele->tag)
|
||||
- g_print ("%-5d: %p: %s [%s]\n", ele->pid, (gpointer)ele->addr, ele->name, g_quark_to_string (ele->tag));
|
||||
+ g_print ("%-5d: %"G_GUINT64_FORMAT": %s [%s]\n", ele->pid, ele->addr, ele->name, g_quark_to_string (ele->tag));
|
||||
else
|
||||
- g_print ("%-5d: %p: %s\n", ele->pid, (gpointer)ele->addr, ele->name);
|
||||
+ g_print ("%-5d: %"G_GUINT64_FORMAT": %s\n", ele->pid, ele->addr, ele->name);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
368
0001-cleanup-remove-duplicated-NSEC_PER_SEC-macros.patch
Normal file
368
0001-cleanup-remove-duplicated-NSEC_PER_SEC-macros.patch
Normal file
@ -0,0 +1,368 @@
|
||||
From c2728b8adaddc4a05889f25175d0bb627f12b44a Mon Sep 17 00:00:00 2001
|
||||
From: Christian Hergert <chergert@redhat.com>
|
||||
Date: Thu, 18 Jul 2019 10:22:46 -0700
|
||||
Subject: [PATCH] cleanup: remove duplicated NSEC_PER_SEC macros
|
||||
|
||||
This switches everything to using a single 64-bit constant for NSEC_PER_SEC
|
||||
that ensure we're doing 64-bit math everywhere.
|
||||
---
|
||||
src/libsysprof-capture/sysprof-clock.h | 4 +-
|
||||
.../sysprof-cell-renderer-duration.c | 2 -
|
||||
src/libsysprof-ui/sysprof-details-page.c | 4 +-
|
||||
src/libsysprof-ui/sysprof-log-model.c | 8 ++--
|
||||
src/libsysprof-ui/sysprof-marks-page.c | 6 +--
|
||||
src/libsysprof-ui/sysprof-time-label.c | 2 -
|
||||
src/libsysprof-ui/sysprof-visualizer-ticks.c | 39 +++++++++----------
|
||||
src/libsysprof-ui/sysprof-zoom-manager.c | 12 +++---
|
||||
src/tools/sysprof-dump.c | 18 ++++-----
|
||||
9 files changed, 42 insertions(+), 53 deletions(-)
|
||||
|
||||
diff --git a/src/libsysprof-capture/sysprof-clock.h b/src/libsysprof-capture/sysprof-clock.h
|
||||
index c4c8af2..ac101a3 100644
|
||||
--- a/src/libsysprof-capture/sysprof-clock.h
|
||||
+++ b/src/libsysprof-capture/sysprof-clock.h
|
||||
@@ -67,6 +67,8 @@ typedef gint SysprofClock;
|
||||
typedef gint64 SysprofTimeStamp;
|
||||
typedef gint32 SysprofTimeSysprofan;
|
||||
|
||||
+#define SYSPROF_NSEC_PER_SEC G_GINT64_CONSTANT(1000000000)
|
||||
+
|
||||
SYSPROF_AVAILABLE_IN_ALL
|
||||
SysprofClock sysprof_clock;
|
||||
|
||||
@@ -80,7 +82,7 @@ sysprof_clock_get_current_time (void)
|
||||
clock = CLOCK_MONOTONIC;
|
||||
clock_gettime (clock, &ts);
|
||||
|
||||
- return (ts.tv_sec * G_GINT64_CONSTANT (1000000000)) + ts.tv_nsec;
|
||||
+ return (ts.tv_sec * SYSPROF_NSEC_PER_SEC) + ts.tv_nsec;
|
||||
}
|
||||
|
||||
static inline SysprofTimeSysprofan
|
||||
diff --git a/src/libsysprof-ui/sysprof-cell-renderer-duration.c b/src/libsysprof-ui/sysprof-cell-renderer-duration.c
|
||||
index 462b83e..d1cebda 100644
|
||||
--- a/src/libsysprof-ui/sysprof-cell-renderer-duration.c
|
||||
+++ b/src/libsysprof-ui/sysprof-cell-renderer-duration.c
|
||||
@@ -26,8 +26,6 @@
|
||||
#include "sysprof-ui-private.h"
|
||||
#include "sysprof-zoom-manager.h"
|
||||
|
||||
-#define NSEC_PER_SEC (G_USEC_PER_SEC * 1000L)
|
||||
-
|
||||
typedef struct
|
||||
{
|
||||
gint64 capture_begin_time;
|
||||
diff --git a/src/libsysprof-ui/sysprof-details-page.c b/src/libsysprof-ui/sysprof-details-page.c
|
||||
index 13170f4..03963c5 100644
|
||||
--- a/src/libsysprof-ui/sysprof-details-page.c
|
||||
+++ b/src/libsysprof-ui/sysprof-details-page.c
|
||||
@@ -33,8 +33,6 @@
|
||||
#include "sysprof-details-page.h"
|
||||
#include "sysprof-ui-private.h"
|
||||
|
||||
-#define NSEC_PER_SEC (G_USEC_PER_SEC * 1000L)
|
||||
-
|
||||
struct _SysprofDetailsPage
|
||||
{
|
||||
SysprofPage parent_instance;
|
||||
@@ -231,7 +229,7 @@ sysprof_details_page_set_reader (SysprofDetailsPage *self,
|
||||
|
||||
duration = sysprof_capture_reader_get_end_time (reader) -
|
||||
sysprof_capture_reader_get_start_time (reader);
|
||||
- duration_str = g_strdup_printf (_("%0.4lf seconds"), duration / (gdouble)NSEC_PER_SEC);
|
||||
+ duration_str = g_strdup_printf (_("%0.4lf seconds"), duration / (gdouble)SYSPROF_NSEC_PER_SEC);
|
||||
gtk_label_set_label (self->duration, duration_str);
|
||||
|
||||
if (sysprof_capture_reader_get_stat (reader, &st_buf))
|
||||
diff --git a/src/libsysprof-ui/sysprof-log-model.c b/src/libsysprof-ui/sysprof-log-model.c
|
||||
index d5abfed..c7b3183 100644
|
||||
--- a/src/libsysprof-ui/sysprof-log-model.c
|
||||
+++ b/src/libsysprof-ui/sysprof-log-model.c
|
||||
@@ -28,8 +28,6 @@
|
||||
|
||||
#include "sysprof-log-model.h"
|
||||
|
||||
-#define NSEC_PER_SEC (G_USEC_PER_SEC * 1000L)
|
||||
-
|
||||
struct _SysprofLogModel
|
||||
{
|
||||
GObject parent_instance;
|
||||
@@ -189,9 +187,9 @@ sysprof_log_model_get_value (GtkTreeModel *model,
|
||||
case SYSPROF_LOG_MODEL_COLUMN_TIME_STRING:
|
||||
{
|
||||
gint64 offset = item->time - self->begin_time;
|
||||
- gint min = offset / (NSEC_PER_SEC * 60L);
|
||||
- gint seconds = (offset - (min * NSEC_PER_SEC)) / NSEC_PER_SEC;
|
||||
- gint msec = (offset % NSEC_PER_SEC) / (NSEC_PER_SEC / 1000L);
|
||||
+ gint min = offset / SYSPROF_NSEC_PER_SEC / 60L;
|
||||
+ gint seconds = (offset - (min * SYSPROF_NSEC_PER_SEC)) / SYSPROF_NSEC_PER_SEC;
|
||||
+ gint msec = (offset % SYSPROF_NSEC_PER_SEC) / (SYSPROF_NSEC_PER_SEC / 1000L);
|
||||
|
||||
g_value_init (value, G_TYPE_STRING);
|
||||
g_value_take_string (value,
|
||||
diff --git a/src/libsysprof-ui/sysprof-marks-page.c b/src/libsysprof-ui/sysprof-marks-page.c
|
||||
index a0e0ae5..5ceff30 100644
|
||||
--- a/src/libsysprof-ui/sysprof-marks-page.c
|
||||
+++ b/src/libsysprof-ui/sysprof-marks-page.c
|
||||
@@ -28,8 +28,6 @@
|
||||
#include "sysprof-ui-private.h"
|
||||
#include "sysprof-zoom-manager.h"
|
||||
|
||||
-#define NSEC_PER_SEC (G_USEC_PER_SEC * 1000L)
|
||||
-
|
||||
typedef struct
|
||||
{
|
||||
SysprofMarksModelKind kind;
|
||||
@@ -245,9 +243,9 @@ sysprof_marks_page_tree_view_query_tooltip_cb (SysprofMarksPage *self,
|
||||
durationstr = _sysprof_format_duration (duration);
|
||||
|
||||
if (duration != 0)
|
||||
- timestr = g_strdup_printf ("%0.4lf (%s)", begin_time / (gdouble)NSEC_PER_SEC, durationstr);
|
||||
+ timestr = g_strdup_printf ("%0.4lf (%s)", begin_time / (gdouble)SYSPROF_NSEC_PER_SEC, durationstr);
|
||||
else
|
||||
- timestr = g_strdup_printf ("%0.4lf", begin_time / (gdouble)NSEC_PER_SEC);
|
||||
+ timestr = g_strdup_printf ("%0.4lf", begin_time / (gdouble)SYSPROF_NSEC_PER_SEC);
|
||||
|
||||
tooltip_text = g_strdup_printf ("%s: %s", timestr, text);
|
||||
|
||||
diff --git a/src/libsysprof-ui/sysprof-time-label.c b/src/libsysprof-ui/sysprof-time-label.c
|
||||
index eac8898..2ce58e7 100644
|
||||
--- a/src/libsysprof-ui/sysprof-time-label.c
|
||||
+++ b/src/libsysprof-ui/sysprof-time-label.c
|
||||
@@ -24,8 +24,6 @@
|
||||
|
||||
#include "sysprof-time-label.h"
|
||||
|
||||
-#define NSEC_PER_SEC (G_USEC_PER_SEC * 1000L)
|
||||
-
|
||||
struct _SysprofTimeLabel
|
||||
{
|
||||
GtkBox parent;
|
||||
diff --git a/src/libsysprof-ui/sysprof-visualizer-ticks.c b/src/libsysprof-ui/sysprof-visualizer-ticks.c
|
||||
index fc3a60a..af55c0c 100644
|
||||
--- a/src/libsysprof-ui/sysprof-visualizer-ticks.c
|
||||
+++ b/src/libsysprof-ui/sysprof-visualizer-ticks.c
|
||||
@@ -27,11 +27,10 @@
|
||||
|
||||
#include "sysprof-visualizer-ticks.h"
|
||||
|
||||
-#define NSEC_PER_SEC G_GINT64_CONSTANT(1000000000)
|
||||
-#define NSEC_PER_DAY (NSEC_PER_SEC * 60L * 60L * 24L)
|
||||
-#define NSEC_PER_HOUR (NSEC_PER_SEC * 60L * 60L)
|
||||
-#define NSEC_PER_MIN (NSEC_PER_SEC * 60L)
|
||||
-#define NSEC_PER_MSEC (NSEC_PER_SEC/G_GINT64_CONSTANT(1000))
|
||||
+#define NSEC_PER_DAY (SYSPROF_NSEC_PER_SEC * 60L * 60L * 24L)
|
||||
+#define NSEC_PER_HOUR (SYSPROF_NSEC_PER_SEC * 60L * 60L)
|
||||
+#define NSEC_PER_MIN (SYSPROF_NSEC_PER_SEC * 60L)
|
||||
+#define NSEC_PER_MSEC (SYSPROF_NSEC_PER_SEC/G_GINT64_CONSTANT(1000))
|
||||
#define MIN_TICK_DISTANCE 20
|
||||
#define LABEL_HEIGHT_PX 10
|
||||
|
||||
@@ -64,16 +63,16 @@ struct {
|
||||
gint height;
|
||||
gint64 span;
|
||||
} tick_sizing[N_TICKS] = {
|
||||
- { 1, 12, NSEC_PER_SEC * 60 },
|
||||
- { 1, 11, NSEC_PER_SEC * 30 },
|
||||
- { 1, 10, NSEC_PER_SEC * 5 },
|
||||
- { 1, 9, NSEC_PER_SEC },
|
||||
- { 1, 8, NSEC_PER_SEC / 2 },
|
||||
- { 1, 6, NSEC_PER_SEC / 4 },
|
||||
- { 1, 5, NSEC_PER_SEC / 10 },
|
||||
- { 1, 4, NSEC_PER_SEC / 100 },
|
||||
- { 1, 3, NSEC_PER_SEC / 1000 },
|
||||
- { 1, 1, NSEC_PER_SEC / 10000 },
|
||||
+ { 1, 12, SYSPROF_NSEC_PER_SEC * 60 },
|
||||
+ { 1, 11, SYSPROF_NSEC_PER_SEC * 30 },
|
||||
+ { 1, 10, SYSPROF_NSEC_PER_SEC * 5 },
|
||||
+ { 1, 9, SYSPROF_NSEC_PER_SEC },
|
||||
+ { 1, 8, SYSPROF_NSEC_PER_SEC / 2 },
|
||||
+ { 1, 6, SYSPROF_NSEC_PER_SEC / 4 },
|
||||
+ { 1, 5, SYSPROF_NSEC_PER_SEC / 10 },
|
||||
+ { 1, 4, SYSPROF_NSEC_PER_SEC / 100 },
|
||||
+ { 1, 3, SYSPROF_NSEC_PER_SEC / 1000 },
|
||||
+ { 1, 1, SYSPROF_NSEC_PER_SEC / 10000 },
|
||||
};
|
||||
|
||||
G_DEFINE_TYPE (SysprofVisualizerTicks, sysprof_visualizer_ticks, GTK_TYPE_DRAWING_AREA)
|
||||
@@ -93,7 +92,7 @@ update_label_text (PangoLayout *layout,
|
||||
|
||||
g_assert (PANGO_IS_LAYOUT (layout));
|
||||
|
||||
- tmp = time % NSEC_PER_SEC;
|
||||
+ tmp = time % SYSPROF_NSEC_PER_SEC;
|
||||
time -= tmp;
|
||||
msec = tmp / 100000L;
|
||||
|
||||
@@ -115,10 +114,10 @@ update_label_text (PangoLayout *layout,
|
||||
time %= NSEC_PER_MIN;
|
||||
}
|
||||
|
||||
- if (time >= NSEC_PER_SEC)
|
||||
+ if (time >= SYSPROF_NSEC_PER_SEC)
|
||||
{
|
||||
- sec = time / NSEC_PER_SEC;
|
||||
- time %= NSEC_PER_SEC;
|
||||
+ sec = time / SYSPROF_NSEC_PER_SEC;
|
||||
+ time %= SYSPROF_NSEC_PER_SEC;
|
||||
}
|
||||
|
||||
if (want_msec || (!hours && !min && !sec && msec))
|
||||
@@ -204,7 +203,7 @@ draw_ticks (SysprofVisualizerTicks *self,
|
||||
/* If we are operating on smaller than seconds here, then we want
|
||||
* to ensure we include msec with the timestamps.
|
||||
*/
|
||||
- want_msec = tick_sizing[ticks].span < NSEC_PER_SEC;
|
||||
+ want_msec = tick_sizing[ticks].span < SYSPROF_NSEC_PER_SEC;
|
||||
|
||||
for (gint64 t = self->begin_time - x_offset;
|
||||
t <= self->end_time;
|
||||
diff --git a/src/libsysprof-ui/sysprof-zoom-manager.c b/src/libsysprof-ui/sysprof-zoom-manager.c
|
||||
index 25df51f..b636b32 100644
|
||||
--- a/src/libsysprof-ui/sysprof-zoom-manager.c
|
||||
+++ b/src/libsysprof-ui/sysprof-zoom-manager.c
|
||||
@@ -25,11 +25,11 @@
|
||||
#include <glib/gi18n.h>
|
||||
#include <gio/gio.h>
|
||||
#include <math.h>
|
||||
+#include <sysprof-capture.h>
|
||||
|
||||
#include "sysprof-zoom-manager.h"
|
||||
|
||||
#define DEFAULT_PIXELS_PER_SEC (20.0)
|
||||
-#define NSEC_PER_SEC G_GINT64_CONSTANT(1000000000)
|
||||
|
||||
struct _SysprofZoomManager
|
||||
{
|
||||
@@ -584,7 +584,7 @@ sysprof_zoom_manager_get_duration_for_width (SysprofZoomManager *self,
|
||||
{
|
||||
g_return_val_if_fail (SYSPROF_IS_ZOOM_MANAGER (self), 0);
|
||||
|
||||
- return NSEC_PER_SEC * ((gdouble)width / (DEFAULT_PIXELS_PER_SEC * self->zoom));
|
||||
+ return SYSPROF_NSEC_PER_SEC * ((gdouble)width / (DEFAULT_PIXELS_PER_SEC * self->zoom));
|
||||
}
|
||||
|
||||
gint
|
||||
@@ -593,7 +593,7 @@ sysprof_zoom_manager_get_width_for_duration (SysprofZoomManager *self,
|
||||
{
|
||||
g_return_val_if_fail (SYSPROF_IS_ZOOM_MANAGER (self), 0);
|
||||
|
||||
- return (gdouble)duration / (gdouble)NSEC_PER_SEC * DEFAULT_PIXELS_PER_SEC * self->zoom;
|
||||
+ return (gdouble)duration / (gdouble)SYSPROF_NSEC_PER_SEC * DEFAULT_PIXELS_PER_SEC * self->zoom;
|
||||
}
|
||||
|
||||
gdouble
|
||||
@@ -605,7 +605,7 @@ sysprof_zoom_manager_fit_zoom_for_duration (SysprofZoomManager *self,
|
||||
g_return_val_if_fail (duration >= 0, 1.0);
|
||||
g_return_val_if_fail (width >= 0, 1.0);
|
||||
|
||||
- return (width / DEFAULT_PIXELS_PER_SEC) / (duration / (gdouble)NSEC_PER_SEC);
|
||||
+ return (width / DEFAULT_PIXELS_PER_SEC) / (duration / (gdouble)SYSPROF_NSEC_PER_SEC);
|
||||
}
|
||||
|
||||
gdouble
|
||||
@@ -633,14 +633,14 @@ _sysprof_format_duration (gint64 duration)
|
||||
|
||||
duration = ABS (duration);
|
||||
|
||||
- if (duration < NSEC_PER_SEC)
|
||||
+ if (duration < SYSPROF_NSEC_PER_SEC)
|
||||
return g_strdup_printf ("%s%.2lf msec",
|
||||
negative ? "-" : "",
|
||||
(duration / 1000000.0));
|
||||
else
|
||||
return g_strdup_printf ("%s%.4lf seconds",
|
||||
negative ? "-" : "",
|
||||
- (duration / (gdouble)NSEC_PER_SEC));
|
||||
+ (duration / (gdouble)SYSPROF_NSEC_PER_SEC));
|
||||
}
|
||||
|
||||
/**
|
||||
diff --git a/src/tools/sysprof-dump.c b/src/tools/sysprof-dump.c
|
||||
index 719e38c..f93a177 100644
|
||||
--- a/src/tools/sysprof-dump.c
|
||||
+++ b/src/tools/sysprof-dump.c
|
||||
@@ -24,8 +24,6 @@
|
||||
#include <stdlib.h>
|
||||
#include <sysprof-capture.h>
|
||||
|
||||
-#define NSEC_PER_SEC G_GINT64_CONSTANT(1000000000)
|
||||
-
|
||||
static gboolean list_files = FALSE;
|
||||
static const GOptionEntry main_entries[] = {
|
||||
{ "list-files", 'l', 0, G_OPTION_ARG_NONE, &list_files, "List files within the capture" },
|
||||
@@ -86,7 +84,7 @@ main (gint argc,
|
||||
end_time = sysprof_capture_reader_get_end_time (reader);
|
||||
|
||||
g_print ("Capture Time Range: %"G_GUINT64_FORMAT" to %"G_GUINT64_FORMAT" (%lf)\n",
|
||||
- begin_time, end_time, (end_time - begin_time) / (gdouble)NSEC_PER_SEC);
|
||||
+ begin_time, end_time, (end_time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC);
|
||||
|
||||
while (sysprof_capture_reader_peek_type (reader, &type))
|
||||
{
|
||||
@@ -138,7 +136,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_LOG:
|
||||
{
|
||||
const SysprofCaptureLog *log = sysprof_capture_reader_read_log (reader);
|
||||
- gdouble ptime = (log->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (log->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
|
||||
g_print ("LOG: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n"
|
||||
" severity = %d\n"
|
||||
@@ -169,7 +167,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_FILE_CHUNK:
|
||||
{
|
||||
const SysprofCaptureFileChunk *file_chunk = sysprof_capture_reader_read_file (reader);
|
||||
- gdouble ptime = (file_chunk->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (file_chunk->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
|
||||
g_print ("FILE_CHUNK: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n"
|
||||
" path = %s\n"
|
||||
@@ -184,7 +182,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_MARK:
|
||||
{
|
||||
const SysprofCaptureMark *mark = sysprof_capture_reader_read_mark (reader);
|
||||
- gdouble ptime = (mark->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (mark->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
|
||||
g_print ("MARK: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n"
|
||||
" group = %s\n"
|
||||
@@ -200,7 +198,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_METADATA:
|
||||
{
|
||||
const SysprofCaptureMetadata *metadata = sysprof_capture_reader_read_metadata (reader);
|
||||
- gdouble ptime = (metadata->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (metadata->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
|
||||
g_print ("METADATA: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n"
|
||||
" id = %s\n"
|
||||
@@ -226,7 +224,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_SAMPLE:
|
||||
{
|
||||
const SysprofCaptureSample *s = sysprof_capture_reader_read_sample (reader);
|
||||
- gdouble ptime = (s->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (s->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
guint i;
|
||||
|
||||
g_print ("SAMPLE: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n", s->frame.pid, s->frame.time, ptime);
|
||||
@@ -247,7 +245,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_CTRDEF:
|
||||
{
|
||||
const SysprofCaptureCounterDefine *def = sysprof_capture_reader_read_counter_define (reader);
|
||||
- gdouble ptime = (def->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (def->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
guint i;
|
||||
|
||||
g_print ("NEW COUNTERS: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n", def->frame.pid, def->frame.time, ptime);
|
||||
@@ -273,7 +271,7 @@ main (gint argc,
|
||||
case SYSPROF_CAPTURE_FRAME_CTRSET:
|
||||
{
|
||||
const SysprofCaptureCounterSet *set = sysprof_capture_reader_read_counter_set (reader);
|
||||
- gdouble ptime = (set->frame.time - begin_time) / (gdouble)NSEC_PER_SEC;
|
||||
+ gdouble ptime = (set->frame.time - begin_time) / (gdouble)SYSPROF_NSEC_PER_SEC;
|
||||
guint i;
|
||||
|
||||
g_print ("SET COUNTERS: pid=%d time=%"G_GINT64_FORMAT" (%lf)\n", set->frame.pid, set->frame.time, ptime);
|
||||
--
|
||||
2.21.0
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (sysprof-3.32.0.tar.xz) = 7b9d84ac241d376a5e545082b1224e7db96af26ae0ee297d5f0b2d45abc4676e23009dbd560085e5d4879378a8dd79eefb4449df3961fbfd09238bd2056061d0
|
||||
SHA512 (sysprof-3.33.3.tar.xz) = 84860583f2c995bde4b8315be25e819faa8cda7e45c30e8dd62f894dfb155e5df7028ddeb7a2debf32e211a8416a220da0ec77c8649bba2a8853394778d20946
|
||||
|
55
sysprof.spec
55
sysprof.spec
@ -1,23 +1,28 @@
|
||||
Name: sysprof
|
||||
Version: 3.32.0
|
||||
Version: 3.33.3
|
||||
Release: 1%{?dist}
|
||||
Summary: A system-wide Linux profiler
|
||||
|
||||
License: GPLv3+
|
||||
URL: http://www.sysprof.com
|
||||
Source0: https://download.gnome.org/sources/sysprof/3.32/sysprof-%{version}.tar.xz
|
||||
Source0: https://download.gnome.org/sources/sysprof/3.33/sysprof-%{version}.tar.xz
|
||||
|
||||
# Backported from upstream
|
||||
Patch0: 0001-build-fix-some-32-bit-build-issues.patch
|
||||
Patch1: 0001-cleanup-remove-duplicated-NSEC_PER_SEC-macros.patch
|
||||
|
||||
BuildRequires: meson
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: pkgconfig(gobject-2.0)
|
||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||
BuildRequires: pkgconfig(polkit-gobject-1)
|
||||
BuildRequires: pkgconfig(systemd)
|
||||
BuildRequires: pkgconfig(libsystemd) >= 222
|
||||
BuildRequires: pkgconfig(glib-2.0)
|
||||
BuildRequires: gettext
|
||||
BuildRequires: itstool
|
||||
BuildRequires: meson
|
||||
BuildRequires: pkgconfig(gio-unix-2.0)
|
||||
BuildRequires: pkgconfig(glib-2.0)
|
||||
BuildRequires: pkgconfig(gobject-2.0)
|
||||
BuildRequires: pkgconfig(libdazzle-1.0)
|
||||
BuildRequires: pkgconfig(libsystemd)
|
||||
BuildRequires: pkgconfig(polkit-gobject-1)
|
||||
BuildRequires: pkgconfig(systemd)
|
||||
BuildRequires: /usr/bin/appstream-util
|
||||
BuildRequires: /usr/bin/desktop-file-validate
|
||||
|
||||
@ -78,35 +83,43 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
|
||||
%license COPYING
|
||||
%doc NEWS README.md TODO AUTHORS
|
||||
%{_bindir}/sysprof
|
||||
%{_datadir}/metainfo/org.gnome.Sysprof2.appdata.xml
|
||||
%{_datadir}/applications/org.gnome.Sysprof2.desktop
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.sysprof2.gschema.xml
|
||||
%{_datadir}/applications/org.gnome.Sysprof3.desktop
|
||||
%{_datadir}/glib-2.0/schemas/org.gnome.sysprof3.gschema.xml
|
||||
%{_datadir}/icons/hicolor/*/*/*
|
||||
%{_datadir}/metainfo/org.gnome.Sysprof3.appdata.xml
|
||||
%{_datadir}/mime/packages/sysprof-mime.xml
|
||||
|
||||
%files cli -f %{name}.lang
|
||||
%license COPYING
|
||||
%{_bindir}/sysprof-cli
|
||||
%{_libdir}/libsysprof-2.so
|
||||
%{_libexecdir}/sysprof/sysprofd
|
||||
%{_libdir}/libsysprof-3.so
|
||||
%{_libexecdir}/sysprofd
|
||||
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Profiler.xml
|
||||
%{_datadir}/dbus-1/interfaces/org.gnome.Sysprof3.Service.xml
|
||||
%{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
|
||||
%{_datadir}/dbus-1/system.d/org.gnome.Sysprof3.conf
|
||||
%{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
|
||||
%{_datadir}/polkit-1/actions/org.gnome.sysprof2.policy
|
||||
%{_datadir}/dbus-1/system-services/org.gnome.Sysprof3.service
|
||||
%{_datadir}/polkit-1/actions/org.gnome.sysprof3.policy
|
||||
%{_unitdir}/sysprof2.service
|
||||
%{_unitdir}/sysprof3.service
|
||||
|
||||
%files -n libsysprof-ui
|
||||
%license COPYING
|
||||
%{_libdir}/libsysprof-ui-2.so
|
||||
%{_libdir}/libsysprof-ui-3.so
|
||||
|
||||
%files devel
|
||||
%{_includedir}/sysprof-2/
|
||||
%{_libdir}/pkgconfig/sysprof-2.pc
|
||||
%{_libdir}/pkgconfig/sysprof-capture-2.pc
|
||||
%{_libdir}/pkgconfig/sysprof-ui-2.pc
|
||||
%{_libdir}/libsysprof-capture-2.a
|
||||
%{_includedir}/sysprof-3/
|
||||
%{_libdir}/pkgconfig/sysprof-3.pc
|
||||
%{_libdir}/pkgconfig/sysprof-capture-3.pc
|
||||
%{_libdir}/pkgconfig/sysprof-ui-3.pc
|
||||
%{_libdir}/libsysprof-capture-3.a
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 19 2019 Kalev Lember <klember@redhat.com> - 3.33.3-1
|
||||
- Update to 3.33.3
|
||||
|
||||
* Wed Mar 13 2019 Kalev Lember <klember@redhat.com> - 3.32.0-1
|
||||
- Update to 3.32.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user