Update to 3.21.90
This commit is contained in:
parent
45112012aa
commit
8e11ba1e9e
1
.gitignore
vendored
1
.gitignore
vendored
@ -2,3 +2,4 @@ sysprof-1.1.6.tar.gz
|
||||
/sysprof-1.1.8.tar.gz
|
||||
/sysprof-1.2.0.tar.gz
|
||||
/sysprof-3.20.0.tar.xz
|
||||
/sysprof-3.21.90.tar.xz
|
||||
|
@ -1,28 +0,0 @@
|
||||
From 329743c917b07a4a17cb83f9f8c1811e8e8b23d6 Mon Sep 17 00:00:00 2001
|
||||
From: Jussi Kukkonen <jussi.kukkonen@intel.com>
|
||||
Date: Fri, 10 Jun 2016 14:01:54 +0300
|
||||
Subject: [PATCH] callgraph: Use U64_TO_POINTER
|
||||
|
||||
This fixes a "cast to pointer from integer of different size" on i586.
|
||||
|
||||
https://bugzilla.gnome.org/show_bug.cgi?id=767693
|
||||
---
|
||||
lib/sp-callgraph-view.c | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/lib/sp-callgraph-view.c b/lib/sp-callgraph-view.c
|
||||
index fc41230..b033e45 100644
|
||||
--- a/lib/sp-callgraph-view.c
|
||||
+++ b/lib/sp-callgraph-view.c
|
||||
@@ -135,7 +135,7 @@ build_functions_store (StackNode *node,
|
||||
|
||||
gtk_list_store_append (state->store, &iter);
|
||||
gtk_list_store_set (state->store, &iter,
|
||||
- COLUMN_NAME, (const gchar *)node->data,
|
||||
+ COLUMN_NAME, U64_TO_POINTER(node->data),
|
||||
COLUMN_SELF, 100.0 * size / state->profile_size,
|
||||
COLUMN_TOTAL, 100.0 * total / state->profile_size,
|
||||
COLUMN_POINTER, node,
|
||||
--
|
||||
2.7.4
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
d56e8492033b60e247634731e7f760b9 sysprof-3.20.0.tar.xz
|
||||
36a4dc586d7bff8a7f0643a7eb51b22f sysprof-3.21.90.tar.xz
|
||||
|
10
sysprof.spec
10
sysprof.spec
@ -1,13 +1,11 @@
|
||||
Name: sysprof
|
||||
Version: 3.20.0
|
||||
Version: 3.21.90
|
||||
Release: 1%{?dist}
|
||||
Summary: A system-wide Linux profiler
|
||||
|
||||
License: GPLv3+
|
||||
URL: http://www.sysprof.com
|
||||
Source0: https://download.gnome.org/sources/sysprof/3.20/sysprof-%{version}.tar.xz
|
||||
# Backported from upstream
|
||||
Patch0: 0001-callgraph-Use-U64_TO_POINTER.patch
|
||||
Source0: https://download.gnome.org/sources/sysprof/3.21/sysprof-%{version}.tar.xz
|
||||
|
||||
BuildRequires: binutils-devel
|
||||
BuildRequires: desktop-file-utils
|
||||
@ -38,7 +36,6 @@ developing applications that use %{name}.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
@ -95,6 +92,9 @@ gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Aug 23 2016 Kalev Lember <klember@redhat.com> - 3.21.90-1
|
||||
- Update to 3.21.90
|
||||
|
||||
* Mon Aug 08 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
|
||||
- Update to 3.20.0
|
||||
- Modernize spec file
|
||||
|
Loading…
Reference in New Issue
Block a user