Moving package to livna due to kmod requirement

This commit is contained in:
Gianluca Sforna 2008-04-08 22:48:48 +00:00
parent 78865468d7
commit 357c5b7512
7 changed files with 1 additions and 282 deletions

View File

@ -1,21 +0,0 @@
# Makefile for source rpm: sysprof
# $Id$
NAME := sysprof
SPECFILE = $(firstword $(wildcard *.spec))
define find-makefile-common
for d in common ../common ../../common ; do if [ -f $$d/Makefile.common ] ; then if [ -f $$d/CVS/Root -a -w $$/Makefile.common ] ; then cd $$d ; cvs -Q update ; fi ; echo "$$d/Makefile.common" ; break ; fi ; done
endef
MAKEFILE_COMMON := $(shell $(find-makefile-common))
ifeq ($(MAKEFILE_COMMON),)
# attept a checkout
define checkout-makefile-common
test -f CVS/Root && { cvs -Q -d $$(cat CVS/Root) checkout common && echo "common/Makefile.common" ; } || { echo "ERROR: I can't figure out how to checkout the 'common' module." ; exit -1 ; } >&2
endef
MAKEFILE_COMMON := $(shell $(checkout-makefile-common))
endif
include $(MAKEFILE_COMMON)

View File

@ -1,5 +0,0 @@
How to build the kernel module for sysprof
In order to build and install in the proper location the sysprof kernel
module, run as root:

1
dead.package Normal file
View File

@ -0,0 +1 @@
Package moved to livna due to kmod requirement

View File

@ -1 +0,0 @@
3fdbce685f75fac650c8a03e3bafff57 sysprof-1.0.9.tar.gz

View File

@ -1,96 +0,0 @@
Index: sysprof-1.0.9/sysprof.c
===================================================================
--- sysprof-1.0.9.orig/sysprof.c
+++ sysprof-1.0.9/sysprof.c
@@ -543,32 +543,67 @@ on_start_toggled (GtkWidget *widget, gpo
if (app->input_fd == -1)
{
- int fd;
- fd = open ("/proc/sysprof-trace", O_RDONLY);
- if (fd < 0)
- {
- load_module();
-
- fd = open ("/proc/sysprof-trace", O_RDONLY);
-
- if (fd < 0)
- {
- sorry (app->main_window,
- "Can't open /proc/sysprof-trace. You need to insert\n"
- "the sysprof kernel module. Run\n"
- "\n"
- " modprobe sysprof-module\n"
- "\n"
- "as root.");
-
- update_sensitivity (app);
- return;
- }
- }
+ // Check for kernel module existence
+ gchar * modules_path;
+ gchar * standard_output;
+ gchar * standard_error;
+ int exit_status = -1;
+ if (g_spawn_command_line_sync ("/bin/uname -r",
+ &standard_output, &standard_error,
+ &exit_status,
+ NULL))
+ {
+ g_strchomp( standard_output );
+ gchar * module_path;
+ module_path = g_strdup_printf( "/lib/modules/%s/extra/sysprof-module.ko", standard_output );
+
+ if ( ! g_file_test( module_path, G_FILE_TEST_EXISTS ))
+ {
+ sorry (app->main_window,
+ "Can not find sysprof kernel module in:\n\n"
+ " %s\n\n"
+ "Please see:\n"
+ "\n"
+ " %s/README.Fedora\n"
+ "\n"
+ "for more info about module installation.", module_path, PACKAGE_DOCDIR );
+ g_free( module_path );
+ update_sensitivity (app);
+ return;
+
+ }
+ g_free (standard_output);
+ g_free (standard_error);
+ g_free( module_path );
+ }
+
+ int fd;
+
+ fd = open ("/proc/sysprof-trace", O_RDONLY);
+ if (fd < 0)
+ {
+ load_module();
+
+ fd = open ("/proc/sysprof-trace", O_RDONLY);
+
+ if (fd < 0)
+ {
+ sorry (app->main_window,
+ "Can't open /proc/sysprof-trace. You need to insert\n"
+ "the sysprof kernel module. Run\n"
+ "\n"
+ " modprobe sysprof-module\n"
+ "\n"
+ "as root.");
+
+ update_sensitivity (app);
+ return;
+ }
+ }
- app->input_fd = fd;
- fd_add_watch (app->input_fd, app);
+ app->input_fd = fd;
+ fd_add_watch (app->input_fd, app);
}
fd_set_read_callback (app->input_fd, on_read);

View File

@ -1,11 +0,0 @@
[Desktop Entry]
Version=0.9.4
Encoding=UTF-8
Name=Sysprof
Comment=a sampling CPU profiler
Exec=sysprof
Icon=sysprof-icon.png
StartupNotify=true
Terminal=false
Type=Application
Categories=Development;Profiling;

View File

@ -1,148 +0,0 @@
Name: sysprof
Version: 1.0.9
Release: 4%{?dist}
Summary: Sysprof is a sampling CPU profiler
Group: Development/System
License: GPLv2+
URL: http://www.daimi.au.dk/~sandmann/sysprof/
Source0: http://www.daimi.au.dk/~sandmann/sysprof/sysprof-%{version}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
Source1: sysprof.desktop
Source2: README.Fedora
Patch0: sysprof-1.0.9-warn-for-missing-module.patch
BuildRequires: gtk2-devel => 2.6
BuildRequires: libglade2-devel
BuildRequires: binutils-devel
BuildRequires: desktop-file-utils
Requires: sysprof-module = %{version}
ExclusiveArch: %{ix86} x86_64
%description
Sysprof is a sampling CPU profiler for Linux that uses a kernel module
to profile the entire system, not just a single application.
Sysprof handles shared libraries and applications do not need to be
recompiled. In fact they don't even have to be restarted.
%package module
Summary: Source code for the required kernel module
Group: Development/System
Requires: kernel-devel
Requires: %{name} = %{version}
# Replace old kmods - to be removed in Fedora 11
Obsoletes: kmod-sysprof <= 1.0.9-3
%description module
Sysprof needs a kernel module to be inserted before profiling could start.
This package provides the necessary source files for building sysprof-module
The full build/install procedure is described in:
%{_docdir}/%{name}-%{version}/README.Fedora
%prep
%setup -q
%patch0 -p1
# Finish up README file
cp %{SOURCE2} ./README.Fedora
echo "cd %{_docdir}/sysprof-module-%{version}/module" >> README.Fedora
echo "make modules install" >> README.Fedora
%build
%configure --disable-kernel-module
# Add info about README.Fedora
echo "#define PACKAGE_DOCDIR \"%{_docdir}/sysprof-module-%{version}\"" >> config.h
make %{?_smp_mflags}
%install
rm -rf ${RPM_BUILD_ROOT}
make install DESTDIR=${RPM_BUILD_ROOT}
desktop-file-install --vendor fedora \
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
%{SOURCE1}
%clean
rm -rf ${RPM_BUILD_ROOT}
%files
%defattr(-,root,root,-)
%doc README COPYING ChangeLog
%{_bindir}/sysprof
%{_datadir}/pixmaps/sysprof-icon.png
%dir %{_datadir}/sysprof
%{_datadir}/sysprof/sysprof-icon.png
%{_datadir}/sysprof/sysprof.glade
%{_datadir}/applications/*.desktop
%files module
%defattr(-,root,root,-)
%doc README.Fedora config.h module/
%changelog
* Mon Feb 18 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 1.0.9-4
- Autorebuild for GCC 4.3
* Thu Dec 27 2007 Gianluca Sforna <giallu gmail com> - 1.0.9-3
- add subpackage with kernel module sources
- obsolete kmod-sysprof
- add patch for warning user about missing module
- add README.Fedora file with module build procedure
* Fri Dec 07 2007 Release Engineering <rel-eng at fedoraproject dot org> - 1.0.9-2
- Rebuild for deps
* Sat Dec 1 2007 Gianluca Sforna <giallu gmail com> - 1.0.9-1
- version update to 1.0.9
- drop kernel module
- do not add category X-Fedora to desktop file
* Tue Aug 28 2007 Gianluca Sforna <giallu gmail com> 1.0.8-2
- update License field
* Thu Dec 21 2006 Gianluca Sforna <giallu gmail com> 1.0.8-1
- version update to 1.0.8
* Tue Nov 21 2006 Gianluca Sforna <giallu gmail com> 1.0.7-1
- version update to 1.0.7
* Wed Nov 1 2006 Gianluca Sforna <giallu gmail com> 1.0.5-1
- version update
* Sun Oct 8 2006 Gianluca Sforna <giallu gmail com> 1.0.3-6
- better to use ExclusiveArch %{ix86} (thanks Ville)
* Thu Oct 5 2006 Gianluca Sforna <giallu gmail com> 1.0.3-5
- add ExclusiveArch to match sysprof-kmod supported archs
* Tue Oct 2 2006 Gianluca Sforna <giallu gmail com> 1.0.3-4
- add .desktop file
* Fri Sep 30 2006 Gianluca Sforna <giallu gmail com> 1.0.3-3
- versioned Provides
- add BR: binutils-devel
* Fri Sep 29 2006 Gianluca Sforna <giallu gmail com> 1.0.3-2
- own sysprof directory
* Thu Jun 22 2006 Gianluca Sforna <giallu gmail com> 1.0.3-1
- version update
- use standard %%configure macro
* Sun May 14 2006 Gianluca Sforna <giallu gmail com> 1.0.2-1
- Initial Version