Update to 3.20.0
This commit is contained in:
parent
d579823caa
commit
08d29d31ad
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
|||||||
sysprof-1.1.6.tar.gz
|
sysprof-1.1.6.tar.gz
|
||||||
/sysprof-1.1.8.tar.gz
|
/sysprof-1.1.8.tar.gz
|
||||||
/sysprof-1.2.0.tar.gz
|
/sysprof-1.2.0.tar.gz
|
||||||
|
/sysprof-3.20.0.tar.xz
|
||||||
|
28
0001-callgraph-Use-U64_TO_POINTER.patch
Normal file
28
0001-callgraph-Use-U64_TO_POINTER.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 329743c917b07a4a17cb83f9f8c1811e8e8b23d6 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jussi Kukkonen <jussi.kukkonen@intel.com>
|
||||||
|
Date: Fri, 10 Jun 2016 14:01:54 +0300
|
||||||
|
Subject: [PATCH] callgraph: Use U64_TO_POINTER
|
||||||
|
|
||||||
|
This fixes a "cast to pointer from integer of different size" on i586.
|
||||||
|
|
||||||
|
https://bugzilla.gnome.org/show_bug.cgi?id=767693
|
||||||
|
---
|
||||||
|
lib/sp-callgraph-view.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/lib/sp-callgraph-view.c b/lib/sp-callgraph-view.c
|
||||||
|
index fc41230..b033e45 100644
|
||||||
|
--- a/lib/sp-callgraph-view.c
|
||||||
|
+++ b/lib/sp-callgraph-view.c
|
||||||
|
@@ -135,7 +135,7 @@ build_functions_store (StackNode *node,
|
||||||
|
|
||||||
|
gtk_list_store_append (state->store, &iter);
|
||||||
|
gtk_list_store_set (state->store, &iter,
|
||||||
|
- COLUMN_NAME, (const gchar *)node->data,
|
||||||
|
+ COLUMN_NAME, U64_TO_POINTER(node->data),
|
||||||
|
COLUMN_SELF, 100.0 * size / state->profile_size,
|
||||||
|
COLUMN_TOTAL, 100.0 * total / state->profile_size,
|
||||||
|
COLUMN_POINTER, node,
|
||||||
|
--
|
||||||
|
2.7.4
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
a81808d847732f8dafb59d26ec2eebbf sysprof-1.2.0.tar.gz
|
d56e8492033b60e247634731e7f760b9 sysprof-3.20.0.tar.xz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/Makefile.am b/Makefile.am
|
|
||||||
index e294949..8e14ff9 100644
|
|
||||||
--- a/Makefile.am
|
|
||||||
+++ b/Makefile.am
|
|
||||||
@@ -60,7 +60,7 @@ sysprof_LDADD = $(GUI_DEP_LIBS)
|
|
||||||
|
|
||||||
endif
|
|
||||||
|
|
||||||
-udevdir = $(sysconfdir)/udev/rules.d
|
|
||||||
+udevdir = /usr/lib/udev/rules.d
|
|
||||||
dist_udev_DATA = 60-sysprof.rules
|
|
||||||
|
|
||||||
pixmapsdir = $(datadir)/pixmaps
|
|
@ -1,9 +0,0 @@
|
|||||||
[Desktop Entry]
|
|
||||||
Name=Sysprof
|
|
||||||
Comment=a sampling CPU profiler
|
|
||||||
Exec=sysprof
|
|
||||||
Icon=sysprof-icon
|
|
||||||
StartupNotify=true
|
|
||||||
Terminal=false
|
|
||||||
Type=Application
|
|
||||||
Categories=Development;Profiling;
|
|
74
sysprof.spec
74
sysprof.spec
@ -1,60 +1,57 @@
|
|||||||
Name: sysprof
|
Name: sysprof
|
||||||
Version: 1.2.0
|
Version: 3.20.0
|
||||||
Release: 8%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: A system-wide Linux profiler
|
Summary: A system-wide Linux profiler
|
||||||
Group: Development/System
|
Group: Development/System
|
||||||
License: GPLv2+
|
License: GPLv3+
|
||||||
URL: http://www.sysprof.com
|
URL: http://www.sysprof.com
|
||||||
Source0: http://www.sysprof.com/sysprof-%{version}.tar.gz
|
Source0: https://download.gnome.org/sources/sysprof/3.20/sysprof-%{version}.tar.xz
|
||||||
|
# Backported from upstream
|
||||||
|
Patch0: 0001-callgraph-Use-U64_TO_POINTER.patch
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
Source1: sysprof.desktop
|
|
||||||
|
|
||||||
BuildRequires: gtk2-devel => 2.6
|
|
||||||
BuildRequires: libglade2-devel
|
|
||||||
BuildRequires: binutils-devel
|
BuildRequires: binutils-devel
|
||||||
BuildRequires: desktop-file-utils
|
BuildRequires: desktop-file-utils
|
||||||
BuildRequires: automake
|
BuildRequires: gettext
|
||||||
|
BuildRequires: gtk3-devel
|
||||||
|
BuildRequires: itstool
|
||||||
|
BuildRequires: polkit-devel
|
||||||
|
BuildRequires: systemd-devel
|
||||||
|
|
||||||
|
|
||||||
Requires: kernel => 2.6.31
|
|
||||||
Requires: hicolor-icon-theme
|
Requires: hicolor-icon-theme
|
||||||
|
|
||||||
ExclusiveArch: %{ix86} x86_64
|
ExclusiveArch: %{ix86} x86_64
|
||||||
|
|
||||||
Patch0: sysprof-1.2.0-fix_udev_rule_path.patch
|
|
||||||
|
|
||||||
%description
|
%description
|
||||||
Sysprof is a sampling CPU profiler for Linux that collects accurate,
|
Sysprof is a sampling CPU profiler for Linux that collects accurate,
|
||||||
high-precision data and provides efficient access to the sampled
|
high-precision data and provides efficient access to the sampled
|
||||||
calltrees.
|
calltrees.
|
||||||
|
|
||||||
|
|
||||||
|
%package devel
|
||||||
|
Summary: Development files for %{name}
|
||||||
|
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||||
|
|
||||||
|
%description devel
|
||||||
|
The %{name}-devel package contains libraries and header files for
|
||||||
|
developing applications that use %{name}.
|
||||||
|
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n sysprof-%{version}
|
%setup -q -n sysprof-%{version}
|
||||||
%patch0 -p1
|
%patch0 -p1
|
||||||
|
|
||||||
# Fix README
|
|
||||||
iconv --from=ISO-8859-1 --to=UTF-8 README > README.new && \
|
|
||||||
touch -r README README.new && \
|
|
||||||
mv README.new README
|
|
||||||
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
autoreconf
|
%configure --disable-static
|
||||||
%configure
|
|
||||||
make %{?_smp_mflags}
|
make %{?_smp_mflags}
|
||||||
|
|
||||||
|
|
||||||
%install
|
%install
|
||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
make install DESTDIR=${RPM_BUILD_ROOT}
|
make install DESTDIR=${RPM_BUILD_ROOT}
|
||||||
|
find $RPM_BUILD_ROOT -name '*.la' -delete
|
||||||
for size in 16 24 32 48; do
|
%find_lang %{name} --all-name --with-gnome
|
||||||
mkdir -p ${RPM_BUILD_ROOT}%{_datadir}/icons/hicolor/${size}x${size}/apps
|
|
||||||
ln -s %{_datadir}/pixmaps/sysprof-icon-${size}.png \
|
|
||||||
${RPM_BUILD_ROOT}%{_datadir}/icons/hicolor/${size}x${size}/apps/sysprof-icon.png
|
|
||||||
done
|
|
||||||
|
|
||||||
desktop-file-install \
|
desktop-file-install \
|
||||||
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
|
--dir ${RPM_BUILD_ROOT}%{_datadir}/applications \
|
||||||
@ -65,9 +62,11 @@ desktop-file-install \
|
|||||||
rm -rf ${RPM_BUILD_ROOT}
|
rm -rf ${RPM_BUILD_ROOT}
|
||||||
|
|
||||||
%post
|
%post
|
||||||
|
/sbin/ldconfig
|
||||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
|
||||||
%postun
|
%postun
|
||||||
|
/sbin/ldconfig
|
||||||
if [ $1 -eq 0 ] ; then
|
if [ $1 -eq 0 ] ; then
|
||||||
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
touch --no-create %{_datadir}/icons/hicolor &>/dev/null
|
||||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
@ -77,18 +76,33 @@ fi
|
|||||||
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
gtk-update-icon-cache %{_datadir}/icons/hicolor &>/dev/null || :
|
||||||
|
|
||||||
|
|
||||||
%files
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc NEWS README COPYING TODO AUTHORS
|
%doc NEWS README COPYING TODO AUTHORS
|
||||||
%{_prefix}/lib/udev/rules.d/60-sysprof.rules
|
|
||||||
%{_bindir}/sysprof
|
%{_bindir}/sysprof
|
||||||
%{_bindir}/sysprof-cli
|
%{_bindir}/sysprof-cli
|
||||||
%{_datadir}/pixmaps/sysprof-*.png
|
%{_libdir}/libsysprof-2.so
|
||||||
%{_datadir}/sysprof/
|
%{_libdir}/libsysprof-ui-2.so
|
||||||
|
%{_libexecdir}/sysprof/sysprofd
|
||||||
%{_datadir}/applications/*.desktop
|
%{_datadir}/applications/*.desktop
|
||||||
|
%{_datadir}/dbus-1/system.d/org.gnome.Sysprof2.conf
|
||||||
|
%{_datadir}/dbus-1/system-services/org.gnome.Sysprof2.service
|
||||||
|
%{_datadir}/glib-2.0/schemas/org.gnome.sysprof2.gschema.xml
|
||||||
%{_datadir}/icons/hicolor/*/*/*
|
%{_datadir}/icons/hicolor/*/*/*
|
||||||
|
%{_datadir}/mime/packages/sysprof-mime.xml
|
||||||
|
%{_datadir}/polkit-1/actions/org.gnome.sysprof2.policy
|
||||||
|
%{_unitdir}/sysprof2.service
|
||||||
|
|
||||||
|
%files devel
|
||||||
|
%{_includedir}/sysprof-2/
|
||||||
|
%{_libdir}/pkgconfig/sysprof-2.pc
|
||||||
|
%{_libdir}/pkgconfig/sysprof-ui-2.pc
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 08 2016 Kalev Lember <klember@redhat.com> - 3.20.0-1
|
||||||
|
- Update to 3.20.0
|
||||||
|
|
||||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-8
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.2.0-8
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user