syslinux/syslinux-2.08-x86_64.patch
cvsdist 152e33ea56 auto-import changelog data from syslinux-2.08-1.src.rpm
Sun Dec 14 2003 Jeremy Katz <katzj@redhat.com> 2.08-1
- 2.08
2004-09-09 12:55:28 +00:00

26 lines
684 B
Diff

--- syslinux-2.08/sample/Makefile.x86_64 2003-12-10 15:44:57.000000000 -0500
+++ syslinux-2.08/sample/Makefile 2003-12-14 17:26:35.142040434 -0500
@@ -29,6 +29,13 @@
LIBOBJS = conio.o atou.o skipatou.o printf.o
+ARCH := $(shell uname -m)
+ifneq (x86_64, $ARCH)
+CFLAGS += -m32
+SFLAGS += -m32
+LDFLAGS += -m elf_i386
+endif
+
.SUFFIXES: .lss .c .o .elf .c32
all: syslogo.lss comecho.com hello.c32 hello2.c32 filetest.c32 c32echo.c32 fd.c32 chain.c32
@@ -40,7 +47,7 @@
$(CC) $(CFLAGS) -c -o $@ $<
%.elf: c32entry.o %.o $(LIB)
- $(LD) -Ttext 0x101000 -e _start -o $@ $^
+ $(LD) $(LDFLAGS) -Ttext 0x101000 -e _start -o $@ $^
%.c32: %.elf
$(OBJCOPY) -O binary $< $@