* Thu Aug 05 2010 Peter Jones <pjones@redhat.com> - 4.02-1
- Update to 4.02
This commit is contained in:
parent
ab41a56aec
commit
c0b4a03cda
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
clog
|
||||
syslinux-3.84.tar.bz2
|
||||
syslinux-4.02.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
7a3503098a9d1e3b55b90bec303e66e2 syslinux-3.84.tar.bz2
|
||||
52912c03f5c275d6c0ac09180ebab81f syslinux-4.02.tar.bz2
|
||||
|
@ -1,25 +0,0 @@
|
||||
--- syslinux-2.08/sample/Makefile.x86_64 2003-12-10 15:44:57.000000000 -0500
|
||||
+++ syslinux-2.08/sample/Makefile 2003-12-14 17:26:35.142040434 -0500
|
||||
@@ -29,6 +29,13 @@
|
||||
|
||||
LIBOBJS = conio.o atou.o skipatou.o printf.o
|
||||
|
||||
+ARCH := $(shell uname -m)
|
||||
+ifneq (x86_64, $ARCH)
|
||||
+CFLAGS += -m32
|
||||
+SFLAGS += -m32
|
||||
+LDFLAGS += -m elf_i386
|
||||
+endif
|
||||
+
|
||||
.SUFFIXES: .lss .c .o .elf .c32
|
||||
|
||||
all: syslogo.lss comecho.com hello.c32 hello2.c32 filetest.c32 c32echo.c32 fd.c32 chain.c32
|
||||
@@ -40,7 +47,7 @@
|
||||
$(CC) $(CFLAGS) -c -o $@ $<
|
||||
|
||||
%.elf: c32entry.o %.o $(LIB)
|
||||
- $(LD) -Ttext 0x101000 -e _start -o $@ $^
|
||||
+ $(LD) $(LDFLAGS) -Ttext 0x101000 -e _start -o $@ $^
|
||||
|
||||
%.c32: %.elf
|
||||
$(OBJCOPY) -O binary $< $@
|
@ -1,13 +0,0 @@
|
||||
--- syslinux-3.36/com32/lib/sys/vesa/video.h.16bpp 2007-05-04 11:54:36.000000000 -0400
|
||||
+++ syslinux-3.36/com32/lib/sys/vesa/video.h 2007-05-03 00:00:50.000000000 -0400
|
||||
@@ -49,9 +49,9 @@
|
||||
/* Pixel formats in order of decreasing preference; PXF_NONE should be last */
|
||||
/* BGR24 is preferred over BGRA32 since the I/O overhead is smaller. */
|
||||
enum vesa_pixel_format {
|
||||
+ PXF_LE_RGB16_565, /* 16-bit littleendian 5:6:5 RGB */
|
||||
PXF_BGR24, /* 24-bit BGR */
|
||||
PXF_BGRA32, /* 32-bit BGRA */
|
||||
- PXF_LE_RGB16_565, /* 16-bit littleendian 5:6:5 RGB */
|
||||
PXF_NONE
|
||||
};
|
||||
|
@ -1,36 +0,0 @@
|
||||
diff -up syslinux-3.83/linux/Makefile.nostrip syslinux-3.83/linux/Makefile
|
||||
--- syslinux-3.83/linux/Makefile.nostrip 2009-04-28 15:34:45.000000000 -0400
|
||||
+++ syslinux-3.83/linux/Makefile 2009-04-28 15:35:16.000000000 -0400
|
||||
@@ -20,7 +20,7 @@ include $(topdir)/MCONFIG
|
||||
OPTFLAGS = -g -Os
|
||||
INCLUDES = -I. -I.. -I../libinstaller
|
||||
CFLAGS = -W -Wall -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
|
||||
-LDFLAGS = -s
|
||||
+LDFLAGS =
|
||||
|
||||
SRCS = syslinux.c \
|
||||
../libinstaller/syslxmod.c \
|
||||
diff -up syslinux-3.83/mtools/Makefile.nostrip syslinux-3.83/mtools/Makefile
|
||||
--- syslinux-3.83/mtools/Makefile.nostrip 2009-04-28 15:34:51.000000000 -0400
|
||||
+++ syslinux-3.83/mtools/Makefile 2009-04-28 15:35:22.000000000 -0400
|
||||
@@ -4,7 +4,7 @@ include $(topdir)/MCONFIG
|
||||
OPTFLAGS = -g -Os
|
||||
INCLUDES = -I. -I.. -I../libfat -I../libinstaller
|
||||
CFLAGS = -W -Wall -D_FILE_OFFSET_BITS=64 $(OPTFLAGS) $(INCLUDES)
|
||||
-LDFLAGS = -s
|
||||
+LDFLAGS =
|
||||
|
||||
SRCS = syslinux.c \
|
||||
../libinstaller/syslxmod.c \
|
||||
diff -urpN syslinux-3.83/utils/Makefile.strip syslinux-3.83/utils/Makefile
|
||||
--- syslinux-3.83/utils/Makefile.strip 2009-10-29 10:11:52.000000000 -0400
|
||||
+++ syslinux-3.83/utils/Makefile 2009-10-29 10:11:53.000000000 -0400
|
||||
@@ -18,7 +18,7 @@ topdir = ..
|
||||
include $(topdir)/MCONFIG
|
||||
|
||||
CFLAGS = -W -Wall -Os -fomit-frame-pointer -D_FILE_OFFSET_BITS=64
|
||||
-LDFLAGS = -O2 -s
|
||||
+LDFLAGS = -O2
|
||||
|
||||
TARGETS = mkdiskimage isohybrid gethostip
|
||||
ASIS = keytab-lilo lss16toppm md5pass ppmtolss16 sha1pass syslinux2ansi \
|
@ -1,13 +1,12 @@
|
||||
Summary: Simple kernel loader which boots from a FAT filesystem
|
||||
Name: syslinux
|
||||
Version: 3.84
|
||||
%define tarball_version 3.84
|
||||
Version: 4.02
|
||||
%define tarball_version 4.02
|
||||
Release: 1%{?dist}
|
||||
License: GPLv2+
|
||||
Group: Applications/System
|
||||
URL: http://syslinux.zytor.com/wiki/index.php/The_Syslinux_Project
|
||||
Source0: http://www.kernel.org/pub/linux/utils/boot/syslinux/%{name}-%{tarball_version}.tar.bz2
|
||||
Patch0: syslinux-debuginfo.patch
|
||||
ExclusiveArch: %{ix86} x86_64
|
||||
Buildroot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
BuildRequires: nasm >= 0.98.38-1, perl, netpbm-progs
|
||||
@ -40,7 +39,6 @@ Headers and libraries for syslinux development.
|
||||
|
||||
%prep
|
||||
%setup -q -n syslinux-%{tarball_version}
|
||||
%patch0 -p1 -b .nostrip
|
||||
|
||||
%build
|
||||
CFLAGS="-Werror -Wno-unused -finline-limit=2000"
|
||||
@ -76,7 +74,7 @@ rm -rf %{buildroot}
|
||||
|
||||
%files
|
||||
%defattr(-,root,root)
|
||||
%doc NEWS README* TODO COPYING
|
||||
%doc NEWS README* COPYING
|
||||
%doc doc/*
|
||||
%doc sample
|
||||
%{_mandir}/man*/*
|
||||
@ -100,6 +98,9 @@ rm -rf %{buildroot}
|
||||
%{_datadir}/syslinux/com32
|
||||
|
||||
%changelog
|
||||
* Thu Aug 05 2010 Peter Jones <pjones@redhat.com> - 4.02-1
|
||||
- Update to 4.02
|
||||
|
||||
* Mon Jan 11 2010 Peter Jones <pjones@redhat.com> - 3.84-1
|
||||
- Update to 3.84
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user