Update to 6.03
Signed-off-by: Peter Jones <pjones@redhat.com>
This commit is contained in:
parent
76761664ae
commit
b60856f793
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,2 +1,3 @@
|
|||||||
clog
|
clog
|
||||||
syslinux-*.tar.*
|
syslinux-*.tar.*
|
||||||
|
*.rpm
|
||||||
|
@ -1,18 +1,18 @@
|
|||||||
From 8b8b0ab5cae3e3e47104dfe696d06709f8ce6850 Mon Sep 17 00:00:00 2001
|
From ca745cdfc27b83b6bcef9f856d858a68c64429de Mon Sep 17 00:00:00 2001
|
||||||
From: Peter Jones <pjones@redhat.com>
|
From: Peter Jones <pjones@redhat.com>
|
||||||
Date: Tue, 8 Apr 2014 15:28:12 -0400
|
Date: Tue, 8 Apr 2014 15:28:12 -0400
|
||||||
Subject: [PATCH 1/2] Add "install-all target" to top side of HAVE_FIRMWARE.
|
Subject: [PATCH] Add "install-all target" to top side of HAVE_FIRMWARE.
|
||||||
|
|
||||||
---
|
---
|
||||||
Makefile | 10 ++++++++++
|
Makefile | 10 ++++++++++
|
||||||
1 file changed, 10 insertions(+)
|
1 file changed, 10 insertions(+)
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
diff --git a/Makefile b/Makefile
|
||||||
index cceb66e..b8ee459 100644
|
index fb387c5..3429058 100644
|
||||||
--- a/Makefile
|
--- a/Makefile
|
||||||
+++ b/Makefile
|
+++ b/Makefile
|
||||||
@@ -269,6 +269,16 @@ efi64:
|
@@ -273,6 +273,16 @@ efi64:
|
||||||
ARCH=x86_64 BITS=64 EFI_BUILD=1 LDLINUX=ldlinux.e64 \
|
FIRMWARE=EFI64 \
|
||||||
$(MAKECMDGOALS)
|
$(MAKECMDGOALS)
|
||||||
|
|
||||||
+install-all:
|
+install-all:
|
||||||
@ -29,5 +29,5 @@ index cceb66e..b8ee459 100644
|
|||||||
|
|
||||||
all: all-local subdirs
|
all: all-local subdirs
|
||||||
--
|
--
|
||||||
1.9.0
|
1.9.3
|
||||||
|
|
||||||
|
@ -1,40 +0,0 @@
|
|||||||
From 8a339e31bdfbaa188a113f690501fea201f71f87 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Peter Jones <pjones@redhat.com>
|
|
||||||
Date: Tue, 8 Apr 2014 15:15:48 -0400
|
|
||||||
Subject: [PATCH 2/2] Don't build efi32.
|
|
||||||
|
|
||||||
---
|
|
||||||
Makefile | 6 +++---
|
|
||||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/Makefile b/Makefile
|
|
||||||
index b8ee459..5ce63c8 100644
|
|
||||||
--- a/Makefile
|
|
||||||
+++ b/Makefile
|
|
||||||
@@ -84,7 +84,7 @@ endif
|
|
||||||
# creating. Which means that we always need a *real* target, such as
|
|
||||||
# 'all', appended to the make goals.
|
|
||||||
#
|
|
||||||
-firmware = bios efi32 efi64
|
|
||||||
+firmware = bios efi64
|
|
||||||
real-target := $(filter-out $(firmware), $(MAKECMDGOALS))
|
|
||||||
real-firmware := $(filter $(firmware), $(MAKECMDGOALS))
|
|
||||||
|
|
||||||
@@ -222,12 +222,12 @@ endif # ifdef EFI_BUILD
|
|
||||||
|
|
||||||
ifeq ($(HAVE_FIRMWARE),)
|
|
||||||
|
|
||||||
-firmware = bios efi32 efi64
|
|
||||||
+firmware = bios efi64
|
|
||||||
|
|
||||||
# If no firmware was specified the rest of MAKECMDGOALS applies to all
|
|
||||||
# firmware.
|
|
||||||
ifeq ($(filter $(firmware),$(MAKECMDGOALS)),)
|
|
||||||
-all strip tidy clean dist spotless install installer netinstall: bios efi32 efi64
|
|
||||||
+all strip tidy clean dist spotless install installer netinstall: bios efi64
|
|
||||||
|
|
||||||
else
|
|
||||||
|
|
||||||
--
|
|
||||||
1.9.0
|
|
||||||
|
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
6f275813a1b08cf852e55c0a3f8fbc78 syslinux-6.02.tar.xz
|
92a253df9211e9c20172796ecf388f13 syslinux-6.03.tar.xz
|
||||||
|
@ -1,8 +1,8 @@
|
|||||||
Summary: Simple kernel loader which boots from a FAT filesystem
|
Summary: Simple kernel loader which boots from a FAT filesystem
|
||||||
Name: syslinux
|
Name: syslinux
|
||||||
Version: 6.02
|
Version: 6.03
|
||||||
%define tarball_version 6.02
|
%define tarball_version 6.03
|
||||||
Release: 7%{?dist}
|
Release: 1%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
Group: Applications/System
|
Group: Applications/System
|
||||||
URL: http://syslinux.zytor.com/wiki/index.php/The_Syslinux_Project
|
URL: http://syslinux.zytor.com/wiki/index.php/The_Syslinux_Project
|
||||||
@ -167,6 +167,8 @@ rm -rf %{buildroot}
|
|||||||
%{_mandir}/man1/gethostip*
|
%{_mandir}/man1/gethostip*
|
||||||
%{_mandir}/man1/syslinux*
|
%{_mandir}/man1/syslinux*
|
||||||
%{_mandir}/man1/extlinux*
|
%{_mandir}/man1/extlinux*
|
||||||
|
%{_mandir}/man1/isohybrid*
|
||||||
|
%{_mandir}/man1/memdiskfind*
|
||||||
%{_bindir}/gethostip
|
%{_bindir}/gethostip
|
||||||
%{_bindir}/isohybrid
|
%{_bindir}/isohybrid
|
||||||
%{_bindir}/memdiskfind
|
%{_bindir}/memdiskfind
|
||||||
@ -255,6 +257,9 @@ elif [ -f /boot/extlinux.conf ]; then \
|
|||||||
fi
|
fi
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 08 2014 Peter Jones <pjones@redhat.com> - 6.03-1
|
||||||
|
- Update to 6.03
|
||||||
|
|
||||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.02-7
|
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 6.02-7
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user