update to 0.9.0
This commit is contained in:
parent
9688a2a2ff
commit
e081636851
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/synce4l-ca51d5.tar.gz
|
||||
/synce4l-0.9.0.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (synce4l-ca51d5.tar.gz) = e48e0cbf8eaf88725d552640ee819a41255f8eb040ee49a1ef8683465985b263363692ebf2a64f8e2ca521fa2ad1dcfe54b5e603aa63c5aab4a65c0f4def2c5d
|
||||
SHA512 (synce4l-0.9.0.tar.gz) = 24e48502576c3f3fe96b87320519436942084d0a3da0f0bf22681fa9bc8ad0b45248786ac62d02747891babf6e9b269666549f6c9de1b272f32dedcd3a0de15f
|
||||
|
31
synce4l-gcc-warn.patch
Normal file
31
synce4l-gcc-warn.patch
Normal file
@ -0,0 +1,31 @@
|
||||
commit 40375f3babd5a52e0e9d5f2abe4a9332505e702d
|
||||
Author: Miroslav Lichvar <mlichvar@redhat.com>
|
||||
Date: Mon Jun 19 11:57:18 2023 +0200
|
||||
|
||||
Avoid -Wmaybe-uninitialized warning
|
||||
|
||||
This avoids the following false positive from gcc:
|
||||
|
||||
config.c:352:28: error: 'df' may be used uninitialized [-Werror=maybe-uninitialized]
|
||||
352 | dst->val.d = df;
|
||||
| ^
|
||||
config.c: In function 'config_read':
|
||||
config.c:286:16: note: 'df' was declared here
|
||||
286 | double df;
|
||||
| ^
|
||||
|
||||
Signed-off-by: Miroslav Lichvar <mlichvar@redhat.com>
|
||||
|
||||
diff --git a/config.c b/config.c
|
||||
index 946e508..26f3c82 100644
|
||||
--- a/config.c
|
||||
+++ b/config.c
|
||||
@@ -283,7 +283,7 @@ static enum parser_result parse_item(struct config *cfg,
|
||||
enum parser_result r;
|
||||
struct config_item *cgi, *dst;
|
||||
struct config_enum *cte;
|
||||
- double df;
|
||||
+ double df = 0.0;
|
||||
int val;
|
||||
|
||||
r = parse_fault_interval(cfg, section, option, value);
|
10
synce4l.conf
10
synce4l.conf
@ -7,11 +7,11 @@ message_tag [synce4l]
|
||||
[<synce1>]
|
||||
input_mode line
|
||||
network_option 1
|
||||
external_input_QL 11
|
||||
external_input_ext_QL 33
|
||||
external_input_QL 0x2
|
||||
external_input_ext_QL 0x20
|
||||
extended_tlv 1
|
||||
recover_time 20
|
||||
eec_get_state_cmd cat /sys/class/net/eth0/device/cgu_state
|
||||
eec_get_state_cmd cat /sys/class/net/eth0/device/dpll_0_state
|
||||
eec_holdover_value 4
|
||||
eec_locked_ho_value 3
|
||||
eec_locked_value 2
|
||||
@ -23,5 +23,5 @@ tx_heartbeat_msec 1000
|
||||
rx_heartbeat_msec 500
|
||||
recover_clock_enable_cmd echo 1 0 > /sys/class/net/eth0/device/phy/synce
|
||||
recover_clock_disable_cmd echo 0 0 > /sys/class/net/eth0/device/phy/synce
|
||||
allowed_qls 3,4,7
|
||||
allowed_ext_qls 20,21
|
||||
allowed_qls 0x2,0x4,0x8
|
||||
allowed_ext_qls 0x20,0x21
|
||||
|
13
synce4l.spec
13
synce4l.spec
@ -1,17 +1,14 @@
|
||||
%global gitver ca51d51d27fb0c2b1ac0febe8600ffb6fbad160a
|
||||
%global gitrel %(c=%{gitver}; echo ${c:0:6})
|
||||
%global gitdate 20221114
|
||||
|
||||
Name: synce4l
|
||||
Version: 0
|
||||
Release: 4.%{gitdate}git%{gitrel}%{?dist}
|
||||
Version: 0.9.0
|
||||
Release: 1%{?dist}
|
||||
Summary: SyncE implementation for Linux
|
||||
|
||||
License: GPL-2.0-or-later
|
||||
URL: https://github.com/intel/synce4l
|
||||
Source0: https://github.com/intel/synce4l/archive/%{gitrel}/synce4l-%{gitrel}.tar.gz
|
||||
Source0: https://github.com/intel/synce4l/archive/%{version}/synce4l-%{version}.tar.gz
|
||||
Source1: synce4l.service
|
||||
Source2: synce4l.conf
|
||||
Patch1: synce4l-gcc-warn.patch
|
||||
|
||||
BuildRequires: gcc make systemd
|
||||
|
||||
@ -25,7 +22,7 @@ supported hardware by processing Ethernet Synchronization Messaging Channel
|
||||
(NIC).
|
||||
|
||||
%prep
|
||||
%setup -q -n synce4l-%{gitver}
|
||||
%autosetup
|
||||
|
||||
%build
|
||||
%{make_build} \
|
||||
|
Loading…
Reference in New Issue
Block a user