- 1.4. All patches now upstream.

This commit is contained in:
Tim Waugh 2009-11-13 10:11:10 +00:00
parent 5f89ef2ecc
commit 230a389d62
4 changed files with 6 additions and 57 deletions

View File

@ -1,27 +0,0 @@
--- symlinks-1.2/symlinks.8.fixman Tue May 30 14:49:29 2000
+++ symlinks-1.2/symlinks.8 Tue May 30 14:50:43 2000
@@ -1,11 +1,11 @@
-.TH SYMLINKS 8 "November 1994" "Version 1.1"
+.TH SYMLINKS 8 "November 1994" "Version 1.2"
.SH NAME
symlinks \- symbolic link maintenance utility
.SH SYNOPSIS
.B symlinks
[
-.B -cdrv
+.B -cdrstv
]
dirlist
.SH DESCRIPTION
--- symlinks-1.2/symlinks.c.fixman Tue May 30 14:59:59 2000
+++ symlinks-1.2/symlinks.c Tue May 30 15:00:39 2000
@@ -289,7 +289,7 @@
fprintf(stderr, "Flags:\t-c == change absolute/messy links to relative\n"
"\t-d == delete dangling links\n"
"\t-r == recurse into subdirs\n"
- "\t-s == shorten lengthy links\n"
+ "\t-s == shorten lengthy links (only displayed if -c not specified)\n"
"\t-v == verbose (show all symlinks)\n\n");
exit(1);
}

View File

@ -1,11 +0,0 @@
--- symlinks-1.2/Makefile.nostatic Thu Feb 10 11:35:00 2000
+++ symlinks-1.2/Makefile Thu Feb 10 11:38:01 2000
@@ -3,7 +3,7 @@
all: symlinks
symlinks: symlinks.c
- gcc -Wall -Wstrict-prototypes -O2 -N -s -o symlinks symlinks.c
+ gcc -Wall -Wstrict-prototypes ${CFLAGS} -o symlinks symlinks.c
install: all symlinks.8
install -m 755 -o root -g root symlinks /usr/local/bin

View File

@ -1,10 +0,0 @@
--- symlinks-1.2/symlinks.c.lr 2003-10-16 14:07:29.000000000 +0200
+++ symlinks-1.2/symlinks.c 2003-10-16 14:08:16.000000000 +0200
@@ -235,6 +235,7 @@
strcpy (np, tail);
(void) tidy_path(new);
}
+ shorten_path(new, path);
if (!testing) {
if (unlink (path)) {
perror(path);

View File

@ -1,16 +1,13 @@
Summary: A utility which maintains a system's symbolic links
Name: symlinks
URL: ftp://metalab.unc.edu/pub/Linux/utils/file/
Version: 1.2
Release: 34%{?dist}
Version: 1.4
Release: 1%{?dist}
Group: Applications/System
License: Copyright only
Source0: ftp://metalab.unc.edu/pub/Linux/utils/file/%{name}-%{version}.tar.gz
Source0: http://ibiblio.org/pub/Linux/utils/file/%{name}-%{version}.tar.gz
# Taken from http://packages.debian.org/changelogs/pool/main/s/symlinks/symlinks_1.2-4.2/symlinks.copyright
Source1: symlinks-LICENSE.txt
Patch0: symlinks-1.2-nostatic.patch
Patch1: symlinks-1.2-fixman.patch
Patch2: symlinks-1.2-short.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
%description
@ -24,9 +21,6 @@ symlinks on your system.
%prep
%setup -q
%patch0 -p1 -b .nostatic
%patch1 -p1 -b .fixman
%patch2 -p1
cp %{SOURCE1} .
%build
@ -49,6 +43,9 @@ rm -rf $RPM_BUILD_ROOT
%{_mandir}/man8/symlinks.8*
%changelog
* Fri Nov 13 2009 Tim Waugh <twaugh@redhat.com> 1.4-1
- 1.4. All patches now upstream.
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-34
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild