Auto sync2gitlab import of symlinks-1.4-19.el8.src.rpm
This commit is contained in:
parent
26cd39c810
commit
1d8f5d0855
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
/symlinks-1.4.tar.gz
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (symlinks-1.4.tar.gz) = d1efb1ca553cc9eb95f1d113e453acd22c9f0964eacec985c85c125de23ae9d636b9ced182c2673f455e5d897ad15a978a424170fce767ccc492443eac7f972f
|
25
symlinks-LICENSE.txt
Normal file
25
symlinks-LICENSE.txt
Normal file
@ -0,0 +1,25 @@
|
||||
From: http://packages.debian.org/changelogs/pool/main/s/symlinks/symlinks_1.2-4.2/symlinks.copyright
|
||||
|
||||
Copyright (c) Mark Lord, freely distributable
|
||||
|
||||
License clarification as found in Debian Bug #273338:
|
||||
|
||||
Hi,
|
||||
|
||||
My "symlinks" utility pre-dates the "open source licensing" fad
|
||||
by a number of years. Just to clarify, this is 100% freeware,
|
||||
written entirely by myself. The intent is to use it to detect
|
||||
missing/obsolete symlink targets on an installed distro, before
|
||||
creating the "gold" (or "final") release discs.
|
||||
|
||||
Use and distribute and modify as you (or anyone else) sees fit.
|
||||
There have no formal restrictions or requirements whatsoever
|
||||
regarding distribution of either binaries or source code,
|
||||
whether modified or original.
|
||||
|
||||
Cheers
|
||||
--
|
||||
Mark Lord
|
||||
Real-Time Remedies Inc.
|
||||
mlord@pobox.com
|
||||
|
12
symlinks-coverity-overrun-dynamic.patch
Normal file
12
symlinks-coverity-overrun-dynamic.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up symlinks-1.4/symlinks.c.coverity-overrun-dynamic symlinks-1.4/symlinks.c
|
||||
--- symlinks-1.4/symlinks.c.coverity-overrun-dynamic 2011-05-20 14:10:25.682843723 +0100
|
||||
+++ symlinks-1.4/symlinks.c 2011-05-20 14:11:15.792920839 +0100
|
||||
@@ -44,7 +44,7 @@ static int substr (char *s, char *old, c
|
||||
newlen = strlen(new);
|
||||
|
||||
if (newlen > oldlen) {
|
||||
- if ((tmp = malloc(strlen(s))) == NULL) {
|
||||
+ if ((tmp = malloc(strlen(s)+1)) == NULL) {
|
||||
fprintf(stderr, "no memory\n");
|
||||
exit (1);
|
||||
}
|
12
symlinks-coverity-readlink.patch
Normal file
12
symlinks-coverity-readlink.patch
Normal file
@ -0,0 +1,12 @@
|
||||
diff -up symlinks-1.4/symlinks.c.coverity-readlink symlinks-1.4/symlinks.c
|
||||
--- symlinks-1.4/symlinks.c.coverity-readlink 2009-10-09 15:03:55.000000000 +0100
|
||||
+++ symlinks-1.4/symlinks.c 2011-05-20 14:10:25.682843723 +0100
|
||||
@@ -160,7 +160,7 @@ static void fix_symlink (char *path, dev
|
||||
struct stat stbuf, lstbuf;
|
||||
int c, fix_abs = 0, fix_messy = 0, fix_long = 0;
|
||||
|
||||
- if ((c = readlink(path, lpath, sizeof(lpath))) == -1) {
|
||||
+ if ((c = readlink(path, lpath, sizeof(lpath)-1)) == -1) {
|
||||
perror(path);
|
||||
return;
|
||||
}
|
229
symlinks.spec
Normal file
229
symlinks.spec
Normal file
@ -0,0 +1,229 @@
|
||||
Summary: A utility which maintains a system's symbolic links
|
||||
Name: symlinks
|
||||
URL: http://ibiblio.org/pub/Linux/utils/file/
|
||||
Version: 1.4
|
||||
Release: 19%{?dist}
|
||||
Group: Applications/System
|
||||
License: Copyright only
|
||||
Source0: http://ibiblio.org/pub/Linux/utils/file/%{name}-%{version}.tar.gz
|
||||
# Taken from http://packages.debian.org/changelogs/pool/main/s/symlinks/symlinks_1.2-4.2/symlinks.copyright
|
||||
Source1: symlinks-LICENSE.txt
|
||||
Patch1: symlinks-coverity-readlink.patch
|
||||
Patch2: symlinks-coverity-overrun-dynamic.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%description
|
||||
The symlinks utility performs maintenance on symbolic links. Symlinks
|
||||
checks for symlink problems, including dangling symlinks which point
|
||||
to nonexistent files. Symlinks can also automatically convert
|
||||
absolute symlinks to relative symlinks.
|
||||
|
||||
Install the symlinks package if you need a program for maintaining
|
||||
symlinks on your system.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
cp %{SOURCE1} .
|
||||
|
||||
# Fix off-by-one error in call to readlink.
|
||||
%patch1 -p1 -b .coverity-readlink
|
||||
|
||||
# Fix possible buffer overrun found by coverity.
|
||||
%patch2 -p1 -b .coverity-overrun-dynamic
|
||||
|
||||
%build
|
||||
make CFLAGS="$RPM_OPT_FLAGS $(getconf LFS_CFLAGS) %{build_ldflags}" %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
mkdir -p $RPM_BUILD_ROOT%{_bindir}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_mandir}/man8
|
||||
install -m 755 symlinks $RPM_BUILD_ROOT%{_bindir}
|
||||
install -m 644 symlinks.8 $RPM_BUILD_ROOT%{_mandir}/man8
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(-,root,root,-)
|
||||
%doc symlinks-LICENSE.txt
|
||||
%{_bindir}/symlinks
|
||||
%{_mandir}/man8/symlinks.8*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 14 2018 Than Ngo <than@redhat.com> - 1.4-19
|
||||
- fixed symlinks: Partial build flags injection
|
||||
|
||||
* Thu Jun 14 2018 Than Ngo <than@redhat.com> - 1.4-18
|
||||
- fixed upstream URL reference
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-17
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-16
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-14
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 1.4-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat Feb 21 2015 Till Maas <opensource@till.name> - 1.4-11
|
||||
- Rebuilt for Fedora 23 Change
|
||||
https://fedoraproject.org/wiki/Changes/Harden_all_packages_with_position-independent_code
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sat Jul 21 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri May 20 2011 Tim Waugh <twaugh@redhat.com> 1.4-4
|
||||
- Applied patches from Jiri Popelka:
|
||||
- Fix off-by-one error in call to readlink.
|
||||
- Fix possible buffer overrun found by coverity.
|
||||
|
||||
* Wed Feb 09 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Nov 13 2009 Tim Waugh <twaugh@redhat.com> 1.4-2
|
||||
- 1.4. All patches now upstream.
|
||||
|
||||
* Sun Jul 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-34
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Feb 25 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1.2-33
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Sat Sep 6 2008 Tom "spot" Callaway <tcallawa@redhat.com> 1.2-32
|
||||
- fix license tag
|
||||
|
||||
* Mon Feb 11 2008 Tim Waugh <twaugh@redhat.com> 1.2-31
|
||||
- Rebuild for GCC 4.3.
|
||||
|
||||
* Wed Aug 29 2007 Tim Waugh <twaugh@redhat.com> 1.2-30
|
||||
- Rebuilt.
|
||||
|
||||
* Fri Feb 23 2007 Tim Waugh <twaugh@redhat.com> 1.2-29
|
||||
- Use smp_mflags (bug #226445).
|
||||
- Better default attributes (bug #226445).
|
||||
- Make setup macro quiet (bug #226445).
|
||||
- Clean build root in %%install section (bug #226445).
|
||||
|
||||
* Wed Feb 7 2007 Tim Waugh <twaugh@redhat.com> 1.2-28
|
||||
- Fixed build root (bug #226445).
|
||||
|
||||
* Tue Feb 6 2007 Tim Waugh <twaugh@redhat.com> 1.2-27
|
||||
- Fixed summary (bug #226445).
|
||||
- Added token URL tag (bug #226445).
|
||||
|
||||
* Tue Jan 30 2007 Florian La Roche <laroche@redhat.com> - 1.2-26
|
||||
- do not strip away debuginfo
|
||||
|
||||
* Thu Jan 18 2007 Tim Waugh <twaugh@redhat.com> - 1.2-25
|
||||
- Build with LFS support (bug #206407).
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - 1.2-24.2.2
|
||||
- rebuild
|
||||
|
||||
* Fri Feb 10 2006 Jesse Keating <jkeating@redhat.com> - 1.2-24.2.1
|
||||
- bump again for double-long bug on ppc(64)
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 1.2-24.2
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Fri Dec 09 2005 Jesse Keating <jkeating@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Mar 2 2005 Tim Waugh <twaugh@redhat.com> 1.2-24
|
||||
- Rebuild for new GCC.
|
||||
|
||||
* Wed Feb 9 2005 Tim Waugh <twaugh@redhat.com> 1.2-23
|
||||
- s/Copyright:/License:/.
|
||||
|
||||
* Tue Jun 15 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Fri Feb 13 2004 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Thu Oct 16 2003 Florian La Roche <Florian.LaRoche@redhat.de>
|
||||
- add patch from #89655
|
||||
|
||||
* Wed Jun 04 2003 Elliot Lee <sopwith@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Jan 22 2003 Tim Powers <timp@redhat.com>
|
||||
- rebuilt
|
||||
|
||||
* Wed Dec 11 2002 Tim Powers <timp@redhat.com> 1.2-17
|
||||
- rebuild on all arches
|
||||
|
||||
* Fri Jun 21 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Thu May 23 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Wed Jan 09 2002 Tim Powers <timp@redhat.com>
|
||||
- automated rebuild
|
||||
|
||||
* Sun Jun 24 2001 Elliot Lee <sopwith@redhat.com>
|
||||
- Bump release + rebuild.
|
||||
|
||||
* Wed Jul 12 2000 Prospector <bugzilla@redhat.com>
|
||||
- automatic rebuild
|
||||
|
||||
* Tue Jun 13 2000 Preston Brown <pbrown@redhat.com>
|
||||
- FHS paths
|
||||
|
||||
* Tue May 30 2000 Preston Brown <pbrown@redhat.com>
|
||||
- fix up help output (#10236)
|
||||
|
||||
* Thu Feb 10 2000 Preston Brown <pbrown@redhat.com>
|
||||
- do not link statically
|
||||
|
||||
* Mon Feb 07 2000 Preston Brown <pbrown@redhat.com>
|
||||
- rebuild to gzip man page
|
||||
|
||||
* Mon Oct 04 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- rebuild against the latest glibc in the sparc tree
|
||||
|
||||
* Sun Mar 21 1999 Cristian Gafton <gafton@redhat.com>
|
||||
- auto rebuild in the new build environment (release 5)
|
||||
|
||||
* Wed Feb 24 1999 Preston Brown <pbrown@redhat.com>
|
||||
- Injected new description and group.
|
||||
|
||||
* Fri Dec 18 1998 Preston Brown <pbrown@redhat.com>
|
||||
- bumped spec number for initial rh 6.0 build
|
||||
|
||||
* Mon Apr 27 1998 Prospector System <bugs@redhat.com>
|
||||
- translations modified for de, fr, tr
|
||||
|
||||
* Mon Oct 20 1997 Otto Hammersmith <otto@redhat.com>
|
||||
- changed build root to /var/tmp, not /var/lib
|
||||
- updated to version 1.2
|
||||
|
||||
* Wed Jul 09 1997 Erik Troan <ewt@redhat.com>
|
||||
- built against glibc
|
||||
- build-rooted
|
Loading…
Reference in New Issue
Block a user