9e5e5b7ae1
Resolves: rhbz#1972785 Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
57 lines
1.6 KiB
Diff
57 lines
1.6 KiB
Diff
From 5887fddd54040701f05e524f014def12dcb788ac Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
|
Date: Mon, 12 Jul 2021 21:36:50 +0400
|
|
Subject: [PATCH] build-sys: carry configure-time CFLAGS
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
Reported: https://github.com/stefanberger/swtpm/issues/483
|
|
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
|
---
|
|
samples/Makefile.am | 2 ++
|
|
src/swtpm_setup/Makefile.am | 2 ++
|
|
2 files changed, 4 insertions(+)
|
|
|
|
diff --git a/samples/Makefile.am b/samples/Makefile.am
|
|
index dcbc9b6..d56da0f 100644
|
|
--- a/samples/Makefile.am
|
|
+++ b/samples/Makefile.am
|
|
@@ -39,11 +39,13 @@ swtpm_localca_LDADD = \
|
|
|
|
swtpm_localca_LDFLAGS = \
|
|
-L$(top_builddir)/src/utils -lswtpm_utils \
|
|
+ $(AM_LDFLAGS) \
|
|
$(HARDENING_LDFLAGS) \
|
|
$(GLIB_LIBS)
|
|
|
|
swtpm_localca_CFLAGS = \
|
|
-I$(top_srcdir)/src/utils \
|
|
+ $(AM_CFLAGS) \
|
|
$(HARDENING_CFLAGS) \
|
|
$(GLIB_CFLAGS)
|
|
|
|
diff --git a/src/swtpm_setup/Makefile.am b/src/swtpm_setup/Makefile.am
|
|
index 045bdb1..1f5b880 100644
|
|
--- a/src/swtpm_setup/Makefile.am
|
|
+++ b/src/swtpm_setup/Makefile.am
|
|
@@ -28,6 +28,7 @@ swtpm_setup_LDADD = \
|
|
|
|
swtpm_setup_LDFLAGS = \
|
|
-L$(top_builddir)/src/utils -lswtpm_utils \
|
|
+ $(AM_LDFLAGS) \
|
|
$(HARDENING_LDFLAGS) \
|
|
$(GLIB_LIBS) \
|
|
$(JSON_GLIB_LIBS) \
|
|
@@ -38,6 +39,7 @@ swtpm_setup_CFLAGS = \
|
|
-I$(top_srcdir)/include \
|
|
-I$(top_srcdir)/include/swtpm \
|
|
-I$(top_srcdir)/src/utils \
|
|
+ $(AM_CFLAGS) \
|
|
$(HARDENING_CFLAGS) \
|
|
$(GLIB_CFLAGS) \
|
|
$(JSON_GLIB_CFLAGS)
|
|
--
|
|
2.32.0.93.g670b81a890
|
|
|