import swtpm-0.7.0-1.20211109gitb79fd91.el9

This commit is contained in:
CentOS Sources 2022-01-11 12:16:51 -05:00 committed by Stepan Oksanichenko
parent 477a4a3ead
commit c8eea9b955
4 changed files with 17 additions and 67 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/swtpm-ea627b3.tar.gz
SOURCES/swtpm-b79fd91.tar.gz

View File

@ -1 +1 @@
12b1b68e25479473e9ab33102df40ba368d9b74c SOURCES/swtpm-ea627b3.tar.gz
b79a2d005663868139f0678cddeecf70278ec219 SOURCES/swtpm-b79fd91.tar.gz

View File

@ -1,56 +0,0 @@
From 5887fddd54040701f05e524f014def12dcb788ac Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Mon, 12 Jul 2021 21:36:50 +0400
Subject: [PATCH] build-sys: carry configure-time CFLAGS
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Reported: https://github.com/stefanberger/swtpm/issues/483
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
samples/Makefile.am | 2 ++
src/swtpm_setup/Makefile.am | 2 ++
2 files changed, 4 insertions(+)
diff --git a/samples/Makefile.am b/samples/Makefile.am
index dcbc9b6..d56da0f 100644
--- a/samples/Makefile.am
+++ b/samples/Makefile.am
@@ -39,11 +39,13 @@ swtpm_localca_LDADD = \
swtpm_localca_LDFLAGS = \
-L$(top_builddir)/src/utils -lswtpm_utils \
+ $(AM_LDFLAGS) \
$(HARDENING_LDFLAGS) \
$(GLIB_LIBS)
swtpm_localca_CFLAGS = \
-I$(top_srcdir)/src/utils \
+ $(AM_CFLAGS) \
$(HARDENING_CFLAGS) \
$(GLIB_CFLAGS)
diff --git a/src/swtpm_setup/Makefile.am b/src/swtpm_setup/Makefile.am
index 045bdb1..1f5b880 100644
--- a/src/swtpm_setup/Makefile.am
+++ b/src/swtpm_setup/Makefile.am
@@ -28,6 +28,7 @@ swtpm_setup_LDADD = \
swtpm_setup_LDFLAGS = \
-L$(top_builddir)/src/utils -lswtpm_utils \
+ $(AM_LDFLAGS) \
$(HARDENING_LDFLAGS) \
$(GLIB_LIBS) \
$(JSON_GLIB_LIBS) \
@@ -38,6 +39,7 @@ swtpm_setup_CFLAGS = \
-I$(top_srcdir)/include \
-I$(top_srcdir)/include/swtpm \
-I$(top_srcdir)/src/utils \
+ $(AM_CFLAGS) \
$(HARDENING_CFLAGS) \
$(GLIB_CFLAGS) \
$(JSON_GLIB_CFLAGS)
--
2.32.0.93.g670b81a890

View File

@ -1,7 +1,7 @@
%bcond_without gnutls
%global gitdate 20210607
%global gitcommit ea627b3b5e847f9141fcf25de0c03004d35fb375
%global gitdate 20211109
%global gitcommit b79fd91c4b4a74c9c5027b517c5036952c5525db
%global gitshortcommit %(c=%{gitcommit}; echo ${c:0:7})
# Macros needed by SELinux
@ -11,12 +11,11 @@
Summary: TPM Emulator
Name: swtpm
Version: 0.6.0
Release: 3.%{gitdate}git%{gitshortcommit}%{?dist}
Version: 0.7.0
Release: 1.%{gitdate}git%{gitshortcommit}%{?dist}
License: BSD
Url: http://github.com/stefanberger/swtpm
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
Patch0001: 0001-build-sys-carry-configure-time-CFLAGS.patch
BuildRequires: make
BuildRequires: git-core
@ -41,6 +40,7 @@ BuildRequires: selinux-policy-devel
BuildRequires: gcc
BuildRequires: libseccomp-devel
BuildRequires: tpm2-pkcs11 tpm2-pkcs11-tools tpm2-tools tpm2-abrmd
BuildRequires: python3-devel
Requires: %{name}-libs = %{version}-%{release}
Requires: libtpms >= 0.6.0
@ -93,12 +93,13 @@ NOCONFIGURE=1 ./autogen.sh
%if %{with gnutls}
--with-gnutls \
%endif
--without-cuse
--without-cuse \
--without-tpm1
%make_build CFLAGS="-Wno-error=deprecated-declarations -fPIE"
%make_build
%check
make %{?_smp_mflags} check VERBOSE=1 CFLAGS="-Wno-error=deprecated-declarations -fPIE"
make %{?_smp_mflags} check VERBOSE=1
%install
@ -154,15 +155,16 @@ fi
%endif
%{_bindir}/swtpm_setup
%{_bindir}/swtpm_ioctl
%{_bindir}/swtpm_localca
%{_mandir}/man8/swtpm_bios.8*
%{_mandir}/man8/swtpm_cert.8*
%{_mandir}/man8/swtpm_ioctl.8*
%{_mandir}/man8/swtpm-localca.conf.8*
%{_mandir}/man8/swtpm-localca.options.8*
%{_mandir}/man8/swtpm-localca.8*
%{_mandir}/man8/swtpm_localca.8*
%{_mandir}/man8/swtpm_setup.8*
%{_mandir}/man8/swtpm_setup.conf.8*
%{_mandir}/man8/swtpm_setup.sh.8*
%config(noreplace) %{_sysconfdir}/swtpm_setup.conf
%config(noreplace) %{_sysconfdir}/swtpm-localca.options
%config(noreplace) %{_sysconfdir}/swtpm-localca.conf
@ -176,6 +178,10 @@ fi
%{_datadir}/swtpm/swtpm-create-tpmca
%changelog
* Fri Nov 12 2021 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.7.0-1.20211109gitb79fd91
- Update to v0.7.0 release
Resolves: rhbz#2021580 & rhbz#1990153
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 0.6.0-3.20210607gitea627b3
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
Related: rhbz#1991688