import swtpm-0.7.0-1.20211109gitb79fd91.module+el8.6.0+13853+e8cd34b9

This commit is contained in:
CentOS Sources 2022-02-07 18:06:21 +00:00 committed by Stepan Oksanichenko
parent 41389475b1
commit b96a4a915b
4 changed files with 17 additions and 92 deletions

2
.gitignore vendored
View File

@ -1 +1 @@
SOURCES/swtpm-ea627b3.tar.gz
SOURCES/swtpm-b79fd91.tar.gz

View File

@ -1 +1 @@
12b1b68e25479473e9ab33102df40ba368d9b74c SOURCES/swtpm-ea627b3.tar.gz
b79a2d005663868139f0678cddeecf70278ec219 SOURCES/swtpm-b79fd91.tar.gz

View File

@ -1,80 +0,0 @@
From b40714634099d8a6ba342397a29ca20b50128c3c Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
Date: Thu, 16 Sep 2021 15:39:00 +0400
Subject: [PATCH] build-sys: add missing AM_CFLAGS
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Some binaries are being built without configure time CFLAGS, fix it.
Upstream commit is cab1e2186fa6f73ffe5848362d5f7c5a2c555bdb ("build-sys:
Add MY_CFLAGS, CFLAGS, and MY_LDFLAGS to all Makefile.am's") and earlier.
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
---
src/swtpm_bios/Makefile.am | 3 ++-
src/swtpm_cert/Makefile.am | 3 ++-
src/swtpm_ioctl/Makefile.am | 3 ++-
src/swtpm_setup/Makefile.am | 3 ++-
4 files changed, 8 insertions(+), 4 deletions(-)
diff --git a/src/swtpm_bios/Makefile.am b/src/swtpm_bios/Makefile.am
index c7c3016..a6c7166 100644
--- a/src/swtpm_bios/Makefile.am
+++ b/src/swtpm_bios/Makefile.am
@@ -13,7 +13,8 @@ bin_PROGRAMS = \
swtpm_bios_CFLAGS = \
-I$(top_builddir)/include \
-I$(top_srcdir)/include \
- $(HARDENING_CFLAGS)
+ $(HARDENING_CFLAGS) \
+ @AM_CFLAGS@
swtpm_bios_LDFLAGS = \
$(HARDENING_LDFLAGS)
diff --git a/src/swtpm_cert/Makefile.am b/src/swtpm_cert/Makefile.am
index bf0d8b7..74e4d2a 100644
--- a/src/swtpm_cert/Makefile.am
+++ b/src/swtpm_cert/Makefile.am
@@ -18,7 +18,8 @@ swtpm_cert_SOURCES = \
swtpm_cert_CFLAGS = \
-I$(top_builddir)/include \
- -I$(top_srcdir)/include
+ -I$(top_srcdir)/include \
+ @AM_CFLAGS@
ek-cert.o : tpm_asn1.h
diff --git a/src/swtpm_ioctl/Makefile.am b/src/swtpm_ioctl/Makefile.am
index cc8388c..3b722bd 100644
--- a/src/swtpm_ioctl/Makefile.am
+++ b/src/swtpm_ioctl/Makefile.am
@@ -14,7 +14,8 @@ swtpm_ioctl_SOURCES = tpm_ioctl.c
swtpm_ioctl_CFLAGS = \
-I$(top_builddir)/include \
-I$(top_srcdir)/include \
- $(HARDENING_CFLAGS)
+ $(HARDENING_CFLAGS) \
+ @AM_CFLAGS@
swtpm_ioctl_LDFLAGS = \
$(HARDENING_LDFLAGS)
diff --git a/src/swtpm_setup/Makefile.am b/src/swtpm_setup/Makefile.am
index 045bdb1..5696dde 100644
--- a/src/swtpm_setup/Makefile.am
+++ b/src/swtpm_setup/Makefile.am
@@ -40,7 +40,8 @@ swtpm_setup_CFLAGS = \
-I$(top_srcdir)/src/utils \
$(HARDENING_CFLAGS) \
$(GLIB_CFLAGS) \
- $(JSON_GLIB_CFLAGS)
+ $(JSON_GLIB_CFLAGS) \
+ @AM_CFLAGS@
EXTRA_DIST = \
README
--
2.33.0.113.g6c40894d24

View File

@ -1,7 +1,7 @@
%bcond_without gnutls
%global gitdate 20210607
%global gitcommit ea627b3b5e847f9141fcf25de0c03004d35fb375
%global gitdate 20211109
%global gitcommit b79fd91c4b4a74c9c5027b517c5036952c5525db
%global gitshortcommit %(c=%{gitcommit}; echo ${c:0:7})
# Macros needed by SELinux
@ -11,12 +11,11 @@
Summary: TPM Emulator
Name: swtpm
Version: 0.6.0
Release: 2.%{gitdate}git%{gitshortcommit}%{?dist}
Version: 0.7.0
Release: 1.%{gitdate}git%{gitshortcommit}%{?dist}
License: BSD
Url: http://github.com/stefanberger/swtpm
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
Patch0001: 0001-build-sys-add-missing-AM_CFLAGS.patch
ExcludeArch: i686
BuildRequires: make
@ -42,7 +41,7 @@ BuildRequires: selinux-policy-devel
BuildRequires: gcc
BuildRequires: libseccomp-devel
BuildRequires: tpm2-tools tpm2-abrmd
BuildRequires: python3
BuildRequires: python3-devel
Requires: %{name}-libs = %{version}-%{release}
Requires: libtpms >= 0.6.0
@ -95,12 +94,13 @@ NOCONFIGURE=1 ./autogen.sh
%if %{with gnutls}
--with-gnutls \
%endif
--without-cuse
--without-cuse \
--without-tpm1
%make_build CFLAGS="-Wno-error=deprecated-declarations -fPIE" V=1
%make_build V=1
%check
make %{?_smp_mflags} check VERBOSE=1 CFLAGS="-Wno-error=deprecated-declarations -fPIE"
make %{?_smp_mflags} check VERBOSE=1
%install
@ -156,15 +156,16 @@ fi
%endif
%{_bindir}/swtpm_setup
%{_bindir}/swtpm_ioctl
%{_bindir}/swtpm_localca
%{_mandir}/man8/swtpm_bios.8*
%{_mandir}/man8/swtpm_cert.8*
%{_mandir}/man8/swtpm_ioctl.8*
%{_mandir}/man8/swtpm-localca.conf.8*
%{_mandir}/man8/swtpm-localca.options.8*
%{_mandir}/man8/swtpm-localca.8*
%{_mandir}/man8/swtpm_localca.8*
%{_mandir}/man8/swtpm_setup.8*
%{_mandir}/man8/swtpm_setup.conf.8*
%{_mandir}/man8/swtpm_setup.sh.8*
%config(noreplace) %{_sysconfdir}/swtpm_setup.conf
%config(noreplace) %{_sysconfdir}/swtpm-localca.options
%config(noreplace) %{_sysconfdir}/swtpm-localca.conf
@ -178,6 +179,10 @@ fi
%{_datadir}/swtpm/swtpm-create-tpmca
%changelog
* Tue Jan 04 2022 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.7.0-1.20211109gitb79fd91
- Rebase to 0.7.0, disable TPM 1.2.
Resovles: rhbz#2029612
* Thu Sep 16 2021 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.6.0-2.20210607gitea627b3
- rebuilt with missing CFLAGS fix.