Applied patch with -Wno-deprecated-declarations for build with OpenSSL 3.0.0
This commit is contained in:
parent
ab0495a841
commit
a3c0d75489
@ -0,0 +1,29 @@
|
||||
From a0ca7c328f1c3c6a417973d194b41d06ab7b0802 Mon Sep 17 00:00:00 2001
|
||||
From: Stefan Berger <stefanb@linux.ibm.com>
|
||||
Date: Wed, 15 Sep 2021 11:34:02 -0400
|
||||
Subject: [PATCH] build-sys: Add -Wno-deprecated-declarations to default CFLAGS
|
||||
(OSSL 3)
|
||||
|
||||
To be able to build with OpenSSL 3.0 we need to added
|
||||
-Wno-deprecated-declarations to the default CFLAGS.
|
||||
|
||||
Signed-off-by: Stefan Berger <stefanb@linux.ibm.com>
|
||||
---
|
||||
configure.ac | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 1e0710c..7da1b47 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -461,6 +461,7 @@ AC_SUBST([TSS_GROUP])
|
||||
CFLAGS="$CFLAGS -Wreturn-type -Wsign-compare -Wswitch-enum"
|
||||
CFLAGS="$CFLAGS -Wmissing-prototypes -Wall -Werror"
|
||||
CFLAGS="$CFLAGS -Wformat -Wformat-security"
|
||||
+CFLAGS="$CFLAGS -Wno-deprecated-declarations"
|
||||
CFLAGS="$CFLAGS $GNUTLS_CFLAGS $COVERAGE_CFLAGS"
|
||||
|
||||
LDFLAGS="$LDFLAGS $COVERAGE_LDFLAGS"
|
||||
--
|
||||
2.31.1
|
||||
|
@ -12,11 +12,13 @@
|
||||
Summary: TPM Emulator
|
||||
Name: swtpm
|
||||
Version: 0.6.0
|
||||
Release: 4.%{gitdate}git%{gitshortcommit}%{?dist}
|
||||
Release: 5.%{gitdate}git%{gitshortcommit}%{?dist}
|
||||
License: BSD
|
||||
Url: http://github.com/stefanberger/swtpm
|
||||
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
|
||||
|
||||
Patch0001: 0001-build-sys-Add-Wno-deprecated-declarations-to-default.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: git-core
|
||||
BuildRequires: automake
|
||||
@ -87,6 +89,7 @@ Tools for creating a local CA based on a pkcs11 device
|
||||
|
||||
%prep
|
||||
%autosetup -S git -n %{name}-%{gitcommit} -p1
|
||||
%patch0001 -p1
|
||||
|
||||
%build
|
||||
|
||||
@ -178,6 +181,9 @@ fi
|
||||
%{_datadir}/swtpm/swtpm-create-tpmca
|
||||
|
||||
%changelog
|
||||
* Thu Sep 16 2021 Stefan Berger <stefanb@linux.ibm.com.> - 0.6.0-5.20210607gitea627b3
|
||||
- Applied patch with -Wno-deprecated-declarations for build with OpenSSL 3.0.0
|
||||
|
||||
* Tue Sep 14 2021 Sahana Prasad <sahana@redhat.com> - 0.6.0-4.20210607gitea627b3
|
||||
- Rebuilt with OpenSSL 3.0.0
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user