Fix CFLAGS issues with 0.6.0
Resolves: rhbz#1972785 Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
This commit is contained in:
parent
5633867027
commit
9e5e5b7ae1
56
0001-build-sys-carry-configure-time-CFLAGS.patch
Normal file
56
0001-build-sys-carry-configure-time-CFLAGS.patch
Normal file
@ -0,0 +1,56 @@
|
||||
From 5887fddd54040701f05e524f014def12dcb788ac Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Marc-Andr=C3=A9=20Lureau?= <marcandre.lureau@redhat.com>
|
||||
Date: Mon, 12 Jul 2021 21:36:50 +0400
|
||||
Subject: [PATCH] build-sys: carry configure-time CFLAGS
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Reported: https://github.com/stefanberger/swtpm/issues/483
|
||||
Signed-off-by: Marc-André Lureau <marcandre.lureau@redhat.com>
|
||||
---
|
||||
samples/Makefile.am | 2 ++
|
||||
src/swtpm_setup/Makefile.am | 2 ++
|
||||
2 files changed, 4 insertions(+)
|
||||
|
||||
diff --git a/samples/Makefile.am b/samples/Makefile.am
|
||||
index dcbc9b6..d56da0f 100644
|
||||
--- a/samples/Makefile.am
|
||||
+++ b/samples/Makefile.am
|
||||
@@ -39,11 +39,13 @@ swtpm_localca_LDADD = \
|
||||
|
||||
swtpm_localca_LDFLAGS = \
|
||||
-L$(top_builddir)/src/utils -lswtpm_utils \
|
||||
+ $(AM_LDFLAGS) \
|
||||
$(HARDENING_LDFLAGS) \
|
||||
$(GLIB_LIBS)
|
||||
|
||||
swtpm_localca_CFLAGS = \
|
||||
-I$(top_srcdir)/src/utils \
|
||||
+ $(AM_CFLAGS) \
|
||||
$(HARDENING_CFLAGS) \
|
||||
$(GLIB_CFLAGS)
|
||||
|
||||
diff --git a/src/swtpm_setup/Makefile.am b/src/swtpm_setup/Makefile.am
|
||||
index 045bdb1..1f5b880 100644
|
||||
--- a/src/swtpm_setup/Makefile.am
|
||||
+++ b/src/swtpm_setup/Makefile.am
|
||||
@@ -28,6 +28,7 @@ swtpm_setup_LDADD = \
|
||||
|
||||
swtpm_setup_LDFLAGS = \
|
||||
-L$(top_builddir)/src/utils -lswtpm_utils \
|
||||
+ $(AM_LDFLAGS) \
|
||||
$(HARDENING_LDFLAGS) \
|
||||
$(GLIB_LIBS) \
|
||||
$(JSON_GLIB_LIBS) \
|
||||
@@ -38,6 +39,7 @@ swtpm_setup_CFLAGS = \
|
||||
-I$(top_srcdir)/include \
|
||||
-I$(top_srcdir)/include/swtpm \
|
||||
-I$(top_srcdir)/src/utils \
|
||||
+ $(AM_CFLAGS) \
|
||||
$(HARDENING_CFLAGS) \
|
||||
$(GLIB_CFLAGS) \
|
||||
$(JSON_GLIB_CFLAGS)
|
||||
--
|
||||
2.32.0.93.g670b81a890
|
||||
|
@ -12,10 +12,11 @@
|
||||
Summary: TPM Emulator
|
||||
Name: swtpm
|
||||
Version: 0.6.0
|
||||
Release: 1.%{gitdate}git%{gitshortcommit}%{?dist}
|
||||
Release: 2.%{gitdate}git%{gitshortcommit}%{?dist}
|
||||
License: BSD
|
||||
Url: http://github.com/stefanberger/swtpm
|
||||
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
|
||||
Patch0001: 0001-build-sys-carry-configure-time-CFLAGS.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: git-core
|
||||
@ -175,7 +176,10 @@ fi
|
||||
%{_datadir}/swtpm/swtpm-create-tpmca
|
||||
|
||||
%changelog
|
||||
* Wed Jun 16 2021 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.6.0-1
|
||||
* Mon Jul 12 2021 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.6.0-2.20210607gitea627b3
|
||||
- rebuilt with AM_* flags patch
|
||||
|
||||
* Wed Jun 16 2021 Marc-André Lureau <marcandre.lureau@redhat.com> - 0.6.0-1.20210607gitea627b3
|
||||
- new version
|
||||
- Fixes: rhbz#1972785
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user