Update to v0.4.0 release
This commit is contained in:
parent
dd319d809f
commit
912e02bc81
1
.gitignore
vendored
1
.gitignore
vendored
@ -14,3 +14,4 @@
|
||||
/swtpm-0.3.0.tar.gz
|
||||
/swtpm-74ae43b.tar.gz
|
||||
/swtpm-80f0418.tar.gz
|
||||
/swtpm-0c238a2.tar.gz
|
||||
|
@ -20,7 +20,7 @@ index 8a4a9c2..c88acb4 100644
|
||||
--- a/tests/Makefile.am
|
||||
+++ b/tests/Makefile.am
|
||||
@@ -79,7 +79,6 @@ TESTS += \
|
||||
test_swtpm_cert \
|
||||
test_swtpm_setup_create_cert \
|
||||
test_tpm2_parameters \
|
||||
test_tpm2_samples_swtpm_localca \
|
||||
- test_tpm2_samples_swtpm_localca_pkcs11 \
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (swtpm-80f0418.tar.gz) = 7190800f04adf970c0579186af07e705aadb36c2305dfae4b2b300b97db3e6c920c41001449154d9bc5dd71bd635b3d6236d47a517caaa9352a3c04aed55b93c
|
||||
SHA512 (swtpm-0c238a2.tar.gz) = 584573b2cfcb295babf4f288f9dc26f0c86c15023c8e6e9f352689d49bb16dd415e37dc8dcd205ed525fe505b58d9d7d2a7a0da3a0b3cfa4b454fadeb0b2779a
|
||||
|
26
swtpm.spec
26
swtpm.spec
@ -1,7 +1,7 @@
|
||||
%bcond_without gnutls
|
||||
|
||||
%global gitdate 20200811
|
||||
%global gitcommit 80f04180f200829053c38818ae83721b21c747e8
|
||||
%global gitdate 20200828
|
||||
%global gitcommit 0c238a2c93cdeea4283c6e9a7b8430a9b2df2b3e
|
||||
%global gitshortcommit %(c=%{gitcommit}; echo ${c:0:7})
|
||||
|
||||
# Macros needed by SELinux
|
||||
@ -11,8 +11,8 @@
|
||||
|
||||
Summary: TPM Emulator
|
||||
Name: swtpm
|
||||
Version: 0.3.4
|
||||
Release: 2.%{gitdate}git%{gitshortcommit}%{?dist}
|
||||
Version: 0.4.0
|
||||
Release: 1.%{gitdate}git%{gitshortcommit}%{?dist}
|
||||
License: BSD
|
||||
Url: http://github.com/stefanberger/swtpm
|
||||
Source0: %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
|
||||
@ -24,16 +24,17 @@ BuildRequires: automake
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libtpms-devel >= 0.6.0
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: gmp-devel
|
||||
BuildRequires: expect
|
||||
BuildRequires: net-tools
|
||||
BuildRequires: openssl-devel
|
||||
BuildRequires: socat
|
||||
BuildRequires: python3
|
||||
BuildRequires: python3-devel
|
||||
BuildRequires: python3-cryptography
|
||||
BuildRequires: python3-pip
|
||||
BuildRequires: python3-setuptools
|
||||
BuildRequires: python3-twisted
|
||||
BuildRequires: trousers >= 0.3.9
|
||||
BuildRequires: tpm-tools >= 1.3.8-6
|
||||
BuildRequires: softhsm
|
||||
%if %{with gnutls}
|
||||
BuildRequires: gnutls >= 3.1.0
|
||||
@ -72,7 +73,8 @@ Include files for the TPM emulator's CUSE interface.
|
||||
Summary: Tools for the TPM emulator
|
||||
License: BSD
|
||||
Requires: swtpm = %{version}-%{release}
|
||||
Requires: trousers >= 0.3.9 tpm-tools >= 1.3.8-6 expect bash net-tools gnutls-utils
|
||||
# trousers: for tss account
|
||||
Requires: trousers >= 0.3.9 bash gnutls-utils python3 python3-cryptography
|
||||
|
||||
%description tools
|
||||
Tools for the TPM emulator from the swtpm package
|
||||
@ -165,9 +167,15 @@ fi
|
||||
%config(noreplace) %{_sysconfdir}/swtpm-localca.conf
|
||||
%dir %{_datadir}/swtpm
|
||||
%{_datadir}/swtpm/swtpm-localca
|
||||
%attr( 755, tss, tss) %{_localstatedir}/lib/swtpm-localca
|
||||
%{_datadir}/swtpm/swtpm-create-user-config-files
|
||||
%{python3_sitelib}/py_swtpm_setup/*
|
||||
%{python3_sitelib}/swtpm_setup-*/*
|
||||
%attr( 750, tss, root) %{_localstatedir}/lib/swtpm-localca
|
||||
|
||||
%changelog
|
||||
* Fri Aug 28 2020 Stefan Berger <stefanb@linux.ibm.com> - 0.4.0-1.20200828git0c238a2
|
||||
- Update to v0.4.0 release
|
||||
|
||||
* Thu Aug 27 2020 Stefan Berger <stefanb@linux.ibm.com> - 0.3.4-2.20200711git80f0418
|
||||
- Disable pkcs11 related test case running into GnuTLS locking bug
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user