diff --git a/.gitignore b/.gitignore
index 8efdb91..53ba4d4 100644
--- a/.gitignore
+++ b/.gitignore
@@ -28,3 +28,4 @@
 /swtpm-f2268ee.tar.gz
 /swtpm-2ae7b01.tar.gz
 /0001-swtpm_setup-Initialized-argv-to-NULL-Fedore-Rawhide.patch
+/swtpm-d2849a9.tar.gz
diff --git a/0001-swtpm_setup-Initialized-argv-to-NULL-Fedore-Rawhide.patch b/0001-swtpm_setup-Initialized-argv-to-NULL-Fedore-Rawhide.patch
deleted file mode 100644
index efc0b27..0000000
--- a/0001-swtpm_setup-Initialized-argv-to-NULL-Fedore-Rawhide.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-From 5b8c9d205a59932ce4e1894dbf09f5df4cfbb907 Mon Sep 17 00:00:00 2001
-From: Stefan Berger <stefanb@linux.ibm.com>
-Date: Thu, 10 Nov 2022 14:20:53 -0500
-Subject: [PATCH] swtpm_setup: Initialized **argv to NULL (Fedore Rawhide)
-
-gcc 12.2.1 on Fedora Rawhide emits this message:
-
-In file included from /usr/include/glib-2.0/glib.h:116,
-                 from swtpm_setup.c:26:
-In function 'g_autoptr_cleanup_generic_gfree',
-    inlined from 'get_swtpm_capabilities.constprop.0' at swtpm_setup.c:940:24:
-/usr/include/glib-2.0/glib/glib-autocleanups.h:30:3: error: 'argv' may be used uninitialized [-Werror=maybe-uninitialized]
-   30 |   g_free (*pp);
-      |   ^~~~~~~~~~~~
-swtpm_setup.c: In function 'get_swtpm_capabilities.constprop.0':
-swtpm_setup.c:940:24: note: 'argv' was declared here
-  940 |     g_autofree gchar **argv;
-      |                        ^~~~
-cc1: all warnings being treated as errors
-
-This makes little sense since the variable is then first used like this:
-
-    argv = concat_arrays(swtpm_prg_l, my_argv, FALSE);
-
-Signed-off-by: Stefan Berger <stefanb@linux.ibm.com>
----
- src/swtpm_setup/swtpm_setup.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/swtpm_setup/swtpm_setup.c b/src/swtpm_setup/swtpm_setup.c
-index 1b528c8..3570235 100644
---- a/src/swtpm_setup/swtpm_setup.c
-+++ b/src/swtpm_setup/swtpm_setup.c
-@@ -937,7 +937,7 @@ static int get_swtpm_capabilities(gchar **swtpm_prg_l, gboolean is_tpm2,
-     gchar *my_argv[] = { "--print-capabilities", is_tpm2 ? "--tpm2" : NULL, NULL };
-     g_autofree gchar *logop = NULL;
-     g_autoptr(GError) error = NULL;
--    g_autofree gchar **argv;
-+    g_autofree gchar **argv = NULL;
-     int exit_status = 0;
-     gboolean success;
-     int ret = 1;
--- 
-2.38.0
-
diff --git a/sources b/sources
index 21724dd..d952d58 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (swtpm-2ae7b01.tar.gz) = 3ca7e8af0b100ef66b416d34f5209cb7ac7f27c4805d24ada15aef2aa895bc7240323252e693b4bbcb47fcd19ce6f6b962b762685b49c7bfd8c1afcabe64b639
+SHA512 (swtpm-d2849a9.tar.gz) = a21f8e0db2cf215b1473a5ddb2afa0fde8313509ae9c5272deb63c32642bb7ec4a9baf9a08e46222c77a645b435f52eeec7e449e6b522643ffc3d2c9140daeb1
diff --git a/swtpm.spec b/swtpm.spec
index a2c4b6b..3e6f646 100644
--- a/swtpm.spec
+++ b/swtpm.spec
@@ -1,7 +1,7 @@
 %bcond_without gnutls
 
-%global gitdate     20221110
-%global gitcommit   2ae7b019370760e17f4f2675195a91ca53950eda
+%global gitdate     20230815
+%global gitcommit   d2849a9f5ced70438d67036693438344b47b4161
 %global gitshortcommit  %(c=%{gitcommit}; echo ${c:0:7})
 
 # Macros needed by SELinux
@@ -11,14 +11,12 @@
 
 Summary: TPM Emulator
 Name:           swtpm
-Version:        0.8.0
-Release:        7%{?dist}
+Version:        0.8.1
+Release:        1%{?dist}
 License:        BSD-3-Clause
 Url:            http://github.com/stefanberger/swtpm
 Source0:        %{url}/archive/%{gitcommit}/%{name}-%{gitshortcommit}.tar.gz
 
-Patch0001:	0001-swtpm_setup-Initialized-argv-to-NULL-Fedore-Rawhide.patch
-
 BuildRequires: make
 BuildRequires:  git-core
 BuildRequires:  automake
@@ -197,6 +195,9 @@ fi
 %{_datadir}/swtpm/swtpm-create-tpmca
 
 %changelog
+* Tue Aug 15 2023 Stefan Berger <stefanb@linux.ibm.com> - 0.8.1-1
+- Update to v0.8.1 release
+
 * Sat Jul 22 2023 Adam Williamson <awilliam@redhat.com> - 0.8.0-7
 - Make swtpm-selinux Requires(post) swtpm (#2223276)