Import switchboard-plug-keyboard-2.7.0-3.el9
This commit is contained in:
commit
6727c41202
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
|||||||
|
SOURCES/switchboard-plug-keyboard-2.7.0.tar.gz
|
1
.switchboard-plug-keyboard.metadata
Normal file
1
.switchboard-plug-keyboard.metadata
Normal file
@ -0,0 +1 @@
|
|||||||
|
88d0197b560c31668d757774506b08c4291a4c3e SOURCES/switchboard-plug-keyboard-2.7.0.tar.gz
|
32
SOURCES/6ebd576.patch
Normal file
32
SOURCES/6ebd576.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
From 6ebd57673b45cc64e1caf895134efc0d5f6cf2be Mon Sep 17 00:00:00 2001
|
||||||
|
From: =?UTF-8?q?Danielle=20For=C3=A9?= <daniel@elementary.io>
|
||||||
|
Date: Sat, 23 Apr 2022 15:34:16 -0700
|
||||||
|
Subject: [PATCH] Read screenshot shortcuts from gala schema (#407)
|
||||||
|
|
||||||
|
---
|
||||||
|
src/Shortcuts/List.vala | 12 ++++++------
|
||||||
|
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/Shortcuts/List.vala b/src/Shortcuts/List.vala
|
||||||
|
index 34a518c9..4d534a16 100644
|
||||||
|
--- a/src/Shortcuts/List.vala
|
||||||
|
+++ b/src/Shortcuts/List.vala
|
||||||
|
@@ -96,12 +96,12 @@ namespace Pantheon.Keyboard.Shortcuts {
|
||||||
|
screenshot_group = {};
|
||||||
|
screenshot_group.icon_name = "io.elementary.switchboard.keyboard.screenshots";
|
||||||
|
screenshot_group.label = _("Screenshots");
|
||||||
|
- add_action (ref screenshot_group, Schema.MEDIA, _("Grab the whole screen"), "screenshot");
|
||||||
|
- add_action (ref screenshot_group, Schema.MEDIA, _("Copy the whole screen to clipboard"), "screenshot-clip");
|
||||||
|
- add_action (ref screenshot_group, Schema.MEDIA, _("Grab the current window"), "window-screenshot");
|
||||||
|
- add_action (ref screenshot_group, Schema.MEDIA, _("Copy the current window to clipboard"), "window-screenshot-clip");
|
||||||
|
- add_action (ref screenshot_group, Schema.MEDIA, _("Select an area to grab"), "area-screenshot");
|
||||||
|
- add_action (ref screenshot_group, Schema.MEDIA, _("Copy an area to clipboard"), "area-screenshot-clip");
|
||||||
|
+ add_action (ref screenshot_group, Schema.GALA, _("Grab the whole screen"), "screenshot");
|
||||||
|
+ add_action (ref screenshot_group, Schema.GALA, _("Copy the whole screen to clipboard"), "screenshot-clip");
|
||||||
|
+ add_action (ref screenshot_group, Schema.GALA, _("Grab the current window"), "window-screenshot");
|
||||||
|
+ add_action (ref screenshot_group, Schema.GALA, _("Copy the current window to clipboard"), "window-screenshot-clip");
|
||||||
|
+ add_action (ref screenshot_group, Schema.GALA, _("Select an area to grab"), "area-screenshot");
|
||||||
|
+ add_action (ref screenshot_group, Schema.GALA, _("Copy an area to clipboard"), "area-screenshot-clip");
|
||||||
|
|
||||||
|
launchers_group = {};
|
||||||
|
launchers_group.icon_name = "preferences-desktop-applications";
|
193
SPECS/switchboard-plug-keyboard.spec
Normal file
193
SPECS/switchboard-plug-keyboard.spec
Normal file
@ -0,0 +1,193 @@
|
|||||||
|
## START: Set by rpmautospec
|
||||||
|
## (rpmautospec version 0.2.6)
|
||||||
|
%define autorelease(e:s:pb:) %{?-p:0.}%{lua:
|
||||||
|
release_number = 3;
|
||||||
|
base_release_number = tonumber(rpm.expand("%{?-b*}%{!?-b:1}"));
|
||||||
|
print(release_number + base_release_number - 1);
|
||||||
|
}%{?-e:.%{-e*}}%{?-s:.%{-s*}}%{?dist}
|
||||||
|
## END: Set by rpmautospec
|
||||||
|
|
||||||
|
%global __provides_exclude_from ^%{_libdir}/switchboard/.*\\.so$
|
||||||
|
|
||||||
|
%global srcname switchboard-plug-keyboard
|
||||||
|
|
||||||
|
%global plug_type hardware
|
||||||
|
%global plug_name keyboard
|
||||||
|
%global plug_rdnn io.elementary.switchboard.keyboard
|
||||||
|
|
||||||
|
Name: switchboard-plug-keyboard
|
||||||
|
Summary: Switchboard Keyboard plug
|
||||||
|
Version: 2.7.0
|
||||||
|
Release: %autorelease
|
||||||
|
License: GPLv3+
|
||||||
|
|
||||||
|
URL: https://github.com/elementary/switchboard-plug-keyboard
|
||||||
|
Source0: %{url}/archive/%{version}/%{srcname}-%{version}.tar.gz
|
||||||
|
|
||||||
|
# upstream patch to support screenshot keyboard shortcut changes in gala
|
||||||
|
Patch: %{url}/commit/6ebd576.patch
|
||||||
|
|
||||||
|
BuildRequires: gettext
|
||||||
|
BuildRequires: libappstream-glib
|
||||||
|
BuildRequires: meson
|
||||||
|
BuildRequires: vala >= 0.22.0
|
||||||
|
|
||||||
|
BuildRequires: pkgconfig(glib-2.0) >= 2.32
|
||||||
|
BuildRequires: pkgconfig(granite) >= 6.0.0
|
||||||
|
BuildRequires: pkgconfig(gtk+-3.0)
|
||||||
|
BuildRequires: pkgconfig(ibus-1.0) >= 1.5.19
|
||||||
|
BuildRequires: pkgconfig(libgnomekbd)
|
||||||
|
BuildRequires: pkgconfig(libgnomekbdui)
|
||||||
|
BuildRequires: pkgconfig(libhandy-1) >= 0.90.0
|
||||||
|
BuildRequires: pkgconfig(switchboard-2.0)
|
||||||
|
BuildRequires: pkgconfig(xkeyboard-config)
|
||||||
|
|
||||||
|
Requires: gala
|
||||||
|
Requires: switchboard%{?_isa}
|
||||||
|
Supplements: switchboard%{?_isa}
|
||||||
|
|
||||||
|
%description
|
||||||
|
This plug can be used to change several keyboard settings, for example
|
||||||
|
the delay and speed of the key repetition, or the cursor blinking speed.
|
||||||
|
You can change your keyboard layout, and use multiple layouts at the
|
||||||
|
same time. Keyboard shortcuts are also part of this plug.
|
||||||
|
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%autosetup -n %{srcname}-%{version} -p1
|
||||||
|
|
||||||
|
|
||||||
|
%build
|
||||||
|
%meson
|
||||||
|
%meson_build
|
||||||
|
|
||||||
|
|
||||||
|
%install
|
||||||
|
%meson_install
|
||||||
|
|
||||||
|
%find_lang %{plug_name}-plug
|
||||||
|
|
||||||
|
|
||||||
|
%check
|
||||||
|
appstream-util validate-relax --nonet \
|
||||||
|
%{buildroot}/%{_datadir}/metainfo/%{plug_rdnn}.appdata.xml
|
||||||
|
|
||||||
|
|
||||||
|
%files -f %{plug_name}-plug.lang
|
||||||
|
%doc README.md
|
||||||
|
%license COPYING
|
||||||
|
|
||||||
|
%{_libdir}/switchboard/%{plug_type}/lib%{plug_name}.so
|
||||||
|
|
||||||
|
%{_datadir}/metainfo/%{plug_rdnn}.appdata.xml
|
||||||
|
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Sat Jul 30 2022 Fabio Valentini <decathorpe@gmail.com> 2.7.0-3
|
||||||
|
- Include patch to support screenshot keyboard shortcut changes in gala
|
||||||
|
|
||||||
|
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> 2.7.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 07 2022 Fabio Valentini <decathorpe@gmail.com> 2.7.0-1
|
||||||
|
- Update to version 2.7.0; Fixes RHBZ#2072873
|
||||||
|
|
||||||
|
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> 2.6.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Nov 24 2021 Fabio Valentini <decathorpe@gmail.com> 2.6.0-1
|
||||||
|
- Update to version 2.6.0; Fixes RHBZ#2026174
|
||||||
|
|
||||||
|
* Tue Sep 28 2021 Fabio Valentini <decathorpe@gmail.com> 2.5.1-1
|
||||||
|
- Update to version 2.5.1; Fixes RHBZ#2007184
|
||||||
|
|
||||||
|
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> 2.5.0-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 15 2021 Fabio Valentini <decathorpe@gmail.com> 2.5.0-1
|
||||||
|
- Update to version 2.5.0; Fixes RHBZ#1982517
|
||||||
|
|
||||||
|
* Fri Feb 19 2021 Fabio Valentini <decathorpe@gmail.com> - 2.4.1-4.20210218git2c6b20e
|
||||||
|
- Bump to commit 2c6b20e. Rebuilt for granite 6 soname bump.
|
||||||
|
|
||||||
|
* Wed Jan 27 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.4.1-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Oct 24 2020 Fabio Valentini <decathorpe@gmail.com> - 2.4.1-2
|
||||||
|
- Add dependency on gala (plug uses gala GSettings keys).
|
||||||
|
|
||||||
|
* Fri Sep 04 2020 Fabio Valentini <decathorpe@gmail.com> - 2.4.1-1
|
||||||
|
- Update to version 2.4.1.
|
||||||
|
|
||||||
|
* Wed Aug 12 2020 Fabio Valentini <decathorpe@gmail.com> - 2.4.0-1
|
||||||
|
- Update to version 2.4.0.
|
||||||
|
|
||||||
|
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.6-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Apr 02 2020 Fabio Valentini <decathorpe@gmail.com> - 2.3.6-1
|
||||||
|
- Update to version 2.3.6.
|
||||||
|
|
||||||
|
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Aug 03 2019 Fabio Valentini <decathorpe@gmail.com> - 2.3.5-3
|
||||||
|
- Add upstream patch to fix FTBFS with vala 0.45+.
|
||||||
|
|
||||||
|
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.5-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Mar 06 2019 Fabio Valentini <decathorpe@gmail.com> - 2.3.5-1
|
||||||
|
- Update to version 2.3.5.
|
||||||
|
|
||||||
|
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 2.3.4-2
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Oct 19 2018 Fabio Valentini <decathorpe@gmail.com> - 2.3.4-1
|
||||||
|
- Update to version 2.3.4.
|
||||||
|
|
||||||
|
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.3-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Jun 13 2018 Fabio Valentini <decathorpe@gmail.com> - 0.3.3-2
|
||||||
|
- Rebuild for granite5 soname bump.
|
||||||
|
|
||||||
|
* Fri Jun 08 2018 Fabio Valentini <decathorpe@gmail.com> - 0.3.3-1
|
||||||
|
- Update to version 0.3.3.
|
||||||
|
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-7
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Feb 05 2018 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-6
|
||||||
|
- Clean up .spec file.
|
||||||
|
|
||||||
|
* Sat Nov 04 2017 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-5
|
||||||
|
- Rebuild for granite soname bump.
|
||||||
|
|
||||||
|
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-4
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.3.2-3
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu May 18 2017 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-2
|
||||||
|
- Add upstream patch to fix compilation with vala 0.35+.
|
||||||
|
|
||||||
|
* Tue Feb 07 2017 Fabio Valentini <decathorpe@gmail.com> - 0.3.2-1
|
||||||
|
- Update to version 0.3.2.
|
||||||
|
|
||||||
|
* Sun Feb 05 2017 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-2
|
||||||
|
- Clean up spec file.
|
||||||
|
|
||||||
|
* Thu Dec 08 2016 Fabio Valentini <decathorpe@gmail.com> - 0.3.1-1
|
||||||
|
- Update to version 0.3.1.
|
||||||
|
|
||||||
|
* Thu Sep 29 2016 Fabio Valentini <decathorpe@gmail.com> - 0.3-3
|
||||||
|
- Mass rebuild.
|
||||||
|
|
||||||
|
* Mon Sep 19 2016 Fabio Valentini <decathorpe@gmail.com> - 0.3-2
|
||||||
|
- Spec file cosmetics.
|
||||||
|
|
||||||
|
* Mon Aug 22 2016 Fabio Valentini <decathorpe@gmail.com> - 0.3-1
|
||||||
|
- Update to version 0.3.
|
||||||
|
|
Loading…
Reference in New Issue
Block a user